LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-09-2007, 10:38 PM   #1
linuxcrazyguy
LQ Newbie
 
Registered: Mar 2007
Posts: 28

Rep: Reputation: 15
configuring util-linux-2.12r


I have no idea what to do because all of the things it wants is what I have
eg.

Does anyone know why configure thinks I don't have anything when I have it all?

I have all of them eg. scsi.h is from libc6-dev:

/usr/include/scsi/scsi.h
/usr/include/linux/blkpg.h

Quote:
configuring util-linux-2.12r

You don't have <scsi/scsi.h>
You don't have <linux/blkpg.h>
You don't have <linux/kd.h>
You don't have <locale.h>
You don't have <langinfo.h>
You don't have <sys/user.h>
You don't have <asm/page.h>
You don't have <uuid/uuid.h>
You don't have <rpcsvc/nfs_prot.h>
You don't have <asm/types.h>
You don't have <linux/raw.h>
You don't have <stdint.h>
You don't have <sys/io.h>
You don't have inet_aton()
You don't have fsync()
You don't have getdomainname()
You don't have nanosleep()
You don't have personality()
You don't have updwtmp()
You don't have fseeko()
You don't have lchown()
You don't have rpmatch()
You don't have <term.h>
You don't have ncurses - I will not make ul and setterm.
You don't have termcap - I will not make more.
You need -lcrypt
Strange... Static compilation fails here.
You don't have native language support
You don't have __progname
You don't have <pty.h> and openpty()
You don't have wide character support
You don't have SYS_pivot_root
You don't have a tm_gmtoff field in struct tm
Your rpcgen output does not compile - using pregenerated code
You don't have zlib
You don't have blkid

Last edited by linuxcrazyguy; 04-09-2007 at 10:49 PM.
 
Old 04-09-2007, 10:55 PM   #2
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Rep: Reputation: 31
If you're running Debian it's already install.

david@debian:~$ apt-cache policy util-linux
util-linux:
Installed: 2.12r-19
Candidate: 2.12r-19
Version table:
*** 2.12r-19 0
500 http://ftp.debian.org sid/main Packages
100 /var/lib/dpkg/status
 
Old 04-09-2007, 11:21 PM   #3
linuxcrazyguy
LQ Newbie
 
Registered: Mar 2007
Posts: 28

Original Poster
Rep: Reputation: 15
Thanks Jackie but I need to compile it myself.

Does anyone have the answer to the configure problem?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
util-linux-2.12r error on 'make -C mount mount umount' james penguin Linux From Scratch 2 08-28-2006 11:55 PM
java.util.*; in Linux? vmlinuz.gz Programming 3 04-05-2006 02:26 PM
Problem compiling util-linux buboleck Slackware 0 12-21-2003 06:41 AM
util-linux cannot find any headers emu_123 Linux From Scratch 3 11-05-2003 04:19 AM
How do I install util-linux-2.10o rdaves@earthlink.net Linux - Newbie 1 05-27-2001 09:28 AM


All times are GMT -5. The time now is 09:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration