LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   computer turns on itself!? (http://www.linuxquestions.org/questions/debian-26/computer-turns-on-itself-882976/)

qrange 05-27-2011 01:56 AM

computer turns on itself!?
 
After exactly 2 hours of being shutdown, computer turns on by itself!

OS is Debian testing amd64.
2 hours is the exact same time that its set to go into standby after inactivity.

I mean, what the hell? has skynet already became operational or something?

druuna 05-27-2011 02:20 AM

Hi,

First thing that comes to mind: Do you have WOL (Wake-up On Lan) activated?

This is activated in your BIOS and your distro should be able to act on the trigger it recieves.

Hope this helps.

Have a look here: Debian - WOL

qrange 05-27-2011 02:36 AM

no, I have already disabled it and all other such things in BIOS. except turning on by keyboard.
why would it always wakeup after 2 hours?

gradinaruvasile 05-27-2011 03:17 AM

Quote:

Originally Posted by qrange (Post 4368342)
no, I have already disabled it and all other such things in BIOS. except turning on by keyboard.
why would it always wakeup after 2 hours?

Do you have on by mouse? It happened to me when i had on by mouse/keyboard and my computer started randomly. Turns out the culprit was the mouse emitting movement events.

16pide 05-27-2011 03:26 AM

Quote:

2 hours is the exact same time that its set to go into standby after inactivity
to be sure this is the culprit, can you try changing that setting to for example 30 minutes, and see if your PC now wakes up after 30 minutes.
I had a similar problem under windows. it was set to hibernate after a certain time, and it would wake up from suspend mode to hibernate. Not great when this happens in the middle of the night!!!
I also had another problem under windows, it would wake up at 3am to do software updates.

Anyway, let us know if changing that 2 hour setting changes something so that we know this is where we should focus.

maury0324 06-09-2011 10:41 AM

Going way back in my memory I remember fixing a couple of problems like that, It was caused by an issue in the power supplys. It happened in a low end E-machine and a Small 486 HP. Do some Google searching to see if you find something on your system. Good Luck. Maury

qrange 07-11-2011 10:05 AM

it seems this has been solved by changing hardware clock to local instead of UTC.
(by editing the file /etc/default/rcS, changing the variable UTC to no).

I believe windows would move the hardware clock by 2 hours and that somehow made linux turn on the computer.


All times are GMT -5. The time now is 04:45 AM.