LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 03-03-2008, 11:54 PM   #1
Mr. Swillis
Member
 
Registered: Sep 2005
Distribution: Arch
Posts: 94

Rep: Reputation: 16
Compiz Title Bar Weirdness


Alright, I have this strange issue (running Compiz on Debian Lenny, GeForce 6800 GT) where the title bar just acts... "flaky". It's hard to explain, but I've seen several Ubuntu threads on this from 2007 that were never resolved.

If I am sitting totally still, the menu bar is fine. But on mouseover and window movement, the buttons (upper right hand corner) will flicker, the whole title bar will flicker, or the whole title bar will disappear. I also get this strange artifact in the upper right hand corner of the Desktop (by the Application menu) after being logged in for a certain period of time.

I have run Ubuntu and Mint (7.10/Daryna) with the default Compiz setup with no problems on this same computer. I know this issue is hard to explain and you may not know exactly what I am talking about if you haven't experienced it, but I also know that many of you have experienced this same thing. Has anyone found a fix for this?

Here's my xorg.conf:

Code:
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "Extensions"
        Option "Composite" "enable"
EndSection

Section "Device"
	Identifier	"nVidia Corporation NV40 [GeForce 6800 GT]"
	Driver		"nvidia"
	BusID		"PCI:1:0:0"
        #Option 		"XAANoOffscreenPixmaps" "true"
        Option          "AllowGLXWithComposite" "true"
        #Option          "TripleBuffer"          "true"
        #Option   	"AIGLX"   		"true"
        Option 		"AddARGBGLXVisuals" "True"
EndSection

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
	HorizSync	30-100
	VertRefresh	50-160
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"nVidia Corporation NV40 [GeForce 6800 GT]"
	Monitor		"Generic Monitor"
	DefaultDepth	24
        #Option 		"AddARGBGLXVisuals" "True"
	SubSection "Display"
		Modes		"1440x900"
	EndSubSection
EndSection

Section "Module"
        #Load "dri"
        #Load "GLcore"
        #Load "dbe"
        Load "glx"
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection
 
Old 03-06-2008, 12:31 PM   #2
cjcox
Member
 
Registered: Jun 2004
Posts: 305

Rep: Reputation: 42
Many others have reported the same or similar problem. I don't know of a fix. I'm using an Nvidia card (nvidia glx) and I use the KDE decorator. I'm running a relatively new compiz-fusion.
 
Old 03-12-2008, 02:05 PM   #3
Mr. Swillis
Member
 
Registered: Sep 2005
Distribution: Arch
Posts: 94

Original Poster
Rep: Reputation: 16
I've done some further testing and been able to reproduced this across distributions (though all debian based). I even had it happen while using compiz in XFCE, so it's not a direct Gnome issue. I've tried different versions of Nvidia drivers (debian packages AND the regular nvidia installer), different xorg.conf options, etc and still have the same issues. I even tried different versions of Compiz.

The only real lead I have gotten on this is that it seems to pick on certain window themes. It really doesn't play well with Industrial, and I got it to flake out on a couple of other ones, but I did manage to get the behavior to go away when using the "tish" (look like Mac) window themes.

Based on this, we might be looking at some kind of GTK theming issue. I'll have to look into the guts of the tish themes and compare to industrial to see if there is anything that stands out. I'll be sure to update this post if I get a true answer, as it seems to be unanswered everywhere.

Swill
 
Old 03-21-2008, 08:35 AM   #4
tapan_chugh
LQ Newbie
 
Registered: Dec 2007
Distribution: Ubuntu 9.10 , Fedora 12
Posts: 26

Rep: Reputation: 15
I also get the same problem while using compiz-fusion.
 
Old 03-23-2008, 02:28 AM   #5
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 59
Below is my config file which works great with both Beryl and now Compiz-fusion using the same video card. I noticed you only have glx enabled in modules section.

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Thu May  3 16:02:56 PDT 2007

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "Synaptics Touchpad"
EndSection

Section "Files"

	# path to defoma fonts
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/usr/X11R6/lib/X11/fonts/misc"
    FontPath        "/usr/share/fonts/X11/cyrillic"
    FontPath        "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath        "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath        "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/Type1"
    FontPath        "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath        "/usr/share/fonts/X11/100dpi"
    FontPath        "/usr/X11R6/lib/X11/fonts/100dpi"
    FontPath        "/usr/share/fonts/X11/75dpi"
    FontPath        "/usr/X11R6/lib/X11/fonts/75dpi"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load           "bitmap"
    Load           "dbe"
    Load           "ddc"
    Load	   "evdev"
    Load           "extmod"
    Load           "freetype"
    Load           "int10"
    Load           "record"
    Load           "vbe"
    Load           "glx"
    Load           "vbe"
    Load           "type1"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc104"
    Option         "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ImPS/2"
    Option         "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
    Identifier     "Synaptics Touchpad"
    Driver         "synaptics"
    Option         "SendCoreEvents" "true"
    Option         "Device" "/dev/psaux"
    Option         "Protocol" "auto-dev"
    Option         "HorizScrollDelta" "0"
EndSection

Section "Monitor"
    Identifier     "Generic"
    HorizSync       30.0 - 70.0
    VertRefresh     50.0 - 160.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "NVIDIA GeForce 6800"
    Driver         "nvidia"
    Option         "XAANoOffscreenPixmaps" "true"
    Option         "AllowGLXWithComposite" "true"
    Option         "TripleBuffer" "true"
    Option         "DisableGLXRootClipping" "True"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "NVIDIA GeForce 6800"
    Monitor        "Generic"
    Option         "AddARGBGLXVisuals" "true"
    DefaultDepth    24
    SubSection     "Display"
        Depth       1
        Modes      "1920x1440"
    EndSubSection
    SubSection     "Display"
        Depth       4
        Modes      "1920x1440"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1920x1440"
    EndSubSection
    SubSection     "Display"
        Depth       15
        Modes      "1920x1440"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1920x1440"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1920x1440"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection
 
Old 03-29-2008, 05:29 PM   #6
Mr. Swillis
Member
 
Registered: Sep 2005
Distribution: Arch
Posts: 94

Original Poster
Rep: Reputation: 16
Alright, I've narrowed this down a bit more since I first posted. This definitely isn't distro or X specific, as I have now replicated on Debian, Ubuntu, Mint, AND Fedora all with default X settings after installing Nvidia drivers. Fedora is the important note, as it is the first non-Debian system I have noticed it on.

After a bit of tinkering and just general awareness, I have found that certain themes don't have the problem. The Tango and Tish themes seem to get along really well, where as older themes like Industrial experience lots of "flicker". The big thing that I just noticed was that this seems to also be application specific. I've only been able to reproduce this on purpose with Firefox and other gecko web browsers like Epiphany.

I'll post more updates as I pinpoint this a bit more...


Swill
 
Old 05-02-2008, 07:25 PM   #7
Mr. Swillis
Member
 
Registered: Sep 2005
Distribution: Arch
Posts: 94

Original Poster
Rep: Reputation: 16
Ok, I've done some more testing and this definitely seems to be an issue with Gecko and Compiz not playing together nicely. I have now confirmed that the "flickering" when rolling the mouse over the window buttons (repeatedly) is happening with the following applications:

Firefox
KompoZer
Epiphany
OpenOffice write (haven't tested other office apps)

All of these have gecko in common, so I'm pretty sure I'm on to something here. Can anyone else reproduce this? I've done it so far on 4 distros consistently, but I've quit paying attention to which versions of compiz, nvidia, etc are being used. It doesn't really seem to matter as I'm sure it's not the exact same version in Debian Testing (5/1/2008 build), Fedora 8, Ubuntu 7.10, and Mint 4.0. Actually Mint and Ubuntu would likely be the same, but having the non-deb Fedora example I think seals the deal that this is not distro/version specific.

If anyone has an example where you can roll the mouse of the Window Buttons repeatedly of any of the mentioned application WITHOUT flicker...please update this thread with your system details.

Thanks!

Swill
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No title-bar in kubuntu with compiz fusion and emerald Etheris Linux - Desktop 5 03-07-2008 09:48 AM
F8 compiz: window title bar covered by gnome-panel Kropotkin Fedora 2 11-13-2007 06:19 AM
Corrupted Title Bar quakintuna Linux - Desktop 0 11-28-2006 05:32 PM
Konsole title bar LocoMojo Linux - Software 2 01-22-2006 10:02 AM
Title bar font qtrob Linux - Software 3 03-31-2005 06:27 PM


All times are GMT -5. The time now is 06:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration