LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 01-11-2006, 02:07 PM   #1
cheema
Member
 
Registered: Oct 2003
Distribution: Debian Sarge
Posts: 50

Rep: Reputation: 15
Colours in Xterm, Xmms and mounting issues


Hi,
I recently installed my first debian, sarge. And I had to fight every step of the way, since I was used to suse and mandrake. Well my system is up and running but these are some of the problems that are irking me the most.

1. Xterm does not display colours. So all the display is in black and white while I was used to the colorful displays in Mandrake. Even vim does not show any colours while opening files. I've tried tweaking .Xresources, .Xdefaults,app-defaults/XTerm and app-defaults/XTerm-color files but nothing helps. Can somebody tell me the exact solution?

2. Non-root user cannot access the soundcard correctly. While running xmms as root I can get the sound, but when non-privileged used tries running xmms I get an error saying that "sound card is either blocked or not configured properly". What is the reason?

3. Non-root user cannot write to a mounted FAT drive. Here is the fstab snippet:

/dev/hda7 /mnt/win_d vfat defaults,user 0 0
/dev/hdb8 /mnt/win_z vfat defaults,user 0 0

4. I have some ISO images residing on FAT drive which I want to mount automatically at boot time. Ofcourse I can mount them manually later but I want them mounted at the boot time. The following code from /etc/fstab does not work:
/mnt/win_z/gsck/gsdke.iso /mnt/gda1 iso9660 defaults,user 0 0

5. And finally can somebody tell me how to install "xview" on debian? Apt-get cannot find any package with the name "xview".

Thnx for any help
 
Old 01-11-2006, 02:58 PM   #2
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
1. I think the option is in .bashrc, /etc/profile, or .bash_profile (I got this to work once a long time ago and have since forgotten -- try google)

2. Add your user to the "audio" group. That worked on my system anyway.

3. Make sure your user is part of the "user" group and also you might add "rw" to the fstab options

4. I think it's another option in fstab like "auto" or something like that (again google is your friend)

5. try apt-cache search xview. You probably need something like "xview-client" or the like.
 
Old 01-11-2006, 03:44 PM   #3
cheema
Member
 
Registered: Oct 2003
Distribution: Debian Sarge
Posts: 50

Original Poster
Rep: Reputation: 15
Thanx for your suggestions.

apt-cache search xview worked beautifully. Thnx a lot. As for other suggestions

1. .bashrc and others are startup scripts. What I want to know is what variables should I set? Tried googling, got confused!

2. My user is already added to the audio group. Here is the line from /etc/group
audio:x:29:cheema

I'll try your other suggestions when I'll be in a mood to reboot my machine.
 
Old 01-11-2006, 04:12 PM   #4
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
You shouldn't have to reboot, just unmount the partitions, change the fstab, and then remount the partitions.

Did a quick search and found this fstab entry for a fat32 partition:

/dev/hda3 /mnt/windows vfat defaults,user,auto,umask=000 0 0

Last edited by pljvaldez; 01-11-2006 at 04:20 PM.
 
Old 01-11-2006, 04:43 PM   #5
cheema
Member
 
Registered: Oct 2003
Distribution: Debian Sarge
Posts: 50

Original Poster
Rep: Reputation: 15
Actually the problem with the permissions on FAT disk is that, when booted, the write permissions are available only for the ROOT. When I unmount /mnt/win_d from root and mount the same directory from user "cheema" i get the full write permissions. So I just want my user "cheema" to have write permission after booting, without my manual unmounting and mounting.
 
Old 01-11-2006, 07:06 PM   #6
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
My guess is that the "umask" option may help you out, but I guess I don't really know for sure...
 
Old 01-11-2006, 07:48 PM   #7
leamassiot
Member
 
Registered: Dec 2005
Location: France
Distribution: Debian
Posts: 123

Rep: Reputation: 17
Hi,

1. Colours

-- Xterm colours:

In my ~/.bashrc, I have the following lines uncommented:
Code:
# enable color support of ls and also add handy aliases
if [ "$TERM" != "dumb" ]; then
    eval "`dircolors -b`"
    alias ls='ls --color=auto'
    #alias dir='ls --color=auto --format=vertical'
    #alias vdir='ls --color=auto --format=long'
fi
-- Vim colours:

In my ~/.vimrc, I have the following line:
Code:
syntax on
(If you have no .vimrc simply do:
touch .vimrc ; echo "syntax on" > .vimrc)

4. I think it depends on the <options> column contents of the /etc/fstab file. For example, if the "noauto" option appears, the filesystem will not be mounted automatically at boot time (expl. floppy).

5. xview
Try apt-cache search xview to get the list of the packages you can install and which could match your query (xview).

Good luck.

--
Léa Massiot
 
Old 01-12-2006, 03:47 AM   #8
cheema
Member
 
Registered: Oct 2003
Distribution: Debian Sarge
Posts: 50

Original Poster
Rep: Reputation: 15
Thnx leamassiot. Sitting in office right now. Will try your suggestion once I get back home.
 
Old 01-12-2006, 04:12 AM   #9
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 53
For the color thingy you can even have a more beautiful terminal : you have the PS1 (prompt) displayed in yellow:

in my .bashrc I have this:

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
xterm-color)
PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:
\[\033[01;34m\]\w\[\033[00m\]\$ '
;;
*)
PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
;;
esac


...

I manage once to get $TERM set to xterm-color (maybe in /etc/default) but not anymore Did not really search so I made a shortcut to open a konsole and to set TERM to xterm-color
 
Old 01-12-2006, 09:10 AM   #10
cheema
Member
 
Registered: Oct 2003
Distribution: Debian Sarge
Posts: 50

Original Poster
Rep: Reputation: 15
Thnx leamassiot. Your suggestion worked.
 
Old 01-12-2006, 09:50 AM   #11
ntubski
Senior Member
 
Registered: Nov 2005
Distribution: Debian
Posts: 2,543

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Have you checked the permissions on /dev/dsp or /dev/audio?
 
Old 01-12-2006, 11:01 AM   #12
cheema
Member
 
Registered: Oct 2003
Distribution: Debian Sarge
Posts: 50

Original Poster
Rep: Reputation: 15
Here is the result of the commands

$ls -l /dev/dsp
crw-rw---- 1 root audio 14, 3 2005-02-26 12:09 /dev/dsp
$ls -l /dev/audio
crw-rw---- 1 root audio 14, 4 2005-02-26 12:09 /dev/audio

And I'm added to the audio group. Here is the line from /etc/group
audio:x:29:cheema

So I guess its not the issue with permissions.
 
Old 01-12-2006, 11:31 AM   #13
cheema
Member
 
Registered: Oct 2003
Distribution: Debian Sarge
Posts: 50

Original Poster
Rep: Reputation: 15
So after 4 days of configuring, my first debian is left with just one major irritant . My soundcard does not seem to work for non-root users. I checked the permissions and the audio group but got no clues. I'm attaching the output xmms gives when run by non-privileged user.

** WARNING **: oss_open(): Failed to open audio device (/dev/dsp): Permission denied

Looks like some other application is using the soundcard. How can I check?
 
Old 01-12-2006, 03:58 PM   #14
leamassiot
Member
 
Registered: Dec 2005
Location: France
Distribution: Debian
Posts: 123

Rep: Reputation: 17
xine

Hello,

Well, I had never tried before to know whether my soundcard worked or not under my Debian system. So I did the following thing:

$ su
root_password
$ apt-get install xine-ui
$ su lea
$ xine &

I introduced an audio CD in the player, and actually... it worked.
You could try that too.



--
Léa Massiot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New to linux, so so lost, auto mounting issues, permissions issues slowhand22 Linux - Newbie 2 02-10-2005 10:41 AM
A few issues with xterm shellcode Linux - General 2 02-01-2005 06:15 PM
Colours in directory listing and XMMS Output plugins Kristijan Linux - Newbie 3 02-22-2004 08:21 AM
Xterm Issues... enk0d Slackware 2 11-01-2003 01:53 PM
I get following output to xterm when launching xmms ... purpleburple Linux - General 11 07-26-2002 07:10 AM


All times are GMT -5. The time now is 01:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration