LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-01-2007, 03:34 PM   #1
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Rep: Reputation: 48
perl: warning: Setting locale failed. (Solution found)


I know most of you must be familiar with the following messages:
Code:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_US:en_GB:en",
        LC_ALL = (unset),
        LANG = "en_US"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
or

Code:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_US:en_GB:en",
        LC_ALL = (unset),
        LANG = "en_US"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

I have tried every possible thing that I could to get rid of these messages but I failed everytime. Once I had a similar problem with Sarge(stable) and I was able to solve the problem like this:
http://www.linuxquestions.org/questi...d.php?t=407835

but unfortunately this does not work in Etch (stable).

Can anyone please tell me how do I get rid of these errors?

I have tried:
Code:
dpkg-reconfigure locales
dpkg-reconfigure localeconf
Would really appreciate if some can help. I am using Debian Etch with 2.6.18 Kernel.

Thanks

Last edited by kushalkoolwal; 08-03-2007 at 02:21 PM.
 
Old 08-02-2007, 02:36 PM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Try installing localepurge then select the ones you want to remain on the system you should see it generating the ones you want at the end hopefully this solves it and make sure that your version of locales matches the version number of the libc6 you have installed.
 
Old 08-02-2007, 03:12 PM   #3
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
Quote:
Originally Posted by HappyTux
Try installing localepurge then select the ones you want to remain on the system you should see it generating the ones you want at the end hopefully this solves it and make sure that your version of locales matches the version number of the libc6 you have installed.
Yeah I tried generating the locales and it does generates but still the warning appears...

I think the problem might what you mentioned about the version number of locales and libc6. How do I matched those....

I recently upgraded from sarge to etch...

Thanks for your reply.
 
Old 08-02-2007, 03:38 PM   #4
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Quote:
Originally Posted by kushalkoolwal
Yeah I tried generating the locales and it does generates but still the warning appears...

I think the problem might what you mentioned about the version number of locales and libc6. How do I matched those....

I recently upgraded from sarge to etch...

Thanks for your reply.
Just use apt-cache policy libc6 locales they should have the same version numbers like below if not the same then upgrade.

Code:
apt-cache policy libc6 locales
libc6:
  Installed: 2.6-2
  Candidate: 2.6-2
  Version table:
     2.6-5 0
        600 http://ftp2.de.debian.org sid/main Packages
 *** 2.6-2 0
        990 http://ftp2.de.debian.org testing/main Packages
        100 /var/lib/dpkg/status
locales:
  Installed: 2.6-2
  Candidate: 2.6-2
  Version table:
     2.6-5 0
        600 http://ftp2.de.debian.org sid/main Packages
 *** 2.6-2 0
        990 http://ftp2.de.debian.org testing/main Packages
        100 /var/lib/dpkg/status
Since you recently upgraded make sure everything got to your etch version by using apt-get dist-upgrade or if using aptitude use whatever is the equal of that apt command with it.
 
Old 08-02-2007, 08:23 PM   #5
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
Quote:
Originally Posted by HappyTux
Just use apt-cache policy libc6 locales they should have the same version numbers like below if not the same then upgrade.

Code:
apt-cache policy libc6 locales
libc6:
  Installed: 2.6-2
  Candidate: 2.6-2
  Version table:
     2.6-5 0
        600 http://ftp2.de.debian.org sid/main Packages
 *** 2.6-2 0
        990 http://ftp2.de.debian.org testing/main Packages
        100 /var/lib/dpkg/status
locales:
  Installed: 2.6-2
  Candidate: 2.6-2
  Version table:
     2.6-5 0
        600 http://ftp2.de.debian.org sid/main Packages
 *** 2.6-2 0
        990 http://ftp2.de.debian.org testing/main Packages
        100 /var/lib/dpkg/status
Since you recently upgraded make sure everything got to your etch version by using apt-get dist-upgrade or if using aptitude use whatever is the equal of that apt command with it.

Great, Thanks I will try that. On a second note, do you know what options to give in apt-get cache policy to check for every package, whether they made into etch or not....
 
Old 08-02-2007, 09:02 PM   #6
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Quote:
Originally Posted by kushalkoolwal
Great, Thanks I will try that. On a second note, do you know what options to give in apt-get cache policy to check for every package, whether they made into etch or not....

Install apt-show-versions then apt-show-versions | grep No should get you a list every package that is not in Etch.
 
Old 08-03-2007, 02:20 PM   #7
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
Smile Solution Found!!!!!

Quote:
Originally Posted by HappyTux
Just use apt-cache policy libc6 locales they should have the same version numbers like below if not the same then upgrade.

Code:
apt-cache policy libc6 locales
libc6:
  Installed: 2.6-2
  Candidate: 2.6-2
  Version table:
     2.6-5 0
        600 http://ftp2.de.debian.org sid/main Packages
 *** 2.6-2 0
        990 http://ftp2.de.debian.org testing/main Packages
        100 /var/lib/dpkg/status
locales:
  Installed: 2.6-2
  Candidate: 2.6-2
  Version table:
     2.6-5 0
        600 http://ftp2.de.debian.org sid/main Packages
 *** 2.6-2 0
        990 http://ftp2.de.debian.org testing/main Packages
        100 /var/lib/dpkg/status
Since you recently upgraded make sure everything got to your etch version by using apt-get dist-upgrade or if using aptitude use whatever is the equal of that apt command with it.
It seems that my locales and libc6 were at the etch version i.e. the installed and candidate values were the same. But still that didn't solve the problem....

But guess what I was able to solve the problem by editing the /etc/environment manually..Here is my /etc/environment file:
Code:
LANGUAGE = en_US
LC_ALL = en_US
LANG = en_US
LC_TYPE = en_US
Also, I would recommend to run dpkg-reconfigure locales after you edit your /etc/environment file.

I hope this might be useful to anyone who has the same problem. At least it will help to save their time....at least couple of hours...
 
  


Reply

Tags
apt-get


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting locale failed godzern Linux - Software 2 10-30-2006 01:32 PM
"perl: warning: Setting locale failed." System wide problem Darek84CJ Debian 3 01-25-2006 05:22 PM
perl: warning: Please check that your locale settings: Daredevil Linux - Software 1 05-12-2005 10:47 AM
Setting locale failed linx win Debian 1 04-02-2005 09:46 AM
Setting locale failed?? calculon Linux - General 1 12-04-2001 01:01 PM


All times are GMT -5. The time now is 10:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration