LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 09-03-2012, 07:54 AM   #1
csDraco_
Member
 
Registered: Feb 2002
Location: Canada
Distribution: Fedora / CentOS
Posts: 93

Rep: Reputation: 15
Question Changing resolution


Question:
Does anyone know how to disable the default change of resolution that happens mid through the bootup process (Debian 6.0.5), or to change it to any other resolution?

Issue Overview
My default install resolution at boot up console level is not displaying properly on my HP Pavilion 6000, how do I change/setup a different resolution?

Note
Coming from Slackware it used to be a kernal parameter in LILO
Code:
ie. vga=773
But with grub2 you have to change a setup file.

What I've done so far
# modify file /etc/default/grub with:
Code:
GRUB_GFXMODE=800x600
+ run: update-grub

Making the above configuration change does work, and I do see a change in the console resolution at grub level and for the first part of the bootup process, but then something allays overwrites it, and I haven't seen any pointers in dmesg or /var/log/messages as to what is making second resolution change.

Current Distro
I'm running latest stable Debian
Code:
Description:    Debian GNU/Linux 6.0.5 (squeeze)
Release:        6.0.5
Codename:       squeeze

.. I think at this point I just need to locate the right configuration file where default 6.0.5 Debian is making a resolution change following the /etc/default/grub file in the bootup process

.. many thanks in advance
 
Old 09-03-2012, 08:01 AM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,653
Blog Entries: 2

Rep: Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097
The vga option is deprecated. You can either use the nomodeset option (which disables kernel mode setting, but also all video/2D/3D acceleration) or you specify the resolution you want to use with the video option, like this:
Code:
video=1024x768@60
This will set the resolution to 1024x768 at 60Hz refresh rate.
Both options, nomodeset and video= have to be added to the options in the quotes in line
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
in /etc/default/grub.
 
Old 09-03-2012, 08:35 AM   #3
csDraco_
Member
 
Registered: Feb 2002
Location: Canada
Distribution: Fedora / CentOS
Posts: 93

Original Poster
Rep: Reputation: 15
Lightbulb

Many thanks TobiSGD !

GRUB_CMDLINE_LINUX_DEFAULT="video=1024x768@60" in /etc/default/grub works like a charm
 
  


Reply

Tags
change, debian, grub 2, resolution


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help changing resolution bobbytaylor21 Linux - Newbie 1 10-15-2009 08:33 AM
Problem changing the video adapter setting and changing the screen resolution habiblove Linux - General 3 02-18-2006 06:10 PM
Changing resolution iandunn Slackware 10 01-10-2006 06:34 PM
Changing Resolution sethgeekx86 Slackware 5 05-08-2004 09:57 PM
Changing resolution sdpeelejr Fedora 14 04-09-2004 02:31 PM


All times are GMT -5. The time now is 06:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration