LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Changing resolution (http://www.linuxquestions.org/questions/debian-26/changing-resolution-4175425398/)

csDraco_ 09-03-2012 06:54 AM

Changing resolution
 
Question:
Does anyone know how to disable the default change of resolution that happens mid through the bootup process (Debian 6.0.5), or to change it to any other resolution?

Issue Overview
My default install resolution at boot up console level is not displaying properly on my HP Pavilion 6000, how do I change/setup a different resolution?

Note
Coming from Slackware it used to be a kernal parameter in LILO
Code:

ie. vga=773
But with grub2 you have to change a setup file.

What I've done so far
# modify file /etc/default/grub with:
Code:

GRUB_GFXMODE=800x600
+ run: update-grub

Making the above configuration change does work, and I do see a change in the console resolution at grub level and for the first part of the bootup process, but then something allays overwrites it, and I haven't seen any pointers in dmesg or /var/log/messages as to what is making second resolution change.

Current Distro
I'm running latest stable Debian
Code:

Description:    Debian GNU/Linux 6.0.5 (squeeze)
Release:        6.0.5
Codename:      squeeze


.. I think at this point I just need to locate the right configuration file where default 6.0.5 Debian is making a resolution change following the /etc/default/grub file in the bootup process

.. many thanks in advance

TobiSGD 09-03-2012 07:01 AM

The vga option is deprecated. You can either use the nomodeset option (which disables kernel mode setting, but also all video/2D/3D acceleration) or you specify the resolution you want to use with the video option, like this:
Code:

video=1024x768@60
This will set the resolution to 1024x768 at 60Hz refresh rate.
Both options, nomodeset and video= have to be added to the options in the quotes in line
Code:

GRUB_CMDLINE_LINUX_DEFAULT="quiet"
in /etc/default/grub.

csDraco_ 09-03-2012 07:35 AM

Many thanks TobiSGD !

GRUB_CMDLINE_LINUX_DEFAULT="video=1024x768@60" in /etc/default/grub works like a charm :)


All times are GMT -5. The time now is 11:45 PM.