LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 03-16-2005, 09:40 PM   #1
furtivefelon
Member
 
Registered: Dec 2004
Distribution: Fedora Core 3
Posts: 35

Rep: Reputation: 15
changing res to 1280x800?


hi, i have installed knoppix on to my hard drive, since debian installer i find too cryptic for a linux newbie.. i'm trying to setup a 1280x800 resolution (my laptop native, which is a Emachines M5410).. i'm using a SiS M760 Ultra 256 if that helps.. can someone point me to the right directions? i have already done extensive search online, and all points me to editing the XF86Config-4 file.. however, with adding to ModeLines and into Screen->Display section yield no result, i thought i'd ask here if some debian users have any similer problems and how they solve it.. thanks alot
 
Old 03-17-2005, 01:38 AM   #2
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
What is very important is getting the correct horizontal and vertical sync rates for the display which will be available either in the manual or from the manufacturer's website. The Debian method of reconfiguring the X server is done uisng the command dpkg-reconfigure xserver-xfree86. I believe that if you have done manual editing of the XF86Config-4 that this no longer works. If you get the correct values as above then you should be able to get the desired display size. I know in my own case I get better and bigger display sizes than I do with M$.
 
Old 03-17-2005, 06:35 AM   #3
doc.nice
Member
 
Registered: Oct 2004
Location: Germany
Distribution: Debian
Posts: 274

Rep: Reputation: 34
you have to add the new resolution before the other modes in the screen section:
so the line has to be:
Modes "1280x800" "1280x768" "800x600"
or whatever modes you want to use. The first *working* line is used at startup, you can cycle them using Ctrl+Num+ and Ctrl+Num-
Try using those keys to access your mode before reordering them, if you can't access it, your modeline is possibly incorrect, see /var/log/XFree86.0.log

in knoppix, there are two commands:
ddcxinfo and ddcxinfo-knoppix, you can try those with parameter -modelines, the knoppix variant gives default vesa modes if the monitor doesn't support ddc flags.

hth,
Flo
 
Old 03-17-2005, 10:43 AM   #4
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 4.0 Etch
Posts: 1,346

Rep: Reputation: 49
I have previously posted a fix here: changing resolution (not screen size)

Quote:
My prefered method is to insert a Modeline into /etc/X11/XF86Config-4, under the "Monitor" section.

Here's a 1280x800@60hz modeline generated by Colas XFree Modeline generator:

ModeLine "1280x800" 87.09 1280 1336 1616 1728 800 802 814 840 #60Hz

I'd insert this into the "Monitor" section, and then in the "Display" section I'd remove all resolutions except for "1280x800".

For KDE, this is enough to change the resolution. The next time KDE starts, it will automatically recognize that only 1280x800 is a valid resolution and will adjust itself to that resolution.

For GNOME, you may have to go into GNOME's Control Center and explicitely force it to use 1280x800.

If you post your /etc/X11/XF86Config-4, then I can show an appropriately modified version of it.

Don't forget to make a backup of your XF86Config-4 before making modifications to it!
 
Old 03-17-2005, 04:04 PM   #5
Robert G. Hays
Member
 
Registered: Jan 2003
Location: Atlanta, Ga., USA
Distribution: Gentoo, Mandrake, ~others
Posts: 157

Rep: Reputation: 30
DANGER, WILL ROBINSON !!

ModeLine blah, blah, blah

This *IS* the ultimate way to fix things, *BUT* if you give the wrong ones for your card &/or monitor, you can damge or destroy either or both.

Not every time automatically, you understand, but there *MAY* be some combinations that will do this, so Get The Data For Your Hardware before using the God-like power of ModeLine, and end up hitting the "kaboom switch", as Epson so long age phrased it. (And I still have the FX-80 & manual to prove it.)

And I like to start grub/lilo in textmode, then start linux at runlevel:3 (multi-user text, then startx to get to the gui, thus x-probs can't down the computer.

Just a couple of thoughts...

And do post that data like IsaacKuo suggested.

Luck!,
 
Old 03-17-2005, 06:24 PM   #6
doc.nice
Member
 
Registered: Oct 2004
Location: Germany
Distribution: Debian
Posts: 274

Rep: Reputation: 34
should be no prob with the above modeline, as it is created for 60Hz for use with a dfp. those can't "explode" as easyly as crts...

but keep the (generally sensible) tips of robert in mind if you start experimenting...
 
Old 04-13-2005, 02:24 PM   #7
fejes
LQ Newbie
 
Registered: Apr 2004
Location: Vancouver, Canada
Distribution: Fedora x86_64
Posts: 8

Rep: Reputation: 0
emachines M5410

I can tell you that in Ubuntu, the default Xorg.conf file uses the wrong driver.

If you switch the line that says:

Driver "vesa"

to

Driver "sis"

Then it'll use the right driver, and you can use the GUI interface to chose the right resolution. (It seems to ignore the 1200x800 option set in the xorg.conf file, and presented a full range of appropriate resolutions anyhow.)

I hope that's usefull for other people trying to get 1200x800 resolution working on M5410's.

While I'm at it, I may as well tell you that enabling the speakers on the laptop can be done through the volume control panel: Go into preferences, and enable the setting for "External Amplifier". You'll then find it visible under "switches". If you uncheck this box, (and then turn up the volume!!!!) you'll hear sound.

Cheers
 
Old 07-15-2005, 02:31 PM   #8
figfighter
Member
 
Registered: Jun 2005
Distribution: Mandriva LE 2005
Posts: 71

Rep: Reputation: 15
please give more details on switching this driver? i'm running a live version of kunbuntu right now and everything is huge! want to be sure i can adjust this before installing....

BTW i am VERY new with linux.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with res 1280x800 daguerr Linux - Laptop and Netbook 10 04-18-2005 06:43 AM
changing screen depth to 1280x800 sh4d0w331 Slackware - Installation 1 01-31-2005 08:27 PM
Changing Res in 9.2 BlankFrank Mandriva 1 02-10-2004 09:54 AM
changing res dfownz Linux - Software 1 01-31-2004 08:31 PM
changing the screen res outside X tux_rox Linux - General 1 06-25-2002 04:23 PM


All times are GMT -5. The time now is 08:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration