LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 07-04-2003, 09:00 PM   #1
andrewlkho
Member
 
Registered: Jul 2003
Location: London
Posts: 548

Rep: Reputation: 30
change console font size?


Hi,
How do I change the font size that is displayed when debian boots up?
many thanks in advance...
 
Old 07-04-2003, 10:22 PM   #2
modnar
LQ Newbie
 
Registered: Jul 2003
Distribution: Debian 3.0 & Mandrake 9.0
Posts: 1

Rep: Reputation: 0
re: console font

I'm having this exact same problem right now. let me tell you what i've discovered so far, these steps (that failed for me) may work for you.

if you are using grub, read the configuration files (man grub) and look for something like what i'm going to describe below for lilo. grub can do the same thing i just don't know exactly how.

If you are using lilo as your boot loader, just change a line in the /etc/lilo.conf file.
somewhere near the top there should be a line that says

vga=normal

or maybe `vga=extended'
change that to

vga=ask

and on boot up you will be presented with a list of modes your video supports, shown as column by row. pick the one with the biggest number, or enter `scan'. the number you pick can be inserted into the lilo.conf file easily (so you won't be prompted each time)

vga=6

or whatever number you liked best if you pick an invalid mode, you probably won't be able to read anything while it boots up. thats ok, just wait until you are certain its finished, then log in carefully (without typos since you can't see) and immediately reboot.


if this steps above don't work for you, for a reason such as all the modes presented by vga=ask are still super huge, then you may need to compile your kernel with more console support. This is happening to me right now I've just compiled the 2.4.21 kernel and the most columns and rows i can squeeze out of it are 80 and 30 respectively. This is not enough!! if X windows can display itty bitty letters in 1024x768 then why can't i get 120 columns out of my console?
anybody with advice on how to make the console font smaller, please share your wisdom (*bow*)
-modnar
 
Old 07-05-2003, 03:12 PM   #3
footfrisbee
Member
 
Registered: Apr 2003
Distribution: Debian Sarge
Posts: 259

Rep: Reputation: 30
Compile your kernel with

Console drivers -> Frame buffer support -> VESA VGA graphics console

(don't worry about all those other options, this one is pretty good). Then read /usr/src/linux/Documentation/fb/vesafb.txt and put the appropriate option in lilo.conf. !Remember to run 'lilo' after you edit lilo.conf!

For a cooler look you can replace the cool penguin this gives you a boot time with the cooler Debian swirl using kernel-patch-debianlogo

I use vga=0x305 (you'll know what this means after you read vesafb.txt). Good luck.

Last edited by footfrisbee; 07-05-2003 at 03:16 PM.
 
Old 07-05-2003, 03:43 PM   #4
andrewlkho
Member
 
Registered: Jul 2003
Location: London
Posts: 548

Original Poster
Rep: Reputation: 30
thanks for your help, both of you. i didn't need to recompile the kernel, it turned out that directly editing lilo.conf worked. thanks
 
Old 07-07-2003, 12:48 PM   #5
mdfairch
LQ Newbie
 
Registered: Jul 2003
Distribution: Redhat
Posts: 3

Rep: Reputation: 0
VGA Mode Console in Redhat 9

I'm trying to get Redhat 9 to boot in VGA Console mode (maybe a nice 80x50?). I've found instructions about adding the VGA=xxx line to my grub.conf/lilo.conf, and that all works well.

The problem is that as soon as Redhat enters RunLevel 5, the console switches back to it's vanilla 80x25 mode. I've heard that this is due to the setfont or setsysfont command. I commented out the setsysfont commands being run in etc/rc.sysinit and etc/init.d/keytable, but this hasn't helped. The console still switches back to 80x25 as soon as the "entering runlevel 5" message appears.

Does anyone know how to fix this? I did a "grep -r 'setsysfont' /etc/*", and only the two files I mentioned above came up.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Font size in console psyklops Linux - General 25 10-09-2006 12:22 PM
how 2 change font size OF chromedit? OpenMacNews Linux - Software 0 08-29-2005 10:55 AM
How to increase font size in 'rxvt' (i.e. in fluxbox console)? kornerr Linux - General 2 02-19-2005 10:07 AM
Where i can change the X font size dr_doom Linux - Software 0 04-09-2004 12:17 PM
Changing console font size frankietomatoes Linux - General 5 06-11-2003 11:31 AM


All times are GMT -5. The time now is 12:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration