LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 09-24-2012, 04:02 AM   #1
mohisn
LQ Newbie
 
Registered: Sep 2012
Posts: 5

Rep: Reputation: Disabled
change compatibility level in debian


How can i change the compatibility level in debian .Currently i am using compatibility level 4 .
 
Old 09-24-2012, 04:08 AM   #2
evo2
Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,591

Rep: Reputation: 1244Reputation: 1244Reputation: 1244Reputation: 1244Reputation: 1244Reputation: 1244Reputation: 1244Reputation: 1244Reputation: 1244
Hi,

you'll need to provide much more information about what you are actually trying to achieve.

However I guess this is related to your java problem on Ubuntu. Please see my post in that thread.

Evo2.
 
Old 09-24-2012, 06:13 AM   #3
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 457Reputation: 457Reputation: 457Reputation: 457Reputation: 457
Chapter*5.*Other files under the debian directory - http://www.debian.org/doc/manuals/ma...dother.en.html
Quote:
5.2. compat

The compat file defines the debhelper compatibility level. Currently, you should set it to the debhelper v7 as follows:

$ echo 7 > debian/compat
The point of debian/compat (was: what compat level for debhelper in jaunty?) - https://lists.ubuntu.com/archives/ub...er/005123.html

debhelper - http://man.he.net/man7/debhelper
 
Old 09-24-2012, 06:51 AM   #4
hafiznasrullah
LQ Newbie
 
Registered: Sep 2012
Posts: 9

Rep: Reputation: Disabled
i am running ubuntu 12.04 and when i enter command

fakeroot make-jpkg jdk-1_5_0_17-linux-i586.bin


The following error appears:


dh_installchangelogs: No compatibility level specified in debian/compat dh_installchangelogs: This package will soon FTBFS; time to fix it! dh_installchangelogs: Compatibility levels before 5 are deprecated (level 4 in use)

i want to change the compatibility level but i didn't find debian/compat .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No Compatibility level specified in debian/compat hafiznasrullah Linux - Server 1 10-15-2012 10:32 AM
No compatibility level specified in debian/compat mohisn Debian 4 09-24-2012 07:48 AM
No compatibility level specified in debian/compat mohisn Linux - Newbie 2 09-24-2012 03:18 AM
No compatibility level specified in debian/compat hafiznasrullah Debian 0 09-22-2012 04:15 AM


All times are GMT -5. The time now is 02:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration