-   Debian (
-   -   change compatibility level in debian (

mohisn 09-24-2012 03:02 AM

change compatibility level in debian
How can i change the compatibility level in debian .Currently i am using compatibility level 4 .

evo2 09-24-2012 03:08 AM


you'll need to provide much more information about what you are actually trying to achieve.

However I guess this is related to your java problem on Ubuntu. Please see my post in that thread.


craigevil 09-24-2012 05:13 AM

Chapter*5.*Other files under the debian directory -

5.2. compat

The compat file defines the debhelper compatibility level. Currently, you should set it to the debhelper v7 as follows:

$ echo 7 > debian/compat
The point of debian/compat (was: what compat level for debhelper in jaunty?) -

debhelper -

hafiznasrullah 09-24-2012 05:51 AM

i am running ubuntu 12.04 and when i enter command

fakeroot make-jpkg jdk-1_5_0_17-linux-i586.bin

The following error appears:

dh_installchangelogs: No compatibility level specified in debian/compat dh_installchangelogs: This package will soon FTBFS; time to fix it! dh_installchangelogs: Compatibility levels before 5 are deprecated (level 4 in use)

i want to change the compatibility level but i didn't find debian/compat .

All times are GMT -5. The time now is 07:32 PM.