LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Chaintech XGI vidoe card driver (http://www.linuxquestions.org/questions/debian-26/chaintech-xgi-vidoe-card-driver-349999/)

seashell11 08-04-2005 03:34 PM

Chaintech XGI vidoe card driver
 
I am currently running Debian Sarge with kernel 2.4.27-2-386 and I have a Chaintech XGI Volari 3 (HERE is a link to it at TigerDirect ) video card.

When I installed Debian I used the medium setting with the VGA driver when setting my monitor on XFree. I set my monitor's best resolution at 1280X1024, because that is what I wanted it to run at, but when the computer came on, it was at a 640x480 resolution with 4 bit color. Is there any way to fix this?

I tried going to XGITECH and downloading the Z7-Linux-xf86-4.4.0 1.2.9 for i386. This was an RPM file so I did the folowing:
Code:

shelwyn:/home/eastern# alien --to-deb /home/eastern/xgi_xf86_4.4.0-1.2.9-1.i386.rpm
xgi-xf86-4.4.0_1.2.9-2_i386.deb generated
shelwyn:/home/eastern# dpkg -i //home/eastern/xgi-xf86-4.4.0_1.2.9-2_i386.deb
Selecting previously deselected package xgi-xf86-4.4.0.
(Reading database ... 122964 files and directories currently installed.)
Unpacking xgi-xf86-4.4.0 (from .../xgi-xf86-4.4.0_1.2.9-2_i386.deb) ...
Setting up xgi-xf86-4.4.0 (1.2.9-2) ...
shelwyn:/home/eastern#

Then I restarted the computer, and nothing was changed. Is the driver even installed or running?

Then I went to
Code:

shelwyn:/home/eastern# nano /etc/X11/XF86Config-4
And it showed:
Code:

Section "Device"
        Identifier      "Generic Video Card"
        Driver          "vga"
EndSection

Section "Monitor"
        Identifier      "Generic Monitor"
        HorizSync      30-65
        VertRefresh    50-75
        Option          "DPMS"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "Generic Video Card"
        Monitor        "Generic Monitor"
        DefaultDepth    4
        SubSection "Display"
                Depth          1
                Modes          "640x480"
        EndSubSection
        SubSection "Display"
                Depth          4
                Modes          "640x480"
        EndSubSection
        SubSection "Display"
                Depth          8
                Modes          "640x480"
        EndSubSection
        SubSection "Display"
                Depth          15
                Modes          "640x480"
        EndSubSection
        SubSection "Display"
                Depth          16
                Modes          "640x480"
        EndSubSection
        SubSection "Display"
                Depth          24
                Modes          "640x480"
        EndSubSection
EndSection

I tried changing the depth to default depth to 24 and the resolution to 1280x1024 and I tried changin depth 4 to 1280x1024 resolution. In both cases it failed to load xserver on reboot. (I don't remember the reason's it gave)

I also tried
Code:

shelwyn:/home/eastern# dpkg-reconfigure xserver-XFree86
in advanced mode and set it so it would only run with 1280x1024 resolution with 24 bit color. On reboot it told me that driver was incapable of 24 depth, or something like that.

bp12345 08-06-2005 04:31 PM

Copy one of the:
Code:

        SubSection "Display"
                Depth          24
                Modes          "640x480"
        EndSubSection

then paste and change to
Code:

        SubSection "Display"
                Depth          24
                Modes          "1280x1024"
        EndSubSection

If you want, you can also change one instead of copying it.
If you use KDE, go the control center, go to peripherals, and under display, there should be the option. If you use GNOME or something else, a similar option should exist, but I'm not sure where.
If there was a driver available as a .deb package, install that one instead, as RPMs aren't designed to run on a Debian system, and all but one of the RPMs I've tried to install don't work. You might not need the driver at all. I have a nVidia card, and haven't installed the driver. It works fine, but you might need to add 'vga=771' to the boot options in GRUB. It might not be necessary, but there is no prolem if you don't need it and add it.

seashell11 08-08-2005 02:20 PM

Quote:

bp12345
but you might need to add 'vga=771' to the boot options in GRUB. It might not be necessary, but there is no prolem if you don't need it and add it.
How do you add this to GRUB?

Sootie 11-14-2005 12:25 AM

try this driver V1.0-0815 2004/09/13
at
http://www.xgitech.com/sd/sd_download2.asp

gudgione 02-10-2006 05:17 PM

I have the same card and couldn't get the driver working with CentOS; but I found that it worked really well with the current version of XFree86 (4.5.0).

I downloaded ftp.xfree86.org/pub/XFree86/4.5.0/binaries/ and followed the directions in the read me.

The card now works.


All times are GMT -5. The time now is 02:29 PM.