LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 06-15-2005, 09:57 AM   #1
cliff76
Member
 
Registered: Feb 2005
Location: PA
Distribution: Fedora Core 3
Posts: 48

Rep: Reputation: 15
Chainging the PATH on login shells


I have an issue on Mepis that I believe is Debian related. I'm trying to add a folder to my login shell PATH and it doesn't seem to work. In Fedora 3 I would just edit bash_profile and add/remove folders to the PATH there. This doesn't work on Mepis. I add a folder to my path in ~/.bash_profile and the extra folder is available whenever I start a new konsole window but it does not appear to be available globally. For example, other programs like my Java IDE don't see the modified path. Does Debian use a different shell (eg. csh) than Fedora? Where does the path get set for all X programs?
 
Old 06-15-2005, 11:12 AM   #2
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
The usual place to set the system-wide default PATH for users is /etc/login.defs. You should see in this file lines beginning with "ENV_SUPATH" and "ENV_PATH" -- the former sets PATH for users when they "su" to root and the latter when they remain normal users. You need to log out and login again before any changes in /etc/login.defs will take effect.
 
Old 06-15-2005, 01:27 PM   #3
cliff76
Member
 
Registered: Feb 2005
Location: PA
Distribution: Fedora Core 3
Posts: 48

Original Poster
Rep: Reputation: 15
Thanx but...

Thanx Parrot,

But I don't think you understand. I'm not trying to change the path for all users only for my user ID. I want the path to be global to all apps that run when I log in. That doesn't seem to work when I edit ~/.bashrc or ~/.bash_profile or ~/.bash_login. I know something is wrong here I just don't know what. Please help.
 
Old 06-15-2005, 03:11 PM   #4
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Hmm... I think your problem is that kdm overrides the normal startup files in your home directory and sets your $PATH. You need to find the file where you can change kdm's behaviour. Unfortunately I don't use kde myself, so I cannot help you there but Debian's X FAQ seems to suggest that kdm's config files might be found from /etc/kde3/kdm/.
 
Old 06-16-2005, 09:53 AM   #5
cliff76
Member
 
Registered: Feb 2005
Location: PA
Distribution: Fedora Core 3
Posts: 48

Original Poster
Rep: Reputation: 15
I did some tracing, starting from the /etc/kde3/kdm folder as suggested. I saw no hint of the PATH being overwritten. There is one file, Xstartup, where the PATH is appended to. something is off here and I still can't find it. I also know that it (what ever it is that's off) is not something I changed at all. What I don't understand is where the profile scripts get sourced. I did not see that anywhere in my tracing, though I did not look into every possible script. I compared the scripts with equivalents I found on my Fedora partition and I didn't see any profiles being sourced there either. It might help if I knew where the profile scripts should be sourced typically so I can try to trace what happend after that point. Thanx for all of your help and I'm still struggling to figure this out.
 
Old 06-16-2005, 03:52 PM   #6
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
It is quite possible that I'm wrong about kdm overriding your local startup files. Actually, I have no idea why changing $PATH in .bash_profile and .bashrc doesn't work.

Anyway, I did a Google search and, although I didn't actually find anything about kdm overriding local startup files, I did find out that the kdm settings file is called kdmrc. So I guess you could try adding your executable folder to $PATH in /etc/kde3/kdm/kdmrc by adding a line like this:

UserPath="$PATH:/path_to_your_executable_folder"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing the login PATH cliff76 MEPIS 1 06-22-2005 03:20 PM
Bash and login shells Adrohak Linux - Software 3 11-18-2004 10:21 AM
Login shells vs non-login shells lsmith Linux - General 2 03-31-2004 07:29 PM
Set path at login bcarl314 Linux - Newbie 4 10-13-2003 12:48 PM
Setting $PATH to include /home at login?? smurphy Linux - General 3 08-08-2001 02:46 PM


All times are GMT -5. The time now is 01:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration