LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 12-17-2005, 09:49 AM   #1
linuxmandrake
Member
 
Registered: Sep 2004
Distribution: debian sarge 64bit (AMD)
Posts: 709

Rep: Reputation: 30
cant open display within 32bit sarge chroot


I dont understand why I cant access xserver within the chroot. I am using dchroot to login. when I do dchroot xclock it works fine however when I do dchroot then xclock when am logged onto the chroot it says "cant open display". I have binded my config file to /etc/X11/ of chroot like this

mount --bind /etc/X11/XF86Config-4 "$CHROOTDIR/etc/X11/XF86Config-4"
when i do mount it shows it has mounted to the correct place

/etc/X11/XF86Config-4 on /var/chroot/sarge/etc/X11/XF86Config-4 type none (rw,bind)
any ideas?

Last edited by linuxmandrake; 12-17-2005 at 09:51 AM.
 
Old 12-17-2005, 10:57 AM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
I don't think you can bind mount a single file or directory, only a full filesystem, to another point. You could make a copy or a hard link, which would probably be more successful. Also, posting the exact error message regading the display might be helpful.
 
Old 12-17-2005, 10:59 AM   #3
linuxmandrake
Member
 
Registered: Sep 2004
Distribution: debian sarge 64bit (AMD)
Posts: 709

Original Poster
Rep: Reputation: 30
thanks that helped alot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AMD64 - 3d accel in a 32bit chroot don't work ssobeht Debian 2 12-22-2005 10:11 AM
debian stuck within 32bit chroot on 64bit sarge linuxmandrake Debian 8 12-13-2005 03:01 PM
chroot 32bit on 64bit install of sarge linuxmandrake Debian 1 12-06-2005 10:14 AM
Debian 32bit chroot setup question Oxyacetylene Debian 4 11-28-2005 08:01 AM
chroot for 32bit progs in debian64 port Jaster Debian 2 03-06-2005 08:34 AM


All times are GMT -5. The time now is 06:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration