LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Can't mount NTFS drives (yeah...I searched first) (http://www.linuxquestions.org/questions/debian-26/cant-mount-ntfs-drives-yeah-i-searched-first-165935/)

mandark 04-04-2004 12:23 AM

Can't mount NTFS drives (yeah...I searched first)
 
Hi all. I'm running Mepis 2003.10 (it's a debian-based distro)

I'm running the 2.4.22 kernel. According to what I have read, the 2.4.22 "should" allow me to access my NTFS partitions, but it doesn't for some reason...

I have researched the problem, I have RTFM, and I have learned "nearly" enough to WAFM, but I cannot seem to solve this one last problem with NTFS access!

After a fresh installation of Mepis, I log in as root and perform:

cat /proc/filesystems

My results are:

mandark@0[mandark]$ cat /proc/filesystems
nodev rootfs
nodev bdev
nodev proc
nodev sockfs
nodev tmpfs
nodev shm
nodev pipefs
ext3
ext2
nodev ramfs
msdos
vfat
iso9660
reiserfs
nodev devpts
nodev usbdevfs
nodev usbfs
ntfs
minix
hfs
nodev autofs
nodev smbfs

I see an entry CLEAR AS DAY for NTFS, so I "should" be able to mount and access them. WRONG!

root@0[mandark]#mkdir /home/mandark/ntfs1 (used /home/mandark/ntfs1 so I wouldn't write over anything in /mnt)
root@0[mandark]#
root@0[mandark]# mount -t ntfs /dev/hda5 /home/mandark/ntfs1
mount: wrong fs type, bad option, bad superblock on /dev/hda5,
or too many mounted file systems


I can perform a modprobe ntfs and then an lsmod to see which modules are loaded and it shows up as being loaded.

However, I then try to mount the NTFS drives, and STILL have no NTFS access...


This is my "standard" MEPIS fstab <-- created from initial installation (modified one below)
/dev/hdc1 / ext3 defaults,noatime 1 1
/dev/hdc2 swap swap sw,pri=1 0 0
proc /proc proc defaults 0 0
devpts /dev/pts devpts mode=0622 0 0
/dev/hdc3 /home ext3 defaults,noatime 1 2
# Dynamic entries
/dev/hda1 /mnt/hda1 vfat noauto,users,exec,umask=000 0 0
/dev/hda5 /mnt/hda5 auto noauto,users,exec 0 0
/dev/hda6 /mnt/hda6 auto noauto,users,exec 0 0
/dev/hdb1 /mnt/hdb1 vfat noauto,users,exec,umask=000 0 0
/dev/hdb5 /mnt/hdb5 auto noauto,users,exec 0 0
/dev/hdb6 /mnt/hdb6 vfat noauto,users,exec,umask=000 0 0

This is my "standard" Mandrake fstab <-- created from Mandrake installation on the exact same hardware as a comparison

none /cdrom supermount dev=/dev/hdd,fs=udf:iso9660,ro,--,iocharset=iso8859-1 0 0
none /dev/pts devpts mode=0620 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,sync,iocharset=iso8859-1,codepage=850 0 0
/dev/hda1 /mnt/win_c vfat umask=0,iocharset=iso8859-1,codepage=850 0 0
/dev/hdb1 /mnt/win_c2 vfat umask=0,iocharset=iso8859-1,codepage=850 0 0
/dev/hda5 /mnt/win_d ntfs umask=0,ro,iocharset=iso8859-1 0 0
/dev/hdb5 /mnt/win_d2 ntfs umask=0,ro,iocharset=iso8859-1 0 0
/dev/hda6 /mnt/win_e ntfs umask=0,ro,iocharset=iso8859-1 0 0
/dev/hdb6 /mnt/win_e2 vfat umask=0,iocharset=iso8859-1,codepage=850 0 0
none /proc proc defaults 0 0

This is how I have modified my MEPIS fstab in hopes of accessing my NTFS drives. NO GO.


/dev/hdc1 / ext3 defaults,noatime 1 1
/dev/hdc2 swap swap sw,pri=1 0 0
proc /proc proc defaults 0 0
devpts /dev/pts devpts mode=0622 0 0
/dev/hdc3 /home ext3 defaults,noatime 1 2
/dev/hda5 /mnt/hda5 ntfs ro,noauto,users,exec 0 0
/dev/hda6 /mnt/hda6 ntfs ro,noauto,users,exec 0 0
/dev/hdb5 /mnt/hdb5 ntfs ro,noauto,users,exec 0 0
# Dynamic entries
/dev/hda1 /mnt/hda1 vfat noauto,users,exec,umask=000 0 0
/dev/hdb1 /mnt/hdb1 vfat noauto,users,exec,umask=000 0 0
/dev/hdb6 /mnt/hdb6 vfat noauto,users,exec,umask=000 0 0

WTF do I need to do?!

Bruce Hill 04-04-2004 12:48 AM

Maybe I'm missing something, but...

/dev/hda5 /mnt/hda5 auto noauto,users,exec 0 0
/dev/hda5 /mnt/hda5 ntfs ro,noauto,users,exec 0 0

should not this be where you look? Did you try ->
$ cd /mnt/hda5
$ ls -alc

What does ->
# fdisk -l
look like?

mandark 04-04-2004 07:33 PM

here's your requested information
 
Quote:

Originally posted by Chinaman
Maybe I'm missing something, but...

/dev/hda5 /mnt/hda5 auto noauto,users,exec 0 0
/dev/hda5 /mnt/hda5 ntfs ro,noauto,users,exec 0 0

should not this be where you look? Did you try ->
$ cd /mnt/hda5
$ ls -alc

What does ->
# fdisk -l
look like?

Here's the ls -alc

root@2[root]# cd /mnt/hda5
root@2[hda5]# ls -alc
total 8
drwxr-xr-x 2 root root 4096 2004-04-03 16:25 .
drwxr-xr-x 14 root root 4096 2004-04-03 16:25 ..


Here's the fdisk -l

Disk /dev/hdc: 20.5 GB, 20576747520 bytes
16 heads, 63 sectors/track, 39870 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System
/dev/hdc1 1 20317 10239736+ 83 Linux
/dev/hdc2 20318 22349 1024128 82 Linux swap
/dev/hdc3 22350 39870 8830584 83 Linux

Disk /dev/hda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 1530 12289693+ c W95 FAT32 (LBA)
/dev/hda2 1531 19457 143998627+ f W95 Ext'd (LBA)
/dev/hda5 1531 11473 79867116 7 HPFS/NTFS
/dev/hda6 11474 19457 64131448+ 7 HPFS/NTFS

Disk /dev/hdb: 100.0 GB, 100030242816 bytes
255 heads, 63 sectors/track, 12161 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 1 885 7108731 b W95 FAT32
/dev/hdb2 886 12162 90577021+ 5 Extended
Partition 2 does not end on cylinder boundary.
/dev/hdb5 886 9490 69119631 7 HPFS/NTFS
/dev/hdb6 9491 12162 21457327+ b W95 FAT32

urzumph 04-05-2004 05:30 AM

I don't know if this will help, but did you try with the -o ro option? Unless you compiled write support into the kernel it doesn't come as default (it's dangerous, as you probably know) I don't know how the read-only NTFS driver would respond to trying to mount read-write - it might just fail or it might mount read only anyway. Anyway, the -o ro option is worth a shot.

mount -t ntfs /dev/hda5 /home/mandark/ntfs1 -o ro

mandark 04-06-2004 11:39 PM

Quote:

Originally posted by urzumph
I don't know if this will help, but did you try with the -o ro option? Unless you compiled write support into the kernel it doesn't come as default (it's dangerous, as you probably know) I don't know how the read-only NTFS driver would respond to trying to mount read-write - it might just fail or it might mount read only anyway. Anyway, the -o ro option is worth a shot.

mount -t ntfs /dev/hda5 /home/mandark/ntfs1 -o ro

ehm...you're not gonna believe it, but I'm gonna tell you anyway...

I’m sitting there last night trying to figure out why the frell Mepis Linux simply refuses to see my NTFS partitions, when it dawns on me that if I’m using this as a “Linux” box, Why the FRELL am I worried about NTFS access in the first place?

I’m already pissed so I throw in my XP CD into the drive and boot from it to get to the repair console, because in my troubleshooting, I managed to kill the MBR (note to self: Absolut neat & computing do not mix well)

While at the Repair console, I say fukkit and format my XP Partition (format c: /q) just to be rid of the damn thing…

I then boot back up in Mepis (live CD) and go to mount the DVD where I have some MP3s, because I wanna hear some tunes while I mull over this crap, and I notice something very odd in the kwikdisk app!

The XP Partition I just formatted is showing up AS A GADDAMB NTFS PARTITION! I try to mount it and IT WORKS!

I researched it further by reinstalling XP on the freshly-formatted NTFS partition. I CAN SEE IT FROM the Mepis Live CD!

From there I start the “340Gb shuffle”, moving files from my NTFS partitions to FAT32 partitions…Once an NTFS partition is empty, I perform a quick format and copy a few files back on to it, then reboot into Mepis…

Sure enough…EACH AND EVERY FREAKING NTFS partition can NOW be mounted and accessed!

SUNOFABITCH! My NTFS partitions evidently were corrupted in such a way that didn’t affect Windows’ ability to see them, but totally flummoxed Linux!

Each partition I formatted NOW SHOWS UP CORRECTLY and WORKS!

To prevent that crap from EVER happening again, I go through the process of repartitioning the NTFS partitions to FAT32 (will be going to Ext3 this weekend)

Now I have 10 accessible partitions, 8 of which are FAT 32, the other two, an 11Gb and a 12Gb, are formatted NTFS for any games that may come along soon (i.e. HL2, DOOM3) that I simply “must” have windows in order to play them.


All times are GMT -5. The time now is 06:46 AM.