LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 11-10-2007, 12:05 PM   #1
vineet7kumar
Member
 
Registered: Aug 2005
Posts: 75

Rep: Reputation: 15
cannot update,upgrade using apt-get...errors


hi,
I just switched from fedora core 6 to debian etch.
I am able to install softwares from the DVD but can't install online using apt-get.
Also can't update or upgrade using apt-get.

error on giving the command
# apt-get update
is

E: Could not get lock /var/lib/apt/lists/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the list directory


the contents of /etc/apt/sources.list file are

#

deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 DVD Binary-1 20070407-11:40]/ etch contrib main

deb-src cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 DVD Binary-1 20070407-11:40]/ etch contrib main


deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 DVD Binary-2 20070407-11:40]/ etch contrib main

deb-src cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 DVD Binary-2 20070407-11:40]/ etch contrib main

deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 DVD Binary-3 20070407-11:40]/ etch contrib main

deb-src cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 DVD Binary-3 20070407-11:40]/ etch contrib main

# Line commented out by installer because it failed to verify:

deb http://security.debian.org/ etch/updates main contrib
# Line commented out by installer because it failed to verify:
# deb http://http.us.debian.org/debian/ sarge main contrib non-free
deb-src http://security.debian.org/ etch/updates main contrib

deb http://ftp.us.debian.org/debian/ etch main contrib non-free
deb-src http://ftp.us.debian.org/debian/ etch main contrib non-free

deb http://security.debian.org/ etch/updates main contrib non-free
deb-src http://security.debian.org/ etch/updates main contrib non-free



I should also mention that I am behind the college Internet proxy.
(Using Internet in the college)

what is the solution?

thanks,
Vineet
 
Old 11-10-2007, 12:19 PM   #2
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,684

Rep: Reputation: 124Reputation: 124
That proxy is your problem. I suggest to get the latest DVD version or the net-install cd if you don't want to wait that long
 
Old 11-10-2007, 01:17 PM   #3
wit_273
Member
 
Registered: Mar 2007
Location: Nebraska
Distribution: CentOS
Posts: 82

Rep: Reputation: 15
This error means that another program is opened that uses apt-get. You most likely have Synaptic (or another update program) opened. Close the update program and try again. It would not have anything to do with the proxy as the problem is apt-get needs to get a lock on /var/lib/apt/lists/ but something else (most likely another update program) already has the directory locked. The other cause for this is running apt-get as a regular user, but it appears that you are running as root since the command you showed is proceeded with a #.

George
 
Old 11-10-2007, 02:18 PM   #4
Zaskar
Member
 
Registered: Feb 2004
Location: NY
Distribution: Debian (Testing)
Posts: 219

Rep: Reputation: 30
If you dont think you have anything open, it is most likley the synaptic automatic uploader, there should an icon in the upper or lower right corner for it. Somethimes it gets weird and will lock the file even though you havent opened it, something weird just happened with it as it was checking for updates, as its not supposed to lock anything when its just sitting in the bar letting you know you have updates available. Only 1 instance of an update can occur at once as they use the same Apt files. Apt-Get, Aptitude and Synaptic all share them.

Disable it (man I forget how sorry, I use fluxbox so I dont even have to concern myself with that) and just use aptitude for updates, using synaptic can get you into trouble, it tries to force all the packages that would normally be held back by synaptic cause they usually arent finished yet and have dependencies that arent compatible (like for instance ive had synaptic remove all of gnome cause i wasnt paying attention, some package had a dependency for a new version of a file that Gnome depended on also... so it removed gnome to resolve the issue hahahaha.)

Last edited by Zaskar; 11-10-2007 at 02:21 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get update errors ahz10 Ubuntu 4 01-06-2006 06:14 PM
apt-get upgrade errors revenge80200 Linux - Newbie 6 12-13-2005 08:51 PM
gpg errors on apt-get update... fannymites Debian 4 07-23-2005 03:46 AM
apt-get update errors since Debian released ( bad /etc/apt/sources.list ?) forgox Debian 10 06-13-2005 01:28 PM
firestarter errors after apt-get upgrade Outabux Debian 2 03-03-2005 02:07 AM


All times are GMT -5. The time now is 03:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration