LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 10-26-2012, 10:15 PM   #1
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,680

Rep: Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558
Can't use touchpad in KDE like I do in Gnome and MATE, what settings control it?


I have installed Debian Wheezy with KDE 4.8.4 and am trying to get the touchpad to work the same way it does in every other DE and OS (yes Windows) on this laptop. KDE has settings to make the touchpad act like a particular mouse button but I just want it to work like it does in Gnome, MATE, Windows, in other words I tap on the toucchpad and I can select anything I like or highlight anything I want to highlight, or place my curser anywhere I want to place it, or use the scoll bar on the side of Iceweasel, etc. etc. etc. Is there an option to do this? or am I stuck with KDEs choices?
 
Old 10-28-2012, 02:14 AM   #2
jim_p
Member
 
Registered: Aug 2009
Distribution: Debian testing
Posts: 483

Rep: Reputation: 108Reputation: 108
Just a suggestion, since i do not have kde or gnome or anything that seems like a desktop enviroment :P

Can you set your settings system wide, from xorg's configuration files that is? I remember doing that "tap to click" thing some year ago on a friend's laptop. Have a look here
https://wiki.archlinux.org/index.php/Xorg
 
1 members found this post helpful.
Old 10-28-2012, 04:21 AM   #3
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,680

Original Poster
Rep: Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558
Hi Jim, I thought of that before but Debian no longer has a xorg.conf file by default. I did make one and it worked the first time but after a reboot it has gone back to the old behaviour.
 
Old 10-28-2012, 04:45 AM   #4
salasi
Senior Member
 
Registered: Jul 2007
Location: Directly above centre of the earth, UK
Distribution: SuSE, plus some hopping
Posts: 3,900

Rep: Reputation: 774Reputation: 774Reputation: 774Reputation: 774Reputation: 774Reputation: 774Reputation: 774
KDE has lots of options for touchpad control in

System setting > Input Devices > Touchpad

(there are also Mouse control options, but I don't even know if when you have touchpad, you get those options layered on top of mouse, or not)

but I have no idea which, if any, of those settings really help you, unfortunately. I would guess that you have to try the different setting and see what does what you want.

So, I don't know what to do, but I have a good idea where to look... (unless you've already tried that, of course, in which case its a lousy idea).
 
1 members found this post helpful.
Old 10-28-2012, 05:03 AM   #5
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,680

Original Poster
Rep: Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558
Thanks Salasi, I have already gone through KDEs gui for it but to no avail. Thanks anyway
 
Old 10-28-2012, 07:58 PM   #6
Knightron
Senior Member
 
Registered: Jan 2011
Location: Planet Earth
Distribution: Slackware.
Posts: 1,325
Blog Entries: 7

Rep: Reputation: 157Reputation: 157
All the options i've ever wanted, and by the sounds of it, what you'd want, can be accomplished with the method salasi posted. Depending on how you installed kde, eg 'plasma-desktop' 'kde-full', you may not have installed the required package. Make sure the 'kcm_touchpad' package is installed and then try salasis method.

If this still doesn't work, you've told us what you want the touch pad to do, but you haven't said what it's doing differently. Please elaborate.
 
Old 10-29-2012, 01:57 AM   #7
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,680

Original Poster
Rep: Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558
Quote:
Originally Posted by Knightron View Post
All the options i've ever wanted, and by the sounds of it, what you'd want, can be accomplished with the method salasi posted. Depending on how you installed kde, eg 'plasma-desktop' 'kde-full', you may not have installed the required package. Make sure the 'kcm_touchpad' package is installed and then try salasis method.
I installed straight Debian Wheezy KDE off DVD1. Looking in Synaptic there is no such package as kcm_touchpad.

Quote:
Originally Posted by Knightron View Post
If this still doesn't work, you've told us what you want the touch pad to do, but you haven't said what it's doing differently. Please elaborate.
In Gnome, MATE, Windows I touch the touchpad and it activates links, highlights text (after dragging the curser across the desired section), with one tap. With two taps I can open folders. In KDE I have to use the "mouse" keys attached to the touchapd to select text, to activate links, to open folders, etc. The current way on my laptop, in KDE, is fine with a normal mouse because the buttons are at the front of the mouse. It is, however, not fine with touchapds because the keys are behind the touchpad and I cannot make my fingers be contortionists.

Last edited by k3lt01; 10-29-2012 at 02:01 AM.
 
Old 10-29-2012, 04:50 AM   #8
Knightron
Senior Member
 
Registered: Jan 2011
Location: Planet Earth
Distribution: Slackware.
Posts: 1,325
Blog Entries: 7

Rep: Reputation: 157Reputation: 157
Hey, it's coincidence but i downloaded the Wheezy beta installer today and installed Wheezy and kde with it.
I can say that the package i was talking about is not on the dvd, so not installed by default.
I called it 'kcm_touchpad', that's the Slackware name; i didn't think Debian would call it something different; 'kde-config-touchpad' is what Debian calls it. Try installing that and give it another shot.
 
Old 10-29-2012, 02:09 PM   #9
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,680

Original Poster
Rep: Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558
Quote:
Originally Posted by Knightron View Post
Hey, it's coincidence but i downloaded the Wheezy beta installer today and installed Wheezy and kde with it.
I can say that the package i was talking about is not on the dvd, so not installed by default.
I called it 'kcm_touchpad', that's the Slackware name; i didn't think Debian would call it something different; 'kde-config-touchpad' is what Debian calls it. Try installing that and give it another shot.
It is installed and my touchpad doesn't work like it does in Gnome etc. I have tried the various touchpad packages (did a search in Synaptic) went through one by and installed the ones that were not already installed rebooted no difference. The only thing that has made any difference so far is the creation of a xorg.conf (which isn't used by default anymore cause Debian uses DBus (I think) now. xorg.conf worked once for a brief moment but not anymore.
 
Old 10-29-2012, 08:12 PM   #10
Knightron
Senior Member
 
Registered: Jan 2011
Location: Planet Earth
Distribution: Slackware.
Posts: 1,325
Blog Entries: 7

Rep: Reputation: 157Reputation: 157
Ok, so did you see the tabs in the touchpad section? if so, are you selecting options and they're simply not working? I must mention since i know you're used of Gnome and Mate, you need to click apply before these will take effect on kde.

From what i gather almost everything you want can be done.
Quote:
In Gnome, MATE, Windows I touch the touchpad and it activates links
In System setting > Input Devices > Touchpad, there's a 'tapping' tab. You need to make the 'Tapping with one finger' say 'left mouse click'
Quote:
highlights text (after dragging the curser across the desired section), with one tap.
In the 'tapping' tab, near the bottom there in an option, 'Drag items by tapping the touch pad and immediately touching it again'
This require two click not one, but it's the closest i find to what you describe.
Quote:
With two taps I can open folders
In the 'Mouse' section of Input Devices, there is an option for double click to open files and folders. This option along with the tapping enabled the way i said in the fist point should get this right.
There is also a 'Scrolling' tab inside the 'Touchpad' selection, if you wish to configure the way you scroll.
 
Old 10-29-2012, 09:24 PM   #11
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,680

Original Poster
Rep: Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558
Knightron I have been through it all. I have installed all the various touchpad debs thata re available and tried each setting and it isn't working. I tried Salasi's excellent suggestion, even though my mind said xorg.conf was no longer required I still tried it, and it worked momentarilly and then stopped. I don't know if, maybe, something has gone awry because from what I understand it should have worked already yet it still hasn't.

I'll give it a break for a few days give it an update and see if that helps.
 
Old 10-29-2012, 10:21 PM   #12
Knightron
Senior Member
 
Registered: Jan 2011
Location: Planet Earth
Distribution: Slackware.
Posts: 1,325
Blog Entries: 7

Rep: Reputation: 157Reputation: 157
Ok well sorry to hear that. Maybe it's a bug. I was just trying to be helpful because it works perfectly on my laptop.
Hope you find a solution.
 
Old 10-29-2012, 11:25 PM   #13
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,680

Original Poster
Rep: Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558
And your help is greatly appreciated.
 
Old 11-07-2012, 04:04 PM   #14
salasi
Senior Member
 
Registered: Jul 2007
Location: Directly above centre of the earth, UK
Distribution: SuSE, plus some hopping
Posts: 3,900

Rep: Reputation: 774Reputation: 774Reputation: 774Reputation: 774Reputation: 774Reputation: 774Reputation: 774
I've just gone to system settings > input devices > touchpad > tapping tab > tapping with one finger = disabled (tapping with two and three fingers were already disabled) and it seems to have cut down my level of 'odd, random, behaviour as I am swiping my finger'. In fact, the only thing on that page that I have enabled is 'Drag items by tapping...'.

No idea whether it helps you, but, for me, kde seems to be behaving more predictably now.
 
1 members found this post helpful.
Old 11-08-2012, 01:19 AM   #15
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,680

Original Poster
Rep: Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558
I'll give that a try, thanks Salasi.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GNOME overrides my Synaptics touchpad settings arielCo Linux - Software 6 11-03-2009 07:46 PM
kde control center - is there any way to delete saved settings .id Linux - Desktop 2 12-19-2007 05:06 AM
Gnome settings overriding KDE settings frode Suse/Novell 2 04-21-2007 02:35 PM
Where is Network Settings in KDE Control Center royeo Linux - Newbie 1 08-05-2006 04:53 PM
Mandrake 10.0 Gnome/KDE Taskbar icon settings...are there settings? LiquidRezin Linux - Newbie 2 03-22-2004 09:27 AM


All times are GMT -5. The time now is 08:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration