LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 07-27-2013, 02:38 AM   #1
EDDY1
Guru
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,028

Rep: Reputation: 442Reputation: 442Reputation: 442Reputation: 442Reputation: 442
can't stop screen from blanking


I'm running Debian Jessie & I haven't been able to stop from blanking due to non activity while play videos on internet tv.
It doesn't bother me when I'm not at computer but if I'm watching a video I don't want to have to hit the mouse to stop screen from blanking.
I think that the xset commands work as long as I enter them at beginning of session, but I also tried different settings in xorg.conf file following these steps
http://crunchbang.org/forums/viewtopic.php?id=13990
They have worked in the since that they do not blank after 10 mins but they do bla after a while, maybe after 2hrs.
 
Old 07-27-2013, 03:41 AM   #2
Lennie
Member
 
Registered: Aug 2012
Location: Sweden
Distribution: LFS, built with pacman
Posts: 301

Rep: Reputation: 60
I use lightsOn.
 
Old 07-27-2013, 11:10 AM   #3
EDDY1
Guru
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,028

Original Poster
Rep: Reputation: 442Reputation: 442Reputation: 442Reputation: 442Reputation: 442
Where do Isave the script to?
 
Old 07-27-2013, 11:24 AM   #4
Lennie
Member
 
Registered: Aug 2012
Location: Sweden
Distribution: LFS, built with pacman
Posts: 301

Rep: Reputation: 60
I have it in ~/bin, and in autostart I have '$HOME/bin/lightsOn.sh 540 &'.
 
Old 07-28-2013, 07:41 AM   #5
EDDY1
Guru
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,028

Original Poster
Rep: Reputation: 442Reputation: 442Reputation: 442Reputation: 442Reputation: 442
Th xset command works but it has to bedone every login
 
Old 07-28-2013, 08:00 AM   #6
odiseo77
Member
 
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 948

Rep: Reputation: 274Reputation: 274Reputation: 274
You can put any command (or the path to a given script) at the end of /etc/rc.local, in the line before "exit 0", and it will be executed at boot.
 
Old 09-17-2013, 09:44 PM   #7
wolsonjr
LQ Newbie
 
Registered: Aug 2007
Distribution: Deb, Mint, Slack, LFS, Fedora, Ubuntu(LXDE)
Posts: 20

Rep: Reputation: 2
stop Gnome screenblank

This has bugged me a long time, it became critical this week and the screen has to be live for certain operations (recordmydesktop) even if the monitor is off. Running Wheezy Gnome desktop, normally up 24/7 before monthly reboot. I don't need screensaver or locking or blanking, I turn off monitor when not working.

Run "gnome-screensaver-command -q" to get status. This will show you if gnome screensaver is your active screensaver.
If it is, run "gnome_screensaver-command --exit" to kill it.

This will need to be run every boot, manually or in boot script. There should be a way to keep gnome.s.s from starting but I haven't found it yet.
This also may need to be run with login, but since I never logout, I can't be certain.
 
Old 09-18-2013, 12:25 AM   #8
EDDY1
Guru
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,028

Original Poster
Rep: Reputation: 442Reputation: 442Reputation: 442Reputation: 442Reputation: 442
I haven't solved that situation but my work around was install vlc insert dvd let it run then pause it. screen never blanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to stop screen blanking during inactivity Stephen Morgan Slackware 1 01-04-2012 01:35 PM
how to stop the screen blanking on crunchbang linux samsearcher Linux - Newbie 8 06-16-2009 01:23 PM
How to turn off screen blanking screen saver in run level 3? Arodef Linux - Software 1 01-04-2005 12:50 PM
how to stop the monitor from blanking soup Slackware 6 04-02-2004 04:48 AM
Can't stop KDE/Mandrake 9.2 from blanking screen themusk Linux - Software 1 03-20-2004 08:49 PM


All times are GMT -5. The time now is 10:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration