LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-12-2004, 11:48 PM   #1
friedknut
LQ Newbie
 
Registered: May 2004
Location: Los Angeles
Distribution: Debian
Posts: 2

Rep: Reputation: 0
Can't install gimp from .deb package


Hello, I can't get the Gimp to install from a .deb package. This is what i get everytime i run apt-get:
Code:
root@deepfry:/# apt-get install gimp
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  gimp: Depends: libgtk2.0-0 (>= 2.4.4) but 2.4.3-3 is to be installed
        Depends: libpango1.0-0 (>= 1.4.1) but 1.4.0-4 is to be installed
E: Broken packages
But everytime i run "apt-get install libgtk2.0-0 libpango1.0-0 gimp" i get:
Code:
libgtk2.0-0 is already the newest version.
libpango1.0-0 is already the newest version.
I've tried with -f and with -m and i still get the same thing.
Thanks for your help.
 
Old 08-12-2004, 11:56 PM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Re: Can't install gimp from .deb package

Quote:
Originally posted by friedknut
The following packages have unmet dependencies:
gimp: Depends: libgtk2.0-0 (>= 2.4.4) but 2.4.3-3 is to be installed
Depends: libpango1.0-0 (>= 1.4.1) but 1.4.0-4 is to be installed
E: Broken packages[/CODE]

But everytime i run "apt-get install libgtk2.0-0 libpango1.0-0 gimp" i get:
Code:
libgtk2.0-0 is already the newest version.
libpango1.0-0 is already the newest version.
I've tried with -f and with -m and i still get the same thing.
Thanks for your help.
You need sources entry for unstable in your /etc/apt/sources.list then use apt-get install libgtk2.0-0/unstable libpango1.0-0/unstable gimp and hopefully it will install if not and it still complains about missing packages then use package_name/unstable as an addition to the line. If you do not want to put sources for unstable in your sources.list then you have to wait until the packages needed enter testing.

Code:
>$ apt-cache policy libgtk2.0-0
libgtk2.0-0:
  Installed: 2.4.4-2
  Candidate: 2.4.4-2
  Version Table:
 *** 2.4.4-2 0
        600 http://ftp.de.debian.org unstable/main Packages
        100 /var/lib/dpkg/status
     2.4.3-3 0
        990 http://ftp.de.debian.org testing/main Packages
Edit: If you do not have an entry for the unstable already and add it to your sources then you either edit or create the file /etc/apt/apt.conf and put these lines in it to prevent you running out of cache space when you run apt-get update to fetch the packages lists and to make sure the system knows you do not want to upgrade your enitre distro to unstable.

Code:
APT::Default-Release "testing";
APT::Cache-Limit 10000000;
[/code]

Last edited by HappyTux; 08-13-2004 at 12:01 AM.
 
Old 08-13-2004, 12:03 AM   #3
friedknut
LQ Newbie
 
Registered: May 2004
Location: Los Angeles
Distribution: Debian
Posts: 2

Original Poster
Rep: Reputation: 0
Thank you very much, that worked. I already had entries for unstable so i just had to run:
Code:
# apt-get install libgtk2.0-bin/unstable libgtk2.0-common/unstable libpango1.0-common/unstable libgtk2.0-0/unstable libpango1.0-0/unstable gimp
 
Old 08-13-2004, 12:20 AM   #4
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Quote:
Originally posted by friedknut
Thank you very much, that worked. I already had entries for unstable so i just had to run:
Code:
# apt-get install libgtk2.0-bin/unstable libgtk2.0-common/unstable libpango1.0-common/unstable libgtk2.0-0/unstable libpango1.0-0/unstable gimp
Your welcome you can also do it another way if say you want to install all packages from unstable with apt-get -t unstable package package1 ... .
 
Old 08-13-2004, 04:08 PM   #5
macondo
Senior Member
 
Registered: Jul 2003
Location: Panama
Distribution: Debian Sid
Posts: 1,014

Rep: Reputation: 49
APT-HOWTO
http://www.debian.org/doc/manuals/ap.../index.en.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is there any way to install .deb package to Fedora kartik_mistry Debian 5 06-18-2009 05:07 PM
How to install deb package tstrickland Linux - Newbie 10 07-21-2005 06:39 PM
help with deb package on Xandros 3.0 xiongnu Debian 2 06-08-2005 11:03 PM
Can I install a .deb package into Vector? Fritz_Monroe Linux - Newbie 2 05-31-2005 05:52 PM
Can apt4rpm use deb repositories or install .deb packages? raylpc Linux - General 0 08-18-2003 01:49 AM


All times are GMT -5. The time now is 10:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration