Originally posted by friedknut
The following packages have unmet dependencies:
gimp: Depends: libgtk2.0-0 (>= 2.4.4) but 2.4.3-3 is to be installed
Depends: libpango1.0-0 (>= 1.4.1) but 1.4.0-4 is to be installed
E: Broken packages[/CODE]
But everytime i run "apt-get install libgtk2.0-0 libpango1.0-0 gimp" i get:
I've tried with -f and with -m and i still get the same thing.
libgtk2.0-0 is already the newest version.
libpango1.0-0 is already the newest version.
Thanks for your help.
You need sources entry for unstable in your /etc/apt/sources.list then use apt-get install libgtk2.0-0/unstable libpango1.0-0/unstable gimp
and hopefully it will install if not and it still complains about missing packages then use package_name/unstable as an addition to the line. If you do not want to put sources for unstable in your sources.list then you have to wait until the packages needed enter testing.
>$ apt-cache policy libgtk2.0-0
*** 2.4.4-2 0
600 http://ftp.de.debian.org unstable/main Packages
990 http://ftp.de.debian.org testing/main Packages
Edit: If you do not have an entry for the unstable already and add it to your sources then you either edit or create the file /etc/apt/apt.conf and put these lines in it to prevent you running out of cache space when you run apt-get update to fetch the packages lists and to make sure the system knows you do not want to upgrade your enitre distro to unstable.