LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 09-04-2007, 11:01 AM   #1
baghdadi13
LQ Newbie
 
Registered: Jul 2006
Distribution: Ubuntu 8.04
Posts: 18

Rep: Reputation: 0
Question can't mount DVD (unknown filesystem 'iso9660'


I'm using Debian 4 (kernel 2.6.17),
this debian was installed (let's say) on computer1 (my old pc), I bought a new pc (let's call it computer2) with Sata 250 HDD and I copied the partition from computer1 to computer2,
when I booted with the new debian on the computer2, I couldn't mount DVDrom and even I don't find /dev/cdrom in the /dev directory and no /dev/sr0, when I try to mount it using :
#mount -t iso9660 /dev/sr0 /mnt/cdrom
it says : unknow fileSystem type 'iso9660'
I tried -t cdfs , but still unknown file system
I can't also mount my windows partition: sda1
it says that vfat is unknown !!
I could only mount ext3 file system : mount /dev/sda9 /mnt/redhat

when I was using this debian on my old computer (computer1), cdRom where mounted automatically

an other thing is that I can't install debian on this computer, when installin it says that my cdrom drive is not found and I have to select it manually, but I tried all the drivers that are in the list but no one was good,
my DVD reader is working perfectly with mandriva and redhat but not with debian

so my two questions:
- how can I mount this DVD
- how can I install debian (is there any option to pass when installing debian on a Sata HDD)
and thank you for your help ... !
 
Old 09-04-2007, 11:13 AM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Look at the contents of /proc/filesystems. Is iso9660 listed? If not double check your running kernels .config file. You may need to reconfigure and rebuild your kernel:
Code:
# CD-ROM/DVD Filesystems
#
CONFIG_ISO9660_FS=y
CONFIG_JOLIET=y
CONFIG_ZISOFS=y
CONFIG_ZISOFS_FS=y
CONFIG_UDF_FS=m
CONFIG_UDF_NLS=y
If it is built as a module then you may need to modprobe the kernel module.

Last edited by jschiwal; 09-04-2007 at 11:15 AM.
 
Old 09-04-2007, 11:21 AM   #3
baghdadi13
LQ Newbie
 
Registered: Jul 2006
Distribution: Ubuntu 8.04
Posts: 18

Original Poster
Rep: Reputation: 0
I tried cat /proc/filesystems , and I got :
nodev sysfs
nodev rootfs
nodev debugfs
ext2
cramfs
ext3

is it the right way to do what you want ?
 
Old 09-04-2007, 11:24 AM   #4
baghdadi13
LQ Newbie
 
Registered: Jul 2006
Distribution: Ubuntu 8.04
Posts: 18

Original Poster
Rep: Reputation: 0
sorry for more than one post per time :

I chaecked now the /boot/config...... file , i found :
config_iso9660=m


this problem is similar to mine :
http://ubuntuforums.org/showthread.php?p=2097387

Last edited by baghdadi13; 09-04-2007 at 11:35 AM.
 
Old 09-04-2007, 11:40 AM   #5
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
So does the DVD Drive in your new PC have an IDE or SATA Interface ?
 
Old 09-04-2007, 11:43 AM   #6
baghdadi13
LQ Newbie
 
Registered: Jul 2006
Distribution: Ubuntu 8.04
Posts: 18

Original Poster
Rep: Reputation: 0
it's an IDE , and was working perfectly with this Debian when I was on my old Pc , I still have the same DVD drive.
 
Old 09-04-2007, 12:27 PM   #7
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Quote:
Originally Posted by baghdadi13 View Post
sorry for more than one post per time :

I chaecked now the /boot/config...... file , i found :
config_iso9660=m


this problem is similar to mine :
http://ubuntuforums.org/showthread.php?p=2097387
So it is configured as a module. Try "sudo /usr/modprobe iso9660" and then check /proc/filesystems again.
 
Old 09-04-2007, 12:38 PM   #8
baghdadi13
LQ Newbie
 
Registered: Jul 2006
Distribution: Ubuntu 8.04
Posts: 18

Original Poster
Rep: Reputation: 0
thank you, but it says :

FATAL: could not load /lib/modules/2.6.17-5mdv/modules.dep: No such file or directory

I loocked in the file modules.dep but I didn't find iso9660

what about installing Debian, is there a special thing to enable sata drives, because when the installertries to detect my dvd drive it says that it's anknown drive, and asks me to choose a driver from the list, but no one is good,,,,,,

Last edited by baghdadi13; 09-04-2007 at 12:42 PM.
 
Old 09-04-2007, 05:24 PM   #9
baghdadi13
LQ Newbie
 
Registered: Jul 2006
Distribution: Ubuntu 8.04
Posts: 18

Original Poster
Rep: Reputation: 0
I think that the problem the SATA drive,
I have desabled SATA from the BIOS, and then i tried to install debian and the installer has detected the CD drive correctly,, so I think that the problem is the SATA drive,
I found this usefull : http://linuxmafia.com/faq/Hardware/sata.html
http://wiki.debian.org/DebianInstall...e4c00f911f8b18

Do I have to recompile my kernel so that it supports the SATA drive, if so what options do I have to enable in the config file
 
Old 09-04-2007, 07:17 PM   #10
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
You need to run "depmod -A" as root. You may need to install the mod-init-tools package if you don't have the /sbin/depmod program. This command produces the modules.dep table that you are missing. The table lists the dependencies of the kernel modules.
 
Old 09-05-2007, 05:39 AM   #11
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215
Blog Entries: 2

Rep: Reputation: 49
Quote:
Originally Posted by baghdadi13 View Post
I think that the problem the SATA drive,
I have desabled SATA from the BIOS, and then i tried to install debian and the installer has detected the CD drive correctly,, so I think that the problem is the SATA drive,
I found this usefull : http://linuxmafia.com/faq/Hardware/sata.html
http://wiki.debian.org/DebianInstall...e4c00f911f8b18

Do I have to recompile my kernel so that it supports the SATA drive, if so what options do I have to enable in the config file
Just a thought, as have been thus fiddling withall.

Are you using udev? If so got to /dev/drive/by-id/ or so, and look for a name that looks like that of the problem drive. Use that name in /etc/fstab, etc., etc.. It is a persistent name and should always point to the drive.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: unknown filesystem type 'ntfs' when trying to mount windows drive... DiZASTiX Linux - Hardware 12 09-28-2008 08:29 PM
mount: unknown filesystem type 'LVM2_member' santana Linux - Hardware 3 02-28-2008 07:20 AM
Mount Unknown Filesystem or Flashdrives on REDHAT DJanarkali Red Hat 4 09-09-2007 08:17 AM
mount: unknown filesystem type 'devfs' kfir_w Linux - Software 2 06-15-2007 07:44 AM
mount: unknown filesystem type 'ntfs' lowrida Linux - Newbie 3 08-01-2005 05:02 PM


All times are GMT -5. The time now is 12:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration