LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 05-06-2004, 06:55 PM   #1
davidas
Member
 
Registered: Mar 2004
Distribution: Debian 'Sarge'
Posts: 168

Rep: Reputation: 30
Boot up with a black screen and the word 'GRUB' followed by blinking cusor


Desired situation
----------------------
To dual boot Win2K and Debian, using Win2K's boot.ini as the first OS loader, i.e. Upon bootup, boot.ini will display a menu that allows you to choose to boot either Win2K or Debian. Choosing Debian will load the Grub GUI menu, that displays the various versions of Kernel, from which you can boot from (assuming you have more than one version of kernel installed).

My partition layout
------------------------
/dev/hdb1 /
/dev/hdb5 swap
/dev/hdb6 /home

What has been done
---------------------------
- Install GRUB using apt-get install grub
- Run grub
- At grub prompt: find /boot/grub/stage1, of which returns (hd1,0)
- do a 'root (hd1,0)'
- do a 'setup (hd1,0)'
- mount floppy to /mnt
- dd if=/dev/hdb1 of=/mnt/sarge.lnx bs=512 count=1
- umount /mnt
- reboot and copy sarge.lnx into window's C:/
- edit Win2K's boot.ini to include c:\sarge.lnx="Debian"
- reboot

Problem: After choosing Debian from the boot menu displayed by
Win2K's boot.ini, I get a black screen with the word GRUB and a blinking cursor at the top left hand corner of the screen.

Any advice please?

Thanks !

Last edited by davidas; 05-06-2004 at 06:57 PM.
 
Old 05-06-2004, 09:05 PM   #2
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 50
you could use grub as boot loader and restore your old boot.ini
 
Old 05-10-2004, 03:15 AM   #3
davidas
Member
 
Registered: Mar 2004
Distribution: Debian 'Sarge'
Posts: 168

Original Poster
Rep: Reputation: 30
How do I use grub as boot loader and restore old boot.ini?

Thanks !

Quote:
Originally posted by mrcheeks
you could use grub as boot loader and restore your old boot.ini
 
Old 05-10-2004, 08:31 AM   #4
someone247356
LQ Newbie
 
Registered: Aug 2003
Location: Earth
Distribution: Debian GNU/Linux
Posts: 7

Rep: Reputation: 0
GRUB grubbing with my boot.ini

I too would be interested.

Been having a heck of a time trying to get Sarge installed via Beta4 netinst.

Install seems to go fine, but can never boot into it.

Like the original poster I have Win2K on /hda and Debian on /hdb.

Tried LILO on /dev/hdb1 and copied the boot sect. to a file. Selecting that option from NTLDR, flashes back to the Win2K menu option.

Tried LILO on /dev/hda1 (works like a charm with Slackware), gives me L 99 99 9 99 99 99 99 99 99 .....

Tried GRUB on floppy, boots to GRUB, in other words it just shows the word GRUB and a flashing cursor (then nothing).

Tried GRUB on /hda, boots to GRUB (then nothing), fdisk /MBR doesn't restore win booting ability. Have to undo the frigging that GRUB apparently does to my win2k boot.ini.

It's good to see that I'm not only one with this problem.
 
Old 07-07-2004, 03:55 AM   #5
troff
LQ Newbie
 
Registered: Jul 2004
Posts: 1

Rep: Reputation: 0
Yes i have the same problem, and I've tried to search for it on Google and other forums. Anyone with answers? Thanks in advance!
 
Old 07-08-2004, 12:52 PM   #6
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 51
Start from scratch, remove --purge grub, apt-get clean then:

To install grub
as root:

apt-get update
apt-get install grub
grub-install /dev/hda
update-grub

all this is assuming you are using the same hard drive.

With your favorite editor, go to /etc/apt/sources.list and add this under your linux menu:

title Windows on /dev/hda1
rootnoverify (hd0,0)
makeactive
chainloader +1

hope this works...

Last edited by macondo; 07-08-2004 at 12:55 PM.
 
Old 07-11-2004, 03:29 PM   #7
Wandering_Dru
Member
 
Registered: May 2004
Posts: 32

Rep: Reputation: 15
Quote:
Originally posted by macondo

all this is assuming you are using the same hard drive.

With your favorite editor, go to /etc/apt/sources.list and add this under your linux menu:

title Windows on /dev/hda1
rootnoverify (hd0,0)
makeactive
chainloader +1

hope this works...
Actually, you want to edit /boot/grub/menu.lst, NOT your apt sources.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I messed with the screen resolution and now Redhat will boot into a black screen! Mr. Hill Linux - Newbie 29 05-04-2009 12:52 PM
GRUB : just write grub in black screen. (Urgent) dezeque Linux - Newbie 11 05-27-2005 01:47 PM
grub (blinking cursor) - won't boot php4u Fedora - Installation 2 04-04-2005 11:23 AM
Blank screen with blinking cursor on boot (yoper) Fisslefink Linux - Newbie 3 02-15-2005 06:16 PM
GRUB black screen mbatalla82 Linux - Software 4 03-17-2003 03:58 PM


All times are GMT -5. The time now is 05:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration