LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 02-19-2009, 02:40 PM   #1
modsRule
LQ Newbie
 
Registered: Feb 2009
Posts: 3

Rep: Reputation: 0
Boot - UDEVADM


I installed Debian Lenny on an old IBM Thinkpad laptop.

The install works fine, apart from the boot takes several minutes. This occurs around 1/2way through the boot process and is caused to udevadm.

udevadm is causing the whole machine to wait while nothing happens untill it timesout.

Is there anyway to reduce the default timeout time to something sensible?

thanks.
modsRule
 
Old 02-19-2009, 08:18 PM   #2
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Try to see where the problem appears
Open a shell and monitor syslog
tail -f /var/log/syslog
In another shell:
udevadm control --log_priority=debug
udevadm control --reload_rules
udevadm trigger

And look at syslog. The timeout of the whole is 3 min at boot and should/can not be changed
 
Old 02-21-2009, 02:16 PM   #3
modsRule
LQ Newbie
 
Registered: Feb 2009
Posts: 3

Original Poster
Rep: Reputation: 0
I have tried that. Nothing stops being written the log for more than 15 seconds, wheras on boot 1 item stops it for several minutes.

Is there a boot-log?
 
Old 02-23-2009, 03:02 AM   #4
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Did you check the thread a few lines below about slow booting on a imac?
This enables more debugging.
Otherwise, simply visually, make sure that your grub line does not contain "quiet" and try to see where it stops?

I'm also having some trouble with some of my initrd :/
 
Old 02-24-2009, 01:35 PM   #5
modsRule
LQ Newbie
 
Registered: Feb 2009
Posts: 3

Original Poster
Rep: Reputation: 0
I removed the quiet flag from the grub boot-loader. (found in /etc/grub/menu.lst because its debian)
No more information relating the sudden holdup occurred.

The last bit before the pause (very.very long pause ) is 'cs: IOPort probe xxxx-xxxx' (where xxxx are numbers)
Hitting Ctrl-C to end whatever is causing the problem. works and the boot then continues with: 'Setting parameters of Disk' and 'Settings System Clock'

Any more ideas?
 
  


Reply

Tags
debian, ibm, lenny, timeout


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot Camp (fixing boot loaders, learning your way around boot & chainloaders) Siljrath Linux - General 7 05-29-2007 11:22 AM
When I boot my comp. (dual boot sys-Suse 10.1 & Win XP) the first boot stalls. philip niedermeyer Linux - Desktop 5 11-13-2006 06:04 PM
Kind souls: help getting Mandriva install 2 boot? edit boot.ini/grub /boot device or NoMoreReinstallMS Linux - Newbie 1 08-09-2006 04:34 AM
GRUB: How to boot WinXP (NTLDR, NTDETECT.COM & BOOT.INI) from boot partition (EXT2) ? Rayen16 Linux - Software 1 05-25-2006 12:09 PM
failed features: boot.shm boot.loadmodules boot.swap cccc Suse/Novell 1 08-08-2005 07:23 AM


All times are GMT -5. The time now is 11:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration