LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   boot into command line debian squeeze (http://www.linuxquestions.org/questions/debian-26/boot-into-command-line-debian-squeeze-938967/)

nepalnt21 04-09-2012 05:16 PM

boot into command line debian squeeze
 
ok so ive reinstalled squeeze, this time with the gui installed.

but now i want to set it up so that instead of booting into the gui login screen, i boot into the command line and do everything from there.

so far ive tried

update-rc.d -f gdm remove
update-rc.d -f kdm remove
update-rc.d -f xdm remove


no errors,

but it still boots up into the log in screen. is this an old method that doesnt work for squeeze?

thanks for any help

widget 04-09-2012 05:34 PM

First off what DE did you install and what dm?

Why not just "apt-get remove <somedm>"?

There really should not be more than one installed.

nepalnt21 04-10-2012 12:48 PM

it came with gnome, i added lxde and i3. if i delete them all and reinstall the one or two i want, will it solve the problem?

fatmac 04-10-2012 01:58 PM

One way that I have done it; as root, go into '/etc/rc2.d', 'mv S21gdm oldS21gdm', save the file.
Next time you boot up, it should start with all services, except gdm will not be started.

Hope that helps you do what you want.

repo 04-10-2012 02:05 PM

Edit
Code:

/etc/inittab
and set the runlevel to 3
Code:

# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:

reboot

Kind regards

craigevil 04-10-2012 05:01 PM

Quote:

Originally Posted by repo (Post 4649523)
Edit
Code:

/etc/inittab
and set the runlevel to 3
Code:

# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:

reboot

Kind regards

Will not work as runlevels 2-5 are the same on Debian.

Debian and Ubuntu Linux Run Levels - http://www.debianadmin.com/debian-an...un-levels.html

Howto Boot debian in text mode instead of graphical mode (GUI) - http://www.debianadmin.com/howto-boo...-mode-gui.html

How to disable X or GUI on boot in Debian - http://www.debianadmin.com/how-to-di...in-debian.html

nepalnt21 04-11-2012 11:03 AM

thanks for all of the responses

i ended up trying:

update-rc.d -f gdm3 remove
update-rc.d -f wdm remove

this solved it

frankbell 04-11-2012 09:40 PM

For others who might light on this thread, installing sysv-rc-conf allows you to turn services on and off for various runlevels. It's in the repos.

That was what I used to be able to boot to the CLI without removing the GDM in Debian.

slackergeek 09-10-2013 04:50 PM

Edit your grub.cfg in /boot/grub/grun.cfg
 
Just add "text" at the end of the line "### BEGIN /etc/grub.d/10_linux ###" of your grub.cfg

mine read:

/vmlinuz-3.2.0-4-686-pae root=/dev/mapper/idebian-root ro quiet text


All times are GMT -5. The time now is 10:25 PM.