LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-14-2006, 01:10 PM   #1
deaz
LQ Newbie
 
Registered: Mar 2005
Posts: 2

Rep: Reputation: 0
black screen & freeze when starting xorg/xf86


Hi guys

I'm having problems installing debian on my new laptop. Its a znote 4315 with a Ati Mobility Radeon X600 Gfx card, the screen is made for 1400x1050. Another thing is before i can install debian i need to run the installer with debian-installer/framebuffer=false option.

Okay heres the problem, i've tryed installing packages from the bottom (which i normaly do with debian). But when i 'startx' (or gdm does that) i get errors, hm... i try to configure my XF86Config again and again. Gave up on that, was strange had it up running a couple of times but with a strange resolution like 100x800 and such. Okay then i install xorg and load my xorg.conf from ubuntu which i know works, and i have the modules used in the config and such. Black screen, its still running but cant go to tty0-1-2-3 and so on :\ Kind of locks up.

Can it maybe have something to do with the framebuffer problem i'm having? Cause it looks like the same black screen i get when i boot the installer with framebuffer. (Yeh i know 2 black screens have alot in common but i got a feeling its the same problem.

Hope someone can help me out here :/

Best Regards,
Deaz
 
Old 04-17-2006, 03:22 PM   #2
deaz
LQ Newbie
 
Registered: Mar 2005
Posts: 2

Original Poster
Rep: Reputation: 0
Installed fglrx from ati.com and it worked, sorry for taking your time to read this thread :\
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
direct rendering results in black screen, voodoo3, xorg 6.9.0 grooveharder Linux - Hardware 3 04-11-2006 06:20 PM
how to check logs after a black screen freeze? TokyoYank Fedora 5 11-04-2005 06:45 PM
Init 4: Logging out of KDE causes black screen, freeze with GDM, KDM and XDM DaneM Slackware 14 02-03-2005 07:38 PM
nVidia in Xorg=black screen FXRS Slackware 13 07-01-2004 01:55 AM
Got Linux Installed, At The Command Black Screen, XF86 PROBLEM!! Gnute Slackware 7 04-20-2003 10:43 PM


All times are GMT -5. The time now is 01:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration