LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 07-09-2008, 12:09 PM   #1
FireFerum
Member
 
Registered: Apr 2004
Location: Lawrenceville, GA
Distribution: Debian
Posts: 115

Rep: Reputation: 15
Azureus / Vuze won't see flash player


I am having trouble getting Azureus to see the flash player. I have the flash player installed correctly in iceweasel. I looked at the only other thread dealing with this and they had to put the flash player plugin into seamonkey. I don't know what browser azureus is defaulting to. I tried opening it in the command prompt but I didn't see where it asked for the browser location. I tried putting the flash player in all types of locations and still the same result. Can anyone point me in the right direction?

Thanks
 
Old 09-01-2008, 07:25 AM   #2
panmanphil
LQ Newbie
 
Registered: Aug 2008
Distribution: Debian Unstable
Posts: 1

Rep: Reputation: 0
There is a solution to this

This was not very easy to find, but since I did I thought I'd put it here in hopes that others find more easily.

Assuming you have xulrunner installed, you have to copy or link your /usr/lib/iceweasel/plugins/libflashplayer.so to /usr/lib/xulrunner-1.9/plugins folder. Adjust for whatever version you have, or you may be able to get it work with a /usr/lib/xulrunner/plugins folder.

So even with firefox 3 installed, and having pointed to firefox 3 in the options, I had to do this to get the vuze UI to not show the "get flash player" message.

Quote:
Originally Posted by FireFerum View Post
I am having trouble getting Azureus to see the flash player. I have the flash player installed correctly in iceweasel. I looked at the only other thread dealing with this and they had to put the flash player plugin into seamonkey. I don't know what browser azureus is defaulting to. I tried opening it in the command prompt but I didn't see where it asked for the browser location. I tried putting the flash player in all types of locations and still the same result. Can anyone point me in the right direction?

Thanks
 
Old 09-01-2008, 01:55 PM   #3
FireFerum
Member
 
Registered: Apr 2004
Location: Lawrenceville, GA
Distribution: Debian
Posts: 115

Original Poster
Rep: Reputation: 15
Thanks for the reply. It turns out that two weeks after this e-mail there was an update to Vuze. I installed it and everything started working normally.
 
Old 09-09-2008, 10:18 AM   #4
hgabreu
LQ Newbie
 
Registered: Sep 2008
Location: Brazil
Distribution: Arch
Posts: 3

Rep: Reputation: 0
get Flash here!

Hi FireFerum, I've also installed the newest version of Vuze on Debian, but I couldn't manage to get flash working.
How you solved your problem?

Thanks
 
Old 11-25-2008, 06:25 PM   #5
JayFitzpatrick
LQ Newbie
 
Registered: Nov 2008
Location: Dublin, Ireland
Distribution: Fedora 13
Posts: 7

Rep: Reputation: 0
Hi hgabreu

the following are based of applying this fix on a Fedora system (been a while since i have used Debian so cannot guarantee that everything is the same)

updatedb
locate xulrunner

you should get back something like /usr/lib/xulrunner-1.9/******

cd /usr/lib/xulrunner-1.9/plugins

locate libflashplayer.so

you should get something like

/usr/lib/mozilla/plugins/libflashplayer.so

create a soft link

ln -s /usr/lib/mozilla/plugins/libflashplayer.so

and run ll -s and you should see something like

libflashplayer.so -> /usr/lib/mozilla/plugins/libflashplayer.so

restart vuze and job done

Jay
 
Old 11-26-2008, 05:08 AM   #6
hgabreu
LQ Newbie
 
Registered: Sep 2008
Location: Brazil
Distribution: Arch
Posts: 3

Rep: Reputation: 0
SOLVED - flash on azureus/vuze

Thanks JayFitzpatrick, it worked!

The only difference is that in Debian, by default, the libflashplayer.so is on iceweasel folder (/usr/lib/iceweasel/plugin).

Thanks a lot ;)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
zattoo complains of no flash player installed, but flash is installed TheBrick Linux - Software 8 07-10-2008 08:28 AM
azureus vuze wont start from webmin redhatanirban Linux - Desktop 0 07-08-2008 01:35 AM
Vuze doesn't see flashplayer 9.0.124.0 on Slackware 12.1 trillobyte Slackware 8 05-29-2008 10:29 PM
Azureus choosing MPlayer as default player instead of Kaffeine Hubmasterflex Linux - Software 1 01-27-2007 04:20 AM
No Real Player Sound after Flash Player hroit Linux - Software 4 01-16-2007 03:05 PM


All times are GMT -5. The time now is 07:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration