LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 09-07-2013, 04:38 PM   #1
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,395

Rep: Reputation: 81
ATI Radeon Express 200M on Debian jessie (as of 7 Sep 2013)


Hya,

System Debian jessie (686) as of 2013-09-07, on an ancient laptop with Radeon Express 200M.

Situation X-session fails to kick in.

Troubleshooting facts Xorg.log reads
Code:
 (II) [KMS] drm report modesetting isn't supported.
 (II) UnloadModule: "radeon"
 (EE) Screen(s) found, but none have a usable configuration.
This message shows after hardware detection and no logs on screen detection process thereafter.

Updated packages include xserver-xorg-core:i386, xserver-common:i386, xserver-xorg-video-fbdev:i386, xserver-xorg-video-radeon:i386 and many other ones. Previous dist-upgrade was about 2 months ago.

Troubleshooting guess and act I checked with two kernels, 3.9.6 and 3.10.7 (both compiled from debian repo) with and without drm modesetting. So, it is not kernel realted.

Debian changelog does not have much information.

Question Has anybody already run into this? If so, solved?
I guess some sort of screen section on xorg.conf would do (or EDID??).

cheers
 
Old 09-08-2013, 08:59 AM   #2
odiseo77
Member
 
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 934

Rep: Reputation: 245Reputation: 245Reputation: 245
Quote:
Originally Posted by kaz2100 View Post
I guess some sort of screen section on xorg.conf would do (or EDID??).
I have little experience with ATI cards, but judging from your Xorg.0.log I guess that creating a screen section would help. You can execute the following command as root in order to create a basic xorg.conf and edit it afterwards:

Code:
Xorg -configure
 
Old 09-09-2013, 12:47 AM   #3
EDDY1
Senior Member
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: DebianSqueeze, winsxp, wins7, Debian wheezy, LFS 7.2
Posts: 4,658

Rep: Reputation: 408Reputation: 408Reputation: 408Reputation: 408Reputation: 408
Check this out
http://forums.gentoo.org/viewtopic-t-943020.html
 
Old 09-12-2013, 05:37 PM   #4
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,395

Original Poster
Rep: Reputation: 81
Hya

Thanks for your attension.

I made one step forward.

I followed your suggestions.

Xorg -configure did not work well. However, It gave me a template.
The "Gentoo forum" suggested by EDDY1 gave me detailed instruction, unfortunately did not work well.

I did many things.

Checked legacy fglrx driver: It turned out that my card is not suppported.

Clean install radeon driver: For some reason, X kicked in, but keyboard and mouse are dead.
For some reason, log says that keyboard and mouse are disabled.
Added "AllowEmptyInput" "False" in xorg.conf, did not do much.
I checked that evdev package is installed. HOWEVER, I found that evdev kernel option is not checked. (I do not know how this happened, it was off in older kernels also.) I recompiled my kernel with evdev on.

Then something wierd went on. X kicks in (good), keyboard and mouse work (good), desktop looks ok (good), but color is screwed up when application (iceweasel, gimp) is launched. (NOT GOOD!!)

I do not have time now, I will update.
 
Old 09-15-2013, 08:09 AM   #5
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,395

Original Poster
Rep: Reputation: 81
Hya

Another step ahead.

Now I know that problem is that color depth is 8 (not 16.)

What I did.
I checked color under xfce4 (I was on fluxbox). Color went differently. Under fluxbox, it went totally odd. Under xfce4, it looked like 8bit color. Xorg.log.0 agrees as follows.
Code:
[    71.575] (II) [KMS] drm report modesetting isn't supported.
[    71.576] (II) Loading sub module "fbdevhw"
[    71.576] (II) LoadModule: "fbdevhw"
[    71.576] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    71.592] (II) Module fbdevhw: vendor="X.Org Foundation"
[    71.592]    compiled for 1.12.4, module version = 0.0.2
[    71.592]    ABI class: X.Org Video Driver, version 12.1
[    71.592] (**) FBDEV(1): claimed PCI slot 1@0:5:0
[    71.592] (II) FBDEV(1): using default device
[    71.592] (==) FBDEV(1): Depth 8, (==) framebuffer bpp 8
[    71.592] (==) FBDEV(1): Default visual is PseudoColor
/etc/X11/xorg.conf reads:
Code:
Section "Screen"
        Device  "fbdev"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
Without xserver-xorg-video-fbdev X does not kick in. (no screen found)
I checked with and without "Device fbdev". Also I removed color depth 8 subsection. (none worked!!)

I somewhat think I am on a right track. (Do I need fbdev when I have xserver-xorg-video-radeon?)

Another possible clue is the fact that dmesg says
Code:
[drm] radeon kernel modesetting enabled.
I will update.

+++++++++++ added on edit
Adding nomodeset as a kernel parameter on boot does not solve this situation.
Userspace modesetting is on.

Last edited by kaz2100; 09-15-2013 at 07:09 PM.
 
Old 09-15-2013, 09:26 PM   #6
angryfirelord
Member
 
Registered: Dec 2005
Posts: 491

Rep: Reputation: 57
What happens when you start X without an xorg.conf file?
 
Old 09-15-2013, 11:56 PM   #7
EDDY1
Senior Member
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: DebianSqueeze, winsxp, wins7, Debian wheezy, LFS 7.2
Posts: 4,658

Rep: Reputation: 408Reputation: 408Reputation: 408Reputation: 408Reputation: 408
Mayb since it saying "modesetting isn't supported"
try nomodeset.
What xversion of legacy driver are you running because 13.1 isn't listing it.
http://support.amd.com/us/gpudownloa...eon_linux.aspx
 
Old 09-16-2013, 07:29 AM   #8
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,395

Original Poster
Rep: Reputation: 81
Hya

Thank.

Without xorg.conf, it kicks in but 8 bit color.

I am using an open source driver (Debian jessie repo) xserver-xorg-video-radeon. Not fglrx-legacy, because it does not support Radeon 200M.

Yes, I tried nomodeset, which did not work. However, I don't think it would work. Why? Debian Changelog reads:
Code:
xserver-xorg-video-ati (1:7.2.0-1) unstable; urgency=low
 * New upstream release:
    - KMS-only release, only works with linux-any (or recent kbsd) now.
 * Require libdrm 2.4.4
 -- Julien Cristau <jcristau@debian.org>  Thu, 15 Aug 2013 18:26:42 +0200
And I have 1:7.2.0-1. I guess I need to find out why kernel modesetting is not working.

I will update. cheers
 
Old 09-17-2013, 12:55 PM   #9
angryfirelord
Member
 
Registered: Dec 2005
Posts: 491

Rep: Reputation: 57
Yeah, since it's only a KMS driver, if it doesn't work, it uses the fbdev driver instead which is why the color display is low.

The key issue seems to be this line.
Code:
[KMS] drm report modesetting isn't supported.
Something is preventing it from starting. If you had the fglrx driver installed at one point, make sure it's removed entirely.

What's located in your /etc/modprobe.d directory?

In the meantime, you may also want to follow this bug, which seems to be a similar issue that you're having: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=721796
 
Old 09-17-2013, 07:58 PM   #10
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,395

Original Poster
Rep: Reputation: 81
Hya,

Thanks for your attention.

Yes, I removed fglrx driver completely, I believe.

I have a little issue with modprobe. I compiled everything into kernel. While I was dividing the kernel into modules, I did something wrong. Currently, under recovery process.

I will update.

cheers
 
Old 09-17-2013, 08:57 PM   #11
angryfirelord
Member
 
Registered: Dec 2005
Posts: 491

Rep: Reputation: 57
I'm more or less interested in seeing if there's anything blacklisted. When you install the fglrx driver, you have to blacklist the radeon driver. Some distros also recommend blacklisting the drm module as well, so check and make sure there's nothing crucial that's being prevented from being loaded. Also, depending on how you installed the fglrx driver, it can overwrite some libraries. I know for Slackware this is the case and the mesa package has to be re-installed after removal.

But before you go too crazy, I'd start with a clean slate. If you can, install Debian on a USB drive and upgrade to Jessie (or use a snapshot to do it). Install X and a window manager like fluxbox and see what happens when you start up X.
 
Old 09-19-2013, 04:18 PM   #12
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,395

Original Poster
Rep: Reputation: 81
Hya

I managed to get my lame penguin back again. (not clean install)
Code:
>ls -l /etc/modprobe.d/
total 28
-rw-r--r-- 1 root root  229 Apr 20 19:45 alsa-base-blacklist.conf
-rw-r--r-- 1 root root 1186 Apr 20 19:45 alsa-base.conf
-rw-r--r-- 1 root root  127 Oct  6  2012 dkms.conf
-rw-r--r-- 1 root root  456 Apr 29 06:44 fbdev-blacklist.conf
-rw-r--r-- 1 root root   37 Nov  1  2009 ide.conf
-rw-r--r-- 1 root root  119 Sep  7 20:36 oss-compat.conf
-rw-r--r-- 1 root root   61 Sep 18  2007 sound.conf



>cat /etc/modprobe.d/fbdev-blacklist.conf

# This file blacklists most old-style PCI framebuffer drivers.

blacklist arkfb
blacklist aty128fb
blacklist atyfb
blacklist radeonfb
blacklist cirrusfb
blacklist cyber2000fb
blacklist gx1fb
blacklist gxfb
blacklist kyrofb
blacklist matroxfb_base
blacklist mb862xxfb
blacklist neofb
blacklist nvidiafb
blacklist pm2fb
blacklist pm3fb
blacklist vt8623fb
I will update.

cheers
 
Old 10-01-2013, 08:37 AM   #13
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,395

Original Poster
Rep: Reputation: 81
self reply.

Upgrading xserver-xorg-video-radeon:i386 and related ones from 1:7.2.0-1 to 1:7.2.0-1+b1 did not resolve the problem.

Still dmesg says kernel modesetting is on, while Xorg.0.log says off.

cheers
 
Old 12-02-2013, 06:24 AM   #14
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,395

Original Poster
Rep: Reputation: 81
self reply

After upgrading kernel to 3.11.8, still problem persists. However, following error message shows up.
Code:
(EE) open /dev/dri/card0: No such file or directory
Then, dogpile lead me several web sites.

I followed the instruction, (modified several kernel options.) then BINGO.

thanks for your help.

Have a happy penguin
 
2 members found this post helpful.
  


Reply

Tags
686, ati, debian, jessie, radeonexpress200m


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ati radeon express 200m on laptop 1280x800 j-ray *BSD 2 01-08-2008 03:46 AM
Blank Screen on ATI Radeon Express 200M DumberDrummer Fedora 12 01-24-2007 05:52 PM
ATI EXPRESS 200M Issues with OpenGL SUSE 10.0 areswargod03 Linux - Hardware 0 03-04-2006 06:16 PM
Laptop with Radeon Express 200M and suse 9.3 problems ... miamitj Suse/Novell 2 09-07-2005 12:51 PM
Ati Radeon Express 200M FedoraUsr Linux - Laptop and Netbook 4 08-28-2005 11:20 AM


All times are GMT -5. The time now is 05:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration