LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 09-24-2004, 08:56 PM   #1
pjpeter
Member
 
Registered: Sep 2004
Distribution: Debian Sarge RC1 Kernel 2.6.7.1
Posts: 46

Rep: Reputation: 15
ATI Linux Debian Driver Install Issue


Hey, I've been following the directions on the http://xoomer.virgilio.it/flavio.sta...installer.html site pretty much to the letter on my Debian Sarge system. But once I get to 4. Install packages and compile the kernel module I get tons of problems. I think option 4.3 is more promising and it calls for:

"4.3 Build with the make-kpkg command

cd kernel-source-x.y.z
fakeroot make-kpkg --append-to-version "-flavour" --added-modules fglrx-xxx-3.12.0 modules_image

This will build a new package, which you will have to install:

dpkg -i /usr/src/fglrx-xxx-kernel-x.y.z_3.12.0-2+kernelversion_i386.deb
"

And so I went to the consol and entered in: make-kpkg --append-to-version "-flavour" --added-modules fglrx-4.3.0-3.12.0 modules_image

And this happened:

"for module in /usr/src/modules/fglrx-4.3.0-3.12.0 ; do \
if test -d $module; then \
(cd $module; \
if ./debian/rules KVERS="2.6.7-flavour" KSRC="/usr/src/kernel-headers-2.6.7-1-386" \
KMAINT="Unknown Kernel Package Maintainer" KEMAIL="unknown@unconfigured.in.etc.kernel-pkg.conf" \
KPKG_DEST_DIR="/usr/src/kernel-headers-2.6.7-1-386/.." \
KPKG_MAINTAINER="Unknown Kernel Package Maintainer" \
KPKG_EXTRAV_ARG="EXTRAVERSION=-flavour" \
KDREV="10.00.Custom" kdist_image; then \
echo "Module $module processed fine"; \
else \
echo "Module $module failed."; \
if [ "X" != "X" ]; then \
echo "Perhaps $module does not understand --rootcmd?"; \
echo "If you see messages that indicate that it is not"; \
echo "in fact being built as root, please file a bug "; \
echo "against $module."; \
fi; \
echo "Hit return to Continue"; \
read ans; \
fi; \
); \
fi; \
done
make[1]: Entering directory `/usr/src/modules/fglrx-4.3.0-3.12.0'
dh_testdir
/usr/bin/make -C /usr/src/kernel-headers-2.6.7-1-386 SUBDIRS=/usr/src/modules/fglrx-4.3.0-3.12.0 modules
make[2]: Entering directory `/usr/src/kernel-headers-2.6.7-1-386'
CC [M] /usr/src/modules/fglrx-4.3.0-3.12.0/firegl_public.o
/usr/src/modules/fglrx-4.3.0-3.12.0/firegl_public.c:279:17: drm.h: No such file or directory
/usr/src/modules/fglrx-4.3.0-3.12.0/firegl_public.c:294:22: drm_proc.h: No such file or directory
/usr/src/modules/fglrx-4.3.0-3.12.0/firegl_public.c: In function `firegl_init_module':
/usr/src/modules/fglrx-4.3.0-3.12.0/firegl_public.c:592: error: `DRM_PROC_ENTRIES' undeclared (first use in this function)
/usr/src/modules/fglrx-4.3.0-3.12.0/firegl_public.c:592: error: (Each undeclared identifier is reported only once
/usr/src/modules/fglrx-4.3.0-3.12.0/firegl_public.c:592: error: for each function it appears in.)
/usr/src/modules/fglrx-4.3.0-3.12.0/firegl_public.c:598: error: `FGLDRM_proc_list' undeclared (first use in this function)
/usr/src/modules/fglrx-4.3.0-3.12.0/firegl_public.c: At top level:
/usr/src/modules/fglrx-4.3.0-3.12.0/firegl_public.c:285: warning: `FGLDRM_mem_info' defined but not used
make[3]: *** [/usr/src/modules/fglrx-4.3.0-3.12.0/firegl_public.o] Error 1
make[2]: *** [_module_/usr/src/modules/fglrx-4.3.0-3.12.0] Error 2
make[2]: Leaving directory `/usr/src/kernel-headers-2.6.7-1-386'
make[1]: *** [build] Error 2
make[1]: Leaving directory `/usr/src/modules/fglrx-4.3.0-3.12.0'
Module /usr/src/modules/fglrx-4.3.0-3.12.0 failed."

Does anyone have any ideas what I've been doing wrong? I seem to have lots of problems when it comes to installs that ask for the source, but its been better since i got the headers installed.

Thanks a lot,
Peter
 
Old 09-24-2004, 11:43 PM   #2
pjpeter
Member
 
Registered: Sep 2004
Distribution: Debian Sarge RC1 Kernel 2.6.7.1
Posts: 46

Original Poster
Rep: Reputation: 15
See http://www.stanchina.net/~flavio/deb.../msg00113.html for more info on my plight. I'm worried though that if I can make a .deb file that compiles I may still have a problem if I actually try to use it since the patch this person suggests is not official.

Can anyone help?
Peter
 
Old 09-26-2004, 07:31 PM   #3
zero79
Member
 
Registered: Nov 2003
Location: Ohio
Distribution: Debian Unstable
Posts: 460

Rep: Reputation: 30
it may be easier to try kano's ati driver installer script (install-radeon-debian.sh). i don't have an ati card, so i don't know how well it works, but give it a shot.

http://kanotix.com/files/
 
Old 09-27-2004, 08:14 AM   #4
jedimastermopar
Member
 
Registered: Jun 2004
Distribution: fedora core 1 and core 2
Posts: 178

Rep: Reputation: 30
I am having problems getting a radeon installed on woody, and I have downloaded the .sh file you mention but I when I try and run it I get a bash bad interpreter: Permission denied
what am I doing wrong?
If Ijust hijacked this thread please slap me and tell me to create a new thread.
 
Old 09-27-2004, 08:48 AM   #5
JaakRandmets
LQ Newbie
 
Registered: Sep 2004
Location: estonia
Distribution: debian
Posts: 21

Rep: Reputation: 15
Quote:
Originally posted by jedimastermopar
I am having problems getting a radeon installed on woody, and I have downloaded the .sh file you mention but I when I try and run it I get a bash bad interpreter: Permission denied
what am I doing wrong?
If Ijust hijacked this thread please slap me and tell me to create a new thread.
Did you try to run it with root?
 
Old 09-27-2004, 10:15 AM   #6
jedimastermopar
Member
 
Registered: Jun 2004
Distribution: fedora core 1 and core 2
Posts: 178

Rep: Reputation: 30
yep, I decided to scrap woody after some reading, and am installing with the netinstall cd of sarge, but now my computer keeps rebooting, how strange, maybe i'll try it on my other machine.

Last edited by jedimastermopar; 09-27-2004 at 10:23 AM.
 
Old 09-27-2004, 06:28 PM   #7
zero79
Member
 
Registered: Nov 2003
Location: Ohio
Distribution: Debian Unstable
Posts: 460

Rep: Reputation: 30
you may have needed to make the script executable.

Code:
chmod +x install-radeon-debian.sh
sh install-radeon-debian.sh
there was another thread recently with someone who was getting a bunch of restarts after installing sarge. i don't know what the resolution does, but you should see if u can find that old post to help you with ur problem. otherwise start a new post about it so that others know that you're trying to find help with it.

Last edited by zero79; 09-27-2004 at 06:29 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI 9600 Driver Install in Debian coolbreeze7000 Debian 2 05-08-2006 01:52 PM
problem with the new ati driver in debian mechmg93 Linux - Hardware 8 06-23-2005 06:33 PM
SUSE 9.2 on Compaq Armada m700 ATI Driver Issue Jeb911 Linux - Laptop and Netbook 1 02-22-2005 05:55 AM
HELP!! Install ATI Mobility RADEON 9000 driver on Debian Kernel 2.4.18-bf2.4?? herbu Linux - Laptop and Netbook 3 11-21-2004 03:37 AM
ATI Video Card Driver Issue vegetacron Linux - Hardware 1 10-15-2004 10:28 PM


All times are GMT -5. The time now is 05:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration