LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   atheros - no wireless (http://www.linuxquestions.org/questions/debian-26/atheros-no-wireless-473091/)

chameleonic 08-11-2006 04:54 PM

atheros - no wireless
 
I have problems with Atheros wifi card. I use madwifi modules. Installation process went smothly.
make
make install
After reboot I have no wireless card found.
# modprobe ath_pci
WARNING: Error inserting ath_hal (/lib/modules/2.6.15-1-686/net/ath_hal.ko): Invalid module format
WARNING: Error inserting wlan (/lib/modules/2.6.15-1-686/net/wlan.ko): Invalid module format
WARNING: Error inserting ath_rate_sample (/lib/modules/2.6.15-1-686/net/ath_rate_sample.ko): Invalid module format
FATAL: Error inserting ath_pci (/lib/modules/2.6.15-1-686/net/ath_pci.ko): Invalid module format


# iwconfig lo no wireless extensions.

eth0 no wireless extensions.

eth1 no wireless extensions.

sit0 no wireless extensions.


Strangely enough it doesn't work with 2.6.15-1-686 kernel, but it works with 2.6.16-2-686 kernel on the same machine when i boot it into with grub.
I installed madwifi in the past on this machine without problems. Can you people help me to make it work as i new to this Linux thing and don't know where to start. Thank you very much.

Penguin of Wonder 08-12-2006 12:11 AM

What distrobution are you using?

chameleonic 08-12-2006 03:07 AM

I am on Debian Testing with original 2.6.15-1-686 kernel. there is another kernel on this machine 2.6.16-2-686, which works with wireless but has problems with sound system. thats why i prefer 2.6,15-1-686. I installed 2.6.15-1-686 kernel as synaptic upgrade. when i boot grub with 2.6.15-1-686 option i have no wireless but allthe rest of system is usable, when i boot with 2.6.2-2-686 option, sound goes in a loop but i'm online wirelesly. i decided to sort out wireless problem first and then sound. thx for reply.


All times are GMT -5. The time now is 04:59 PM.