LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 01-08-2004, 10:28 PM   #16
eaglegst
Member
 
Registered: Dec 2003
Location: Australia
Distribution: Woody, Sarge, Sid
Posts: 83

Rep: Reputation: 15

The nvidia driver on the official website does not support 2.6 kernel yet.
I suggest you run 2.4.24 for the time being.
However, if you really want to try 2.6 out.
Here is the link for the driver patch provided by leoscape@UK
http://www.minion.de/nvidia.html
 
Old 01-09-2004, 08:13 AM   #17
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 212

Original Poster
Rep: Reputation: 30
Thanks, I used the link you gave and eventually got the driver to compile. But now I get an error msg saying "Unable to load the kernel module 'nvidia.ko'."

Also, I am unable to find nvidia.ko after the nvidia-installer has finished, so I can't even try to load it myself.

Any ideas?

Thanks
Joe
 
Old 01-09-2004, 12:05 PM   #18
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 212

Original Poster
Rep: Reputation: 30
It works!

I also have to 'fess up to making a really, really stupid mistake. I was working under the assumption that I had kernel 2.6 running but when I checked it, it was in fact 2.4.22-bf2.4.

Once that little bit of info came my way, I installed the source and headers and the nvidia driver compiled & installed without any hassle. I updated XF86Config-4 and that was it.

llamakc, eaglest, thanks for your help. If it wasn't for your advice, I'd probably have installed Whinedoze on this machine...

Thanks
Joe
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems installing FreeBSD 5.4 with Asus A7N8X-E Deluxe motherboard Tsuroerusu *BSD 13 10-17-2005 01:59 AM
Have hardware problems with ASUS P5AD2 Premium motherboard den777 Linux - Hardware 16 09-09-2005 09:29 AM
Soyo P4-IS2 motherboard problems with LAN card linux_issues Linux - Hardware 8 07-27-2004 12:37 AM
ACPI Problems with Asus P4B533 Motherboard suselova Linux - Hardware 6 01-07-2004 10:44 AM
Soyo p4-IS2 motherboard problems with LAN card linux_issues Linux - Networking 3 11-04-2003 02:42 PM


All times are GMT -5. The time now is 02:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration