LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 09-28-2003, 11:18 PM   #1
hypermegachi
Member
 
Registered: Sep 2003
Posts: 49

Rep: Reputation: 15
apt + KDE3 = unmet dependencies


hi! i just installed Libranet cuz i got fed up with the real Debian installer which kept screwing up!

anyways, after lots of time wasted trying to apt-get to the unstable sid release...i think my system is working ok now. problem is i can't get KDE3 installed. luckily GNOME worked out ok so at least i have a GUI.

i tried lots of the well known commands:
apt-get update
apt-get dist-upgrade
apt-get install kde
apt-get install kdebase kdethis kdethat kdeblahblah

tried everything and it gives me errors. something along the lines of "Depends: packageX but it is not going to be installed"

and i get a ton of those. i found another thread on this site, and they told me to add all the dependant packages to the apt-get command...so i tried it. and it worked only until i came across a package that wouldn't work.

basically, KDE depends on a package which is replaced by another package. when i try to install the package KDE wants me to install, apt tells me that there's a better package that replaces the old one.

and if i try to remove the old package it'll break a lotta stuff. i actually had to reinstall Libranet because the first time trying to apt-get to unstable screwed everything up hardcore. even the 2nd time (currently) i ran into some trouble until aptitude did wonders for me and installed GNOME...too bad it's only 2.2.

any suggestions?
 
Old 09-29-2003, 08:58 AM   #2
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK - South Coast.
Distribution: Ubuntu (usually the latest....)
Posts: 2,672
Blog Entries: 9

Rep: Reputation: 45
if you look here down towards the end of the thread, you will see the file I had to find and install - once done, the rest was easy.

Did I say easy? the lib mentioned seems to be the one that was at the root of my problem.

Hope this helps

regards

John

p.s. you might have to check all the mirrors for the file/library, because there was only 2 or 3 that had it, the rest just "404'd" me.

Last edited by bigjohn; 09-29-2003 at 09:02 AM.
 
Old 09-29-2003, 09:18 AM   #3
Strike
Member
 
Registered: Jun 2001
Location: Houston, TX, USA
Distribution: Debian
Posts: 569

Rep: Reputation: 31
It would help to see the exact dependency error messages, thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get unmet dependencies, etc. knappster Linux - Software 13 12-14-2005 10:06 PM
apt-get unmet dependencies jeffbarish Debian 9 10-27-2005 12:19 AM
apt-get install not working due to unmet dependencies ibrewale Debian 10 07-26-2005 12:13 PM
Unmet Dependencies on Fedora Core with Apt-get for redhat? jon_k Linux - Software 3 05-03-2004 12:23 PM
apt-get & unmet dependencies! beecee Debian 1 01-09-2004 07:44 AM


All times are GMT -5. The time now is 07:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration