LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 03-19-2006, 05:04 PM   #1
zakkeyboorock
LQ Newbie
 
Registered: Dec 2004
Location: Turkey
Distribution: Debian/Testing
Posts: 26

Rep: Reputation: 15
Question apt-get uprade problem in debian sid


when i tried to make an upgrade, i am takin this error message

Code:
Reading package lists... Done
Building dependency tree... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies.
  gnome-media: Depends: libgnome-media0 but it is not installed
               Depends: gnome-media-common (= 2.12.0-4) but it is not installed
E: Unmet dependencies. Try using -f.
what i have to do fix this?
 
Old 03-19-2006, 05:23 PM   #2
dracae
Member
 
Registered: Feb 2006
Location: Oklahoma
Distribution: Debian Sid and Etch
Posts: 423

Rep: Reputation: 30
apt-get -f install
 
Old 03-19-2006, 05:25 PM   #3
zakkeyboorock
LQ Newbie
 
Registered: Dec 2004
Location: Turkey
Distribution: Debian/Testing
Posts: 26

Original Poster
Rep: Reputation: 15
i've tried but failed
 
Old 03-19-2006, 05:38 PM   #4
dracae
Member
 
Registered: Feb 2006
Location: Oklahoma
Distribution: Debian Sid and Etch
Posts: 423

Rep: Reputation: 30
What was the output?
 
Old 03-20-2006, 06:29 AM   #5
RanDrake10
Member
 
Registered: Oct 2004
Location: Florida
Distribution: Debian
Posts: 319

Rep: Reputation: 30
Make the file "/etc/apt/apt.conf" and add "APT:efault-Release "testing";", change testing to your version, then add stable,testing,unstable repos to sources.list.
This will pin the testing repos but the others will still be available.
 
Old 03-20-2006, 02:11 PM   #6
zakkeyboorock
LQ Newbie
 
Registered: Dec 2004
Location: Turkey
Distribution: Debian/Testing
Posts: 26

Original Poster
Rep: Reputation: 15
I've tried -f install it worked but now i have a problem like that

Code:
 apt-get upgrade
Reading package lists... Done
Building dependency tree... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies.
  postgresql-common: Depends: postgresql-client-common but it is not installed
E: Unmet dependencies. Try using -f.
Then

Code:
apt-get -f install
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies...Done
The following extra packages will be installed:
  postgresql-client-common
The following NEW packages will be installed
  postgresql-client-common
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
9 not fully installed or removed.
Need to get 0B/31.0kB of archives.
After unpacking 90.1kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 106279 files and directories currently installed.)
Unpacking postgresql-client-common (from .../postgresql-client-common_46_all.deb) ...
dpkg: error processing /var/cache/apt/archives/postgresql-client-common_46_all.deb (--unpack):
 trying to overwrite `/etc/postgresql-common/user_clusters', which is also in package postgresql-common
Errors were encountered while processing:
 /var/cache/apt/archives/postgresql-client-common_46_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
How can i fix it??

Last edited by zakkeyboorock; 03-20-2006 at 02:39 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
will the ltmodem drivers work in debian sid (knoppix sid) maximalred Debian 5 05-29-2009 10:44 AM
Debian SID problem horatiub Debian 5 09-18-2005 03:48 PM
Problem with java in Debian (sid) yarjar Debian 2 06-19-2005 01:52 AM
[Debian Sid] apt problem goRen Linux - Newbie 1 09-26-2004 12:16 AM
Ok, when one runs apt-get on knoppix does it update it to the full debian sid version maximalred Debian 1 06-24-2004 06:45 AM


All times are GMT -5. The time now is 02:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration