Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Debian This forum is for the discussion of Debian Linux.


  Search this Thread
Old 04-02-2005, 11:56 PM   #1
Registered: Jul 2003
Location: Fort Worth, Texas
Distribution: Mepis Linux 2004
Posts: 547

Rep: Reputation: 30
apt-get is stuck on 'scrollkeeper' package

I messed up gnome, and now when I try and apt-get -f install, it sets up scrollkeeper and then locks up when it rebuilds the database. How can I fix it so the database doesn't lock up when it rebuilds?

Here's a log
root@4[jon_k]# apt-get -f install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
gedit gedit-common gnome-applets gnome-panel gnome-panel-data libecal6
libedataserver3 libpanel-applet2-0
Suggested packages:
gnome-terminal x-terminal-emulator
The following packages will be REMOVED:
The following NEW packages will be installed:
gedit gnome-applets
The following packages will be upgraded:
gedit-common gnome-panel gnome-panel-data libecal6 libedataserver3
6 upgraded, 2 newly installed, 1 to remove and 784 not upgraded.
8 not fully installed or removed.
Need to get 12.1MB of archives.
After unpacking 45.1kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 testing/main gedit 2.8.3-1 [441kB]
Get:2 testing/main gedit-common 2.8.3-1 [1823kB]
Get:3 testing/main libpanel-applet2-0 2.8.3-1 [76.2kB]
Get:4 testing/main gnome-panel 2.8.3-1 [406kB]
Get:5 testing/main gnome-panel-data 2.8.3-1 [2479kB]
Get:6 testing/main libedataserver3 1.0.4-1 [70.1kB]
Get:7 testing/main libecal6 1.0.4-1 [241kB]
Get:8 testing/main gnome-applets 2.8.2-1 [470kB]
Get:9 testing/main gnome-applets-data 2.8.2-1 [6118kB]
Fetched 12.1MB in 1m26s (141kB/s)
(Reading database ... 112785 files and directories currently installed.)
Removing gnome-gv ...
Selecting previously deselected package gedit.
(Reading database ... 112787 files and directories currently installed.)
Unpacking gedit (from .../gedit_2.8.3-1_i386.deb) ...
Selecting previously deselected package gedit-common.
Preparing to replace gedit-common 2.8.2-1 (using .../gedit-common_2.8.3-1_all.deb) ...
Unpacking replacement gedit-common ...
Preparing to replace libpanel-applet2-0 2.8.2-2 (using .../libpanel-applet2-0_2.8.3-1_i386.deb) ...
Unpacking replacement libpanel-applet2-0 ...
Preparing to replace gnome-panel 2.8.2-2 (using .../gnome-panel_2.8.3-1_i386.deb) ...
Unpacking replacement gnome-panel ...
Selecting previously deselected package gnome-panel-data.
Preparing to replace gnome-panel-data 2.8.2-2 (using .../gnome-panel-data_2.8.3-1_all.deb) ...
Unpacking replacement gnome-panel-data ...
Preparing to replace libedataserver3 1.0.3-1 (using .../libedataserver3_1.0.4-1_i386.deb) ...
Unpacking replacement libedataserver3 ...
Preparing to replace libecal6 1.0.3-1 (using .../libecal6_1.0.4-1_i386.deb) ...
Unpacking replacement libecal6 ...
Selecting previously deselected package gnome-applets.
Unpacking gnome-applets (from .../gnome-applets_2.8.2-1_i386.deb) ...
Selecting previously deselected package gnome-applets-data.
Preparing to replace gnome-applets-data 2.8.2-1 (using .../gnome-applets-data_2.8.2-1_all.deb) ...
Unpacking replacement gnome-applets-data ...
Setting up scrollkeeper (0.3.14-9.1) ...
Rebuilding the database. This may take some time.
Old 04-03-2005, 05:55 AM   #2
Registered: Oct 2004
Location: Germany
Distribution: Debian
Posts: 274

Rep: Reputation: 34
try removing it conpletely using
apt-get [--purge] remove scrollkeeper
and then do
apt-get install
without further parameters (or maybe add -f)
and afterwards try reinstalling it

maybe this helps...
Old 04-03-2005, 07:51 PM   #3
Senior Member
Registered: Nov 2000
Location: Seattle, WA USA
Distribution: Ubuntu @ Home, RHEL @ Work
Posts: 3,892
Blog Entries: 1

Rep: Reputation: 66
Moved: This thread is more suitable in Distributions - Debian and has been moved accordingly to help your thread/question get the exposure it deserves.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
latex2e package unavailable in package manager or apt-get cesine Debian 2 07-11-2006 03:31 PM
apt-get stuck at 0% sh4d0w13 Debian 1 07-31-2005 04:10 PM
HELP with apt-getHow come when I tried to use apt-get to remove a package to regain redss Linux - Newbie 1 08-23-2004 12:59 AM
Does apt-get install <package> upgrade the package if it is already installed? davidas Debian 4 04-05-2004 07:12 PM
apt-get is stuck h2gofast Debian 17 03-29-2004 11:02 PM

All times are GMT -5. The time now is 02:35 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration