LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-08-2008, 05:26 AM   #1
PBSchmidt
Member
 
Registered: Aug 2004
Location: Aachen, Germany
Distribution: Debian Sarge
Posts: 129

Rep: Reputation: 15
apt-get gets stuck at vim-common


Hello folks,

after using my sarge home server long and happily, I now have an issue (for some weeks): every time I try to apt-get anything, I have the following error message:

Code:
# apt-get upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  vim: Depends: vim-common (>= 1:6.3-071+1sarge3) but it is not installed
E: Unmet dependencies. Try using -f.
well then I used -f, for the system told me (and up to now, that always helped):

Code:
#apt-get -f install 
...
Unpacking vim-common (from .../vim-common_1%3a6.3-071+1sarge3_all.deb) ...
dpkg: error processing /var/cache/apt/archives/vim-common_1%3a6.3-071+1sarge3_all.deb (--unpack):
 trying to overwrite `/usr/share/doc/vim-common', which is also in package vim-doc
Errors were encountered while processing:
 /var/cache/apt/archives/vim-common_1%3a6.3-071+1sarge3_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
...

Umh . I am quite puzzled. No clue on the net , neither. Today, I apt-get removed vim vim-full vim-common, but no change. Are my packages fouled up? apt database is always kept fresh and up to date ... Oh, by the way, vim works on the box - although it is not properly installed?!?

Anyone who has a clue? Your help is much appreciated!

Kind Regards,


Peter

Last edited by PBSchmidt; 01-08-2008 at 10:06 AM. Reason: missed a word ;-)
 
Old 01-08-2008, 07:23 AM   #2
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,229

Rep: Reputation: 175Reputation: 175
If I remember correctly, the vim package was horribly broken in old-stable(aka sarge).

I would first try removing vim-doc, upgrade everything and reinstall(apt-get) it (if needed, it's just documentation).

If it keeps giving you this conflict you could consider a more brutal fix (at your own risk) by forcing it to install:
Code:
dpkg -i --force-all /var/cache/apt/archives/vim-common_1%3a6.3-071+1sarge3_all.deb
.
Using "force" on a productive server is usually a bad idea though...

Last edited by jens; 01-08-2008 at 07:29 AM.
 
Old 01-08-2008, 10:02 AM   #3
PBSchmidt
Member
 
Registered: Aug 2004
Location: Aachen, Germany
Distribution: Debian Sarge
Posts: 129

Original Poster
Rep: Reputation: 15
Hello jens,

thanks for the quick reply
Quote:
I would first try removing vim-doc, upgrade everything and reinstall(apt-get) it
actually, that is almost what I did. I even moved the files manually - no effect .

Anyone else who has an idea? I do not really want to switch the box to etch, as it does not run with the 2.6 kernel (P2-350).

Thanks,

Peter
 
Old 01-08-2008, 10:15 AM   #4
PBSchmidt
Member
 
Registered: Aug 2004
Location: Aachen, Germany
Distribution: Debian Sarge
Posts: 129

Original Poster
Rep: Reputation: 15
Hello Jens,

after considering the risk, I tried your dpkg line - this took the cookie! I dimly remember having done something like that before (for a non-official .deb that was a little crude aka fouled up a bit), as I did not loose my dear Sarge then, I took the risk and it worked out fine. Hooray! I am saved!

So, again, all my ten thumbs up, debian is coooool ! Never had a box that required that little blood, sweat and tears to maintain. And whenever I reach my limit, it's you coolsters out here having the magic spell to make it work anyway.

Have a wonderful day!

Peter
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't apt-get install dovecot-common pk_kala Debian 2 06-05-2007 08:41 AM
Help! All my common applications don't work after apt-get upgrade wongdg Linux - Newbie 3 04-17-2007 09:11 PM
apt-get install samba-common kristof_v Debian 2 02-26-2007 11:11 AM
Apt-get remove & purge nvidia-kernel-common. safe? Penguin of Wonder Ubuntu 2 03-01-2006 12:11 PM
problems setting up libgtk2.0-common via apt-get on debian unstable f3lix Linux - Software 1 04-15-2003 01:41 PM


All times are GMT -5. The time now is 04:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration