LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 10-04-2005, 08:36 AM   #1
hkl8324
Member
 
Registered: Aug 2003
Location: Hong Kong, China
Distribution: Ubuntu 10.04
Posts: 234

Rep: Reputation: 30
Apt-get dist-upgrade woes


Preparing to replace udev 0.056-3 (using .../archives/udev_0.070-2_i386.deb) ...
udev requires a kernel >= 2.6.12, upgrade aborted.

???

i type apt-get disk-upgrade at the console prompt...
after a while, the above error poped up.

i search at Debiann Package at debian.org, but i cant find a kernel version that is >2.6.12...

it is a apt-get problem?

(i am using sarge)
 
Old 10-04-2005, 08:41 AM   #2
samael26
Member
 
Registered: Oct 2004
Location: France, Provence
Distribution: Debian
Posts: 848

Rep: Reputation: 30
Hi,

In your sources.list , you must have main contrib and non-free.

kernel-image package is replaced by linux-image 2.6.12.

Then you'll be able to get rid of the error, after installing your new kernel.

Don't do apt-dist upgrade, that's my advice. Install apt-listbugs and change

your sources : etch ===> sid or unstable if you want it.

Hope that helps.

cheers
 
Old 10-04-2005, 08:42 AM   #3
hkl8324
Member
 
Registered: Aug 2003
Location: Hong Kong, China
Distribution: Ubuntu 10.04
Posts: 234

Original Poster
Rep: Reputation: 30
O...i find the kernel....

but ist it apt-get supposed to handle the dependecies?
 
Old 10-04-2005, 08:56 AM   #4
hkl8324
Member
 
Registered: Aug 2003
Location: Hong Kong, China
Distribution: Ubuntu 10.04
Posts: 234

Original Poster
Rep: Reputation: 30
it seems that it is too late

Code:
debian:/home/hkl8324# dpkg -i kernel-image-2.6-386_2.6.12-10_i386.deb  linux-image-2.6-386_2.6.12-10_i386.deb linux-image-2.6.12-1-386_2.6.12-10_i386.deb
(Reading database ... 116473 files and directories currently installed.)
Preparing to replace kernel-image-2.6-386 1:2.6.12-10 (using kernel-image-2.6-386_2.6.12-10_i386.deb) ...
Unpacking replacement kernel-image-2.6-386 ...
Preparing to replace linux-image-2.6-386 2.6.12-10 (using linux-image-2.6-386_2.6.12-10_i386.deb) ...
Unpacking replacement linux-image-2.6-386 ...
Selecting previously deselected package linux-image-2.6.12-1-386.
Unpacking linux-image-2.6.12-1-386 (from linux-image-2.6.12-1-386_2.6.12-10_i386.deb) ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "en_HK.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
dpkg: dependency problems prevent configuration of linux-image-2.6.12-1-386:
 linux-image-2.6.12-1-386 depends on initrd-tools (>= 0.1.78); however:
  Package initrd-tools is not configured yet.
 linux-image-2.6.12-1-386 depends on module-init-tools (>= 0.9.13); however:
  Package module-init-tools is not configured yet.
dpkg: error processing linux-image-2.6.12-1-386 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-2.6-386:
 linux-image-2.6-386 depends on linux-image-2.6.12-1-386; however:
  Package linux-image-2.6.12-1-386 is not configured yet.
dpkg: error processing linux-image-2.6-386 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kernel-image-2.6-386:
 kernel-image-2.6-386 depends on linux-image-2.6-386; however:
  Package linux-image-2.6-386 is not configured yet.
dpkg: error processing kernel-image-2.6-386 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-image-2.6.12-1-386
 linux-image-2.6-386
 kernel-image-2.6-386
I managed to screw up apt-get....
 
Old 10-04-2005, 09:00 AM   #5
hkl8324
Member
 
Registered: Aug 2003
Location: Hong Kong, China
Distribution: Ubuntu 10.04
Posts: 234

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by samael26
Hi,

In your sources.list , you must have main contrib and non-free.

kernel-image package is replaced by linux-image 2.6.12.

Then you'll be able to get rid of the error, after installing your new kernel.

Don't do apt-dist upgrade, that's my advice. Install apt-listbugs and change

your sources : etch ===> sid or unstable if you want it.

Hope that helps.

cheers
Oh....

Code:
debian:/home/hkl8324# dpkg -i apt-listbugs_0.0.49_all.deb
Selecting previously deselected package apt-listbugs.
(Reading database ... 118354 files and directories currently installed.)
Unpacking apt-listbugs (from apt-listbugs_0.0.49_all.deb) ...
dpkg: dependency problems prevent configuration of apt-listbugs:
 apt-listbugs depends on ruby (>= 1.8); however:
  Package ruby is not installed.
 apt-listbugs depends on libruby1.8 (>= 1.8.1); however:
  Package libruby1.8 is not installed.
 apt-listbugs depends on libdpkg-ruby1.8; however:
  Package libdpkg-ruby1.8 is not installed.
 apt-listbugs depends on libzlib-ruby1.8; however:
  Package libzlib-ruby1.8 is not installed.
 apt-listbugs depends on libintl-gettext-ruby1.8; however:
  Package libintl-gettext-ruby1.8 is not installed.
 apt-listbugs depends on libxml-parser-ruby1.8; however:
  Package libxml-parser-ruby1.8 is not installed.
dpkg: error processing apt-listbugs (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 apt-listbugs
debian:/home/hkl8324# apt-get install apt-listbugs
Reading Package Lists... Done
Building Dependency Tree... Done
apt-listbugs is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  apt-listbugs: Depends: ruby (>= 1.8) but it is not going to be installed
                Depends: libruby1.8 (>= 1.8.1) but it is not going to be installed
                Depends: libdpkg-ruby1.8 but it is not going to be installed
                Depends: libzlib-ruby1.8
                Depends: libintl-gettext-ruby1.8 but it is not going to be installed
                Depends: libxml-parser-ruby1.8 but it is not going to be installed
  hal: Depends: udev (>= 0.063) but 0.056-3 is to be installed
That mean i have to solve the dependencies by hand???

WTF
 
Old 10-04-2005, 09:05 AM   #6
Bremsstrahlung
Member
 
Registered: Jul 2005
Location: Maine, USA
Distribution: Debian & Slackware
Posts: 77

Rep: Reputation: 15
Hey, don't sweat it, I just yesterday had pretty much the SAME problem you have, and with pointers from these guys I got it figured out. Here's what I did:

First, if you want to upgrade to testing go to http://packages.debian.org/testing/base/ and if you want to upgrade to unstable go to http://packages.debian.org/unstable/base/

in there, you WILL find 2.6.12 for whatever your system is. Download that package (I think it's different from what you tried to install).

Now, assuming your sources.list still has your proper dist, do apt-get install mod-init-tools


If that doesn't work, immediately do apt-get -f install.

THEN try to install your new kernel. Once that's done, go about putting in everything (including udev) that it wouldn't let you do before.

Hope that helps!
 
Old 10-04-2005, 09:14 AM   #7
samael26
Member
 
Registered: Oct 2004
Location: France, Provence
Distribution: Debian
Posts: 848

Rep: Reputation: 30
Try what has been suggested by the previous poster.
Apt-listbugs has basically to be installed IMMEDIATELY
after you have the distro installed so that nothing comes in its way.

It is a useful tool to help you manage your installing packages. For
the moment, it is buggy, apt-listbugs says apt-listbugs is buggy
 
Old 10-04-2005, 09:31 AM   #8
hkl8324
Member
 
Registered: Aug 2003
Location: Hong Kong, China
Distribution: Ubuntu 10.04
Posts: 234

Original Poster
Rep: Reputation: 30
I had done: (manually)

Code:
dpkg -i --force-all linux-image-2.6.12-1-386_2.6.12-10_i386.deb linux-image-2.6-386_2.6.12-10_i386.deb kernel-image-2.6-386_2.6.12-10_i386.deb...
but...when i type

Code:
apt-get -f install udev
or

Code:
dpkg -i --force-all udev_0.070-2_i386.deb
this error occured

Code:
udev requires a kernel >= 2.6.12, upgrade aborted.
 
Old 10-04-2005, 09:33 AM   #9
hkl8324
Member
 
Registered: Aug 2003
Location: Hong Kong, China
Distribution: Ubuntu 10.04
Posts: 234

Original Poster
Rep: Reputation: 30
i installed apt-listbugs....but sadly....nothing good happened.
 
Old 10-04-2005, 10:21 AM   #10
hkl8324
Member
 
Registered: Aug 2003
Location: Hong Kong, China
Distribution: Ubuntu 10.04
Posts: 234

Original Poster
Rep: Reputation: 30
I managed to fix the problem now...but at last,

[code]
Setting up at (3.1.9) ...
Starting deferred execution scheduler: atdinvoke-rc.d: initscript atd, action "start" failed.
dpkg: error processing at (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
at
[/code
 
Old 10-04-2005, 11:35 AM   #11
hkl8324
Member
 
Registered: Aug 2003
Location: Hong Kong, China
Distribution: Ubuntu 10.04
Posts: 234

Original Poster
Rep: Reputation: 30
finding "at" is not so important for me, i just reinstalled it...

BIG THANKS GUYS
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get question: dist-upgrade vs upgrade Arodef Fedora 9 06-15-2012 01:33 PM
some help with apt-get dist-upgrade MaTrIx709 Debian 2 09-10-2005 11:13 AM
apt-get dist-upgrade woes (testing - etch) vharishankar Debian 6 06-13-2005 09:43 PM
dist-upgrade woes nagromo Debian 3 10-01-2004 02:47 PM
What's the difference between apt-get upgrade and apt-get dist-upgrade? davidas Linux - Newbie 4 04-04-2004 08:19 PM


All times are GMT -5. The time now is 05:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration