LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 11-14-2005, 03:38 PM   #1
twinkers
Member
 
Registered: Aug 2003
Distribution: Debian Sid
Posts: 153

Rep: Reputation: 30
apt-get dist-upgrade problem after crash (during first update)


My pc crashed (turned out to be a faulty power supply) while I was upgrading. If I run apt-get dist-upgade now I just keep getting: (and the list is growing by the day, it started with openofficerg-kde and the debconf) Sorry it's in Dutch but the errors must be about the same.

Code:
Password:
debian:/home/twinkers# apt-get dist-upgrade
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd... Klaar
Opwaardering wordt doorgerekend... Klaar
0 pakketten opgewaardeerd, 0 nieuwe pakketten ge´nstalleerd, 0 verwijderen en 0 niet opgewaardeerd.
13 pakketten niet volledig ge´nstalleerd of verwijderd.
Er moeten 0B aan archieven opgehaald worden.
Na het uitpakken zal er 0B extra schijfruimte gebruikt worden.
Wilt u doorgaan [J/n]?
Instellen van debconf (1.4.59) ...
Compiling /usr/lib/python2.3/site-packages/uno.py ...
Sorry: TypeError: ('compile() expected string without null bytes',)
Compiling /usr/lib/python2.3/site-packages/unohelper.py ...
Sorry: TypeError: ('compile() expected string without null bytes',)
dpkg: fout bij afhandelen van debconf (--configure):
 subproces post-installation script gaf een foutwaarde 1 terug
dpkg: vereistenproblemen verhinderen de configuratie van console-data:
 console-data is afhankelijk van debconf | debconf-2.0; maar:
  Pakket debconf is nog niet geconfigureerd.
  Pakket debconf-2.0 is niet ge´nstalleerd.
  Pakket debconf die voorziet in debconf-2.0 is nog niet geconfigureerd.
 console-data is afhankelijk van debconf (>= 0.5) | debconf-2.0; maar:
  Pakket debconf is nog niet geconfigureerd.
  Pakket debconf-2.0 is niet ge´nstalleerd.
  Pakket debconf die voorziet in debconf-2.0 is nog niet geconfigureerd.
dpkg: fout bij afhandelen van console-data (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van console-tools:
 console-tools is afhankelijk van debconf | debconf-2.0; maar:
  Pakket debconf is nog niet geconfigureerd.
  Pakket debconf-2.0 is niet ge´nstalleerd.
  Pakket debconf die voorziet in debconf-2.0 is nog niet geconfigureerd.
dpkg: fout bij afhandelen van console-tools (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van libssl0.9.8:
 libssl0.9.8 is afhankelijk van debconf (>= 0.5) | debconf-2.0; maar:
  Pakket debconf is nog niet geconfigureerd.
  Pakket debconf-2.0 is niet ge´nstalleerd.
  Pakket debconf die voorziet in debconf-2.0 is nog niet geconfigureerd.
dpkg: fout bij afhandelen van libssl0.9.8 (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van tasksel:
 tasksel is afhankelijk van debconf (>= 0.5) | debconf-2.0; maar:
  Pakket debconf is nog niet geconfigureerd.
  Pakket debconf-2.0 is niet ge´nstalleerd.
  Pakket debconf die voorziet in debconf-2.0 is nog niet geconfigureerd.
dpkg: fout bij afhandelen van tasksel (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van dictionaries-common:
 dictionaries-common is afhankelijk van debconf (>= 0.5) | debconf-2.0; maar:
  Pakket debconf is nog niet geconfigureerd.
  Pakket debconf-2.0 is niet ge´nstalleerd.
  Pakket debconf die voorziet in debconf-2.0 is nog niet geconfigureerd.
dpkg: fout bij afhandelen van dictionaries-common (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van locales:
 locales is afhankelijk van debconf | debconf-2.0; maar:
  Pakket debconf is nog niet geconfigureerd.
  Pakket debconf-2.0 is niet ge´nstalleerd.
  Pakket debconf die voorziet in debconf-2.0 is nog niet geconfigureerd.
dpkg: fout bij afhandelen van locales (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van cdrecord:
 cdrecord is afhankelijk van debconf; maar:
  Pakket debconf is nog niet geconfigureerd.
dpkg: fout bij afhandelen van cdrecord (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van debconf-utils:
 debconf-utils is afhankelijk van debconf (>= 1.3.20); maar:
  Pakket debconf is nog niet geconfigureerd.
dpkg: fout bij afhandelen van debconf-utils (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van debhelper:
 debhelper is afhankelijk van debconf-utils (>= 1.1.1); maar:
  Pakket debconf-utils is nog niet geconfigureerd.
dpkg: fout bij afhandelen van debhelper (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van java-package:
 java-package is afhankelijk van debhelper; maar:
  Pakket debhelper is nog niet geconfigureerd.
dpkg: fout bij afhandelen van java-package (--configure):
 vereistenproblemen - blijft ongeconfigureerd
Instellen van openoffice.org-kde (2.0.0-2) ...
dpkg (subproces): kon post-installation script niet uitvoeren: Uitvoerbaar formaat fout
dpkg: fout bij afhandelen van openoffice.org-kde (--configure):
 subproces post-installation script gaf een foutwaarde 2 terug
dpkg: vereistenproblemen verhinderen de configuratie van openssl:
 openssl is afhankelijk van libssl0.9.8 (>= 0.9.8a-1); maar:
  Pakket libssl0.9.8 is nog niet geconfigureerd.
dpkg: fout bij afhandelen van openssl (--configure):
 vereistenproblemen - blijft ongeconfigureerd
Fouten gevonden tijdens behandelen van:
 debconf
 console-data
 console-tools
 libssl0.9.8
 tasksel
 dictionaries-common
 locales
 cdrecord
 debconf-utils
 debhelper
 java-package
 openoffice.org-kde
 openssl
E: Sub-process /usr/bin/dpkg returned an error code (1)
debian:/home/twinkers#
 
Old 11-14-2005, 06:35 PM   #2
Moloko
Member
 
Registered: Mar 2004
Location: Netherlands
Distribution: Debian
Posts: 729

Rep: Reputation: 30
Try to install debconf in a seperate process: apt-get install debconf , everything else relies on a functional debconf.

(p.s. wie heeft in g*dsnaam die vertaling gemaakt? Dat is echt niet om aan te zien...)
 
Old 11-16-2005, 11:05 AM   #3
twinkers
Member
 
Registered: Aug 2003
Distribution: Debian Sid
Posts: 153

Original Poster
Rep: Reputation: 30
didn┤t work, just got the same error

(en ja van de vertaling wordt niemand wijzer )
 
Old 11-16-2005, 01:59 PM   #4
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
What about "dpkg --configure -a" to complete half configured packages. Repeat it until it's done if one time doesn't do it.

F÷rstod int ett ord av ditt felmeddelande
 
Old 11-17-2005, 10:49 AM   #5
twinkers
Member
 
Registered: Aug 2003
Distribution: Debian Sid
Posts: 153

Original Poster
Rep: Reputation: 30
Code:
Password:
debian:/home/twinkers# dpkg --configure -a
Instellen van debconf (1.4.59) ...
Compiling /usr/lib/python2.3/site-packages/uno.py ...
Sorry: TypeError: ('compile() expected string without null bytes',)
Compiling /usr/lib/python2.3/site-packages/unohelper.py ...
Sorry: TypeError: ('compile() expected string without null bytes',)
dpkg: fout bij afhandelen van debconf (--configure):
 subproces post-installation script gaf een foutwaarde 1 terug
dpkg: vereistenproblemen verhinderen de configuratie van cdrecord:
 cdrecord is afhankelijk van debconf; maar:
  Pakket debconf is nog niet geconfigureerd.
dpkg: fout bij afhandelen van cdrecord (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van console-tools:
 console-tools is afhankelijk van debconf | debconf-2.0; maar:
  Pakket debconf is nog niet geconfigureerd.
  Pakket debconf-2.0 is niet ge´nstalleerd.
  Pakket debconf die voorziet in debconf-2.0 is nog niet geconfigureerd.
dpkg: fout bij afhandelen van console-tools (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van libssl0.9.8:
 libssl0.9.8 is afhankelijk van debconf (>= 0.5) | debconf-2.0; maar:
  Pakket debconf is nog niet geconfigureerd.
  Pakket debconf-2.0 is niet ge´nstalleerd.
  Pakket debconf die voorziet in debconf-2.0 is nog niet geconfigureerd.
dpkg: fout bij afhandelen van libssl0.9.8 (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van openssl:
 openssl is afhankelijk van libssl0.9.8 (>= 0.9.8a-1); maar:
  Pakket libssl0.9.8 is nog niet geconfigureerd.
dpkg: fout bij afhandelen van openssl (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van base-config:
 base-config is afhankelijk van debconf (>= 1.3.22) | cdebconf (>= 0.43); maar:
  Pakket debconf is nog niet geconfigureerd.
  Pakket cdebconf is niet ge´nstalleerd.
 base-config is afhankelijk van console-tools; maar:
  Pakket console-tools is nog niet geconfigureerd.
dpkg: fout bij afhandelen van base-config (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van console-data:
 console-data is afhankelijk van debconf | debconf-2.0; maar:
  Pakket debconf is nog niet geconfigureerd.
  Pakket debconf-2.0 is niet ge´nstalleerd.
  Pakket debconf die voorziet in debconf-2.0 is nog niet geconfigureerd.
 console-data is afhankelijk van debconf (>= 0.5) | debconf-2.0; maar:
  Pakket debconf is nog niet geconfigureerd.
  Pakket debconf-2.0 is niet ge´nstalleerd.
  Pakket debconf die voorziet in debconf-2.0 is nog niet geconfigureerd.
dpkg: fout bij afhandelen van console-data (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van adduser:
 adduser is afhankelijk van debconf | debconf-2.0; maar:
  Pakket debconf is nog niet geconfigureerd.
  Pakket debconf-2.0 is niet ge´nstalleerd.
  Pakket debconf die voorziet in debconf-2.0 is nog niet geconfigureerd.
dpkg: fout bij afhandelen van adduser (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van locales:
 locales is afhankelijk van debconf | debconf-2.0; maar:
  Pakket debconf is nog niet geconfigureerd.
  Pakket debconf-2.0 is niet ge´nstalleerd.
  Pakket debconf die voorziet in debconf-2.0 is nog niet geconfigureerd.
dpkg: fout bij afhandelen van locales (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van tasksel:
 tasksel is afhankelijk van debconf (>= 0.5) | debconf-2.0; maar:
  Pakket debconf is nog niet geconfigureerd.
  Pakket debconf-2.0 is niet ge´nstalleerd.
  Pakket debconf die voorziet in debconf-2.0 is nog niet geconfigureerd.
dpkg: fout bij afhandelen van tasksel (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van debconf-utils:
 debconf-utils is afhankelijk van debconf (>= 1.3.20); maar:
  Pakket debconf is nog niet geconfigureerd.
dpkg: fout bij afhandelen van debconf-utils (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van dictionaries-common:
 dictionaries-common is afhankelijk van debconf (>= 0.5) | debconf-2.0; maar:
  Pakket debconf is nog niet geconfigureerd.
  Pakket debconf-2.0 is niet ge´nstalleerd.
  Pakket debconf die voorziet in debconf-2.0 is nog niet geconfigureerd.
dpkg: fout bij afhandelen van dictionaries-common (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van libneon24:
 libneon24 is afhankelijk van libssl0.9.8 (>= 0.9.8a-1); maar:
  Pakket libssl0.9.8 is nog niet geconfigureerd.
dpkg: fout bij afhandelen van libneon24 (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van debhelper:
 debhelper is afhankelijk van debconf-utils (>= 1.1.1); maar:
  Pakket debconf-utils is nog niet geconfigureerd.
dpkg: fout bij afhandelen van debhelper (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van java-package:
 java-package is afhankelijk van debhelper; maar:
  Pakket debhelper is nog niet geconfigureerd.
dpkg: fout bij afhandelen van java-package (--configure):
 vereistenproblemen - blijft ongeconfigureerd
Fouten gevonden tijdens behandelen van:
 debconf
 cdrecord
 console-tools
 libssl0.9.8
 openssl
 base-config
 console-data
 adduser
 locales
 tasksel
 debconf-utils
 dictionaries-common
 libneon24
 debhelper
 java-package
debian:/home/twinkers#
Doesn't work either, this seems to become a big proble,. Debconf just doens't want to configure
Any other ideas?

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get question: dist-upgrade vs upgrade Arodef Fedora 9 06-15-2012 01:33 PM
Does Apt-get dist-upgrade automatically update the kernel? adamb10 Ubuntu 2 07-10-2005 10:57 AM
apt-get dist-upgrade problem (havnt done it in a while...) r3dhatter Debian 1 08-29-2004 12:16 AM
Serious problem with apt-get dist-upgrade - encoutered fatal errors while upgrading! DarkLight Debian 3 08-06-2004 02:22 PM
What's the difference between apt-get upgrade and apt-get dist-upgrade? davidas Linux - Newbie 4 04-04-2004 08:19 PM


All times are GMT -5. The time now is 10:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration