LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   apt-get autoremove (http://www.linuxquestions.org/questions/debian-26/apt-get-autoremove-834576/)

cccc 09-26-2010 09:04 AM

apt-get autoremove
 
hi

I'd like to clean packages on my Lenny with Gnome using apt-get autoremove and I get this output:
Code:

# apt-get autoremove
Reading package lists... Done
Building dependency tree     
Reading state information... Done
The following packages were automatically installed and are no longer required:
  bluez-gnome libsdl1.2debian libsdl1.2debian-alsa libepc-ui-1.0-1 python-gst0.10 libmtp7 gcalctool libpth20 gnome-nettool libepc-1.0-1 libgtk-vnc-1.0-0 libgksu1.2-0
  python-notify aspell pkg-config libgda3-common python-gnome2-extras gucharmap libgksuui1.0-1 libosp5 evolution-exchange libspectre1 gnome-network-admin libsvga1
  gnome-power-manager unzip gnome-cards-data totem-plugins gnome-screensaver rhythmbox w3c-dtd-xhtml python-gdata gedit liblircclient0 python-gtksourceview2 gtk2-engines-pixbuf
  system-config-printer libpt-1.10.10-plugins-alsa gnome-themes seahorse libggzmod4 mysql-common totem-common vinagre swfdec-gnome libpt-1.10.10 libgpod3 libgadu3 libgalago3
  guile-1.8-libs libmysqlclient15off python-gtkmozembed python-gtkhtml2 p7zip gedit-common gnome-themes-extras libhesiod0 finger libmusicbrainz4c2a fast-user-switch-applet arj
  gnome-volume-manager gtk2-engines libgtksourceview2.0-common libkpathsea4 eog libgtksourceview2.0-0 libavahi-gobject0 gnome-backgrounds python-eggtrayicon python-sexy
  python-xdg gnome-spell libggz2 vino evince gnome-app-install libopal-2.2 totem-gstreamer libgnomevfs2-bin zip python-gdbm gnome-core dmz-cursor-theme python-4suite-xml
  liblua5.1-0 libmeanwhile1 libgda3-3 svgalibg1 libpt-1.10.10-plugins-v4l libgpgme11 libggzcore9 libgmyth0 gconf-editor libzephyr3 gnome-system-tools gnuchess
  gstreamer0.10-gnomevfs libavahi-ui0 gstreamer0.10-tools totem-mozilla libgdl-1-0 file-roller libopenobex1 libspeexdsp1 libgdl-1-common gnome-vfs-obexftp
The following packages will be REMOVED:
  arj aspell bluez-gnome dmz-cursor-theme eog evince evolution-exchange fast-user-switch-applet file-roller finger gcalctool gconf-editor gedit gedit-common gnome-app-install
  gnome-backgrounds gnome-cards-data gnome-core gnome-nettool gnome-network-admin gnome-power-manager gnome-screensaver gnome-spell gnome-system-tools gnome-themes
  gnome-themes-extras gnome-vfs-obexftp gnome-volume-manager gnuchess gstreamer0.10-gnomevfs gstreamer0.10-tools gtk2-engines gtk2-engines-pixbuf gucharmap guile-1.8-libs
  libavahi-gobject0 libavahi-ui0 libepc-1.0-1 libepc-ui-1.0-1 libgadu3 libgalago3 libgda3-3 libgda3-common libgdl-1-0 libgdl-1-common libggz2 libggzcore9 libggzmod4 libgksu1.2-0
  libgksuui1.0-1 libgmyth0 libgnomevfs2-bin libgpgme11 libgpod3 libgtk-vnc-1.0-0 libgtksourceview2.0-0 libgtksourceview2.0-common libhesiod0 libkpathsea4 liblircclient0
  liblua5.1-0 libmeanwhile1 libmtp7 libmusicbrainz4c2a libmysqlclient15off libopal-2.2 libopenobex1 libosp5 libpt-1.10.10 libpt-1.10.10-plugins-alsa libpt-1.10.10-plugins-v4l
  libpth20 libsdl1.2debian libsdl1.2debian-alsa libspectre1 libspeexdsp1 libsvga1 libzephyr3 mysql-common p7zip pkg-config python-4suite-xml python-eggtrayicon python-gdata
  python-gdbm python-gnome2-extras python-gst0.10 python-gtkhtml2 python-gtkmozembed python-gtksourceview2 python-notify python-sexy python-xdg rhythmbox seahorse svgalibg1
  swfdec-gnome system-config-printer totem-common totem-gstreamer totem-mozilla totem-plugins unzip vinagre vino w3c-dtd-xhtml zip
0 upgraded, 0 newly installed, 107 to remove and 0 not upgraded.
After this operation, 216MB disk space will be freed.
Do you want to continue [Y/n]?

Have you never get problems after apt-get autoremove?

cccc 09-26-2010 09:25 AM

I've done but a lot of tools like gedit, zip, unzip etc. were tough removed:
Code:

Do you want to continue [Y/n]? y
(Reading database ... 87098 files and directories currently installed.)
Removing arj ...
Removing gnome-spell ...
Removing aspell ...
Removing bluez-gnome ...
Removing dmz-cursor-theme ...
Removing gnome-core ...
Removing eog ...
Removing evince ...
Removing evolution-exchange ...
Removing fast-user-switch-applet ...
Removing file-roller ...
Removing gnome-nettool ...
Removing finger ...
Removing gcalctool ...
Removing gconf-editor ...
Removing gedit ...
Removing gedit-common ...
Removing gnome-app-install ...
Removing gnome-backgrounds ...
Removing gnome-cards-data ...
Removing gnome-network-admin ...
Removing gnome-power-manager ...
Removing gnome-screensaver ...
Removing gnome-system-tools ...
Removing gnome-themes ...
Removing gnome-themes-extras ...
Removing gnome-vfs-obexftp ...
Removing gnome-volume-manager ...
Removing gnuchess ...
Removing totem-plugins ...
Removing totem-mozilla ...
Removing totem-gstreamer ...
Removing rhythmbox ...
Removing gstreamer0.10-gnomevfs ...
Removing gstreamer0.10-tools ...
Removing gtk2-engines ...
Removing gtk2-engines-pixbuf ...
Removing gucharmap ...
Removing guile-1.8-libs ...
Removing libavahi-gobject0 ...
Removing vinagre ...
Removing libavahi-ui0 ...
Removing libepc-ui-1.0-1 ...
Removing libepc-1.0-1 ...
Removing libgadu3 ...
Removing libgalago3 ...
Removing python-gnome2-extras ...
Removing libgda3-3 ...
Removing libgda3-common ...
Removing libgdl-1-0 ...
Removing libgdl-1-common ...
Removing libggzmod4 ...
Removing libggzcore9 ...
Removing libggz2 ...
Removing libgksu1.2-0 ...
Removing libgksuui1.0-1 ...
Removing libgmyth0 ...
Removing libgnomevfs2-bin ...
Removing seahorse ...
Removing libgpgme11 ...
Removing libgpod3 ...
Removing libgtk-vnc-1.0-0 ...
Removing python-gtksourceview2 ...
Removing libgtksourceview2.0-0 ...
Removing libgtksourceview2.0-common ...
Removing libzephyr3 ...
Removing libhesiod0 ...
Removing libkpathsea4 ...
Removing liblircclient0 ...
Removing liblua5.1-0 ...
Removing libmeanwhile1 ...
Removing libmtp7 ...
Removing libmusicbrainz4c2a ...
Removing libmysqlclient15off ...
Removing libopal-2.2 ...
Removing libopenobex1 ...
Removing libosp5 ...
Removing libpt-1.10.10 ...
Removing libpt-1.10.10-plugins-alsa ...
Removing libpt-1.10.10-plugins-v4l ...
Removing libpth20 ...
Removing libsdl1.2debian ...
Removing libsdl1.2debian-alsa ...
Removing libspectre1 ...
Removing libspeexdsp1 ...
Removing svgalibg1 ...
Removing libsvga1 ...
Removing mysql-common ...
Removing p7zip ...
Removing pkg-config ...
Removing python-4suite-xml ...
Removing python-eggtrayicon ...
Removing python-gdata ...
Removing python-gdbm ...
Removing python-gst0.10 ...
Removing python-gtkhtml2 ...
Removing python-gtkmozembed ...
Removing system-config-printer ...
Removing python-notify ...
Removing python-sexy ...
Removing python-xdg ...
Removing swfdec-gnome ...
Removing totem-common ...
Removing unzip ...
Removing vino ...
Removing w3c-dtd-xhtml ...
Removing zip ...
Processing triggers for man-db ...
Processing triggers for menu ...
Processing triggers for python-support ...
Processing triggers for hal ...
Regenerating hal fdi cache ...
 * Restarting Hardware abstraction layer hald


eSelix 09-26-2010 10:45 AM

You have been warned what will be removed. If you do not want remove some packages mark them as "not automatically installed" thorough aptitude or synaptic.

Absent Minded 09-27-2010 02:43 AM

You can also mark something as not auto-installed to meet dependencies by telling apt-get to install it. If there are no upgrades for the package and it is already installed it will just mark the package as manually installed and not change anything. So, typing "# apt-get install foo" will mark the foo package manually installed when it is processed.


All times are GMT -5. The time now is 08:01 AM.