LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 01-09-2004, 08:15 AM   #1
beecee
LQ Newbie
 
Registered: Jan 2004
Distribution: Debian unstable (Knoppix hdinstall)
Posts: 5

Rep: Reputation: 0
apt-get & unmet dependencies!


Hi all,
I am a former RedHat user, new to Debian, running a Knoppix 3.2 hdinstall. All has been well with the apt-get basics, until I tried 'apt-get dist-upgrade' (as root, of course!!), or 'apt-get install kernel-package' in preparation to install my first kernel. Here is the error:

root# apt-get install kernel-package
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these: Sorry, but the following packages have unmet dependencies:
libqt3-mt-dev: Depends: libxcursor-dev but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

OK, so I run 'apt-get' -f install:

root# apt-get -f install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
libxcursor-dev
The following NEW packages will be installed:
libxcursor-dev
0 packages upgraded, 1 newly installed, 0 to remove and 606 not upgraded.
17 packages not fully installed or removed.
Need to get 0B/29.2kB of archives. After unpacking 139kB will be used.
Do you want to continue? [Y/n] y
(Reading database ... 85906 files and directories currently installed.)
Unpacking libxcursor-dev (from .../libxcursor-dev_1.0.2-4_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libxcursor-dev_1.0.2-4_i386.deb (--unpack):
trying to overwrite `/usr/X11R6/include/X11/Xcursor/Xcursor.h', which is also in package xlibs-dev
Errors were encountered while processing:
/var/cache/apt/archives/libxcursor-dev_1.0.2-4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

How do I get around this - can I run 'apt-get remove libxcursor-dev' & again try again?? I think not ...
 
Old 01-09-2004, 08:44 AM   #2
beecee
LQ Newbie
 
Registered: Jan 2004
Distribution: Debian unstable (Knoppix hdinstall)
Posts: 5

Original Poster
Rep: Reputation: 0
I think I found the answer in the Knoppix forum. Yay!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get unmet dependencies, etc. knappster Linux - Software 13 12-14-2005 11:06 PM
apt-get unmet dependencies jeffbarish Debian 9 10-27-2005 01:19 AM
apt-get install not working due to unmet dependencies ibrewale Debian 10 07-26-2005 01:13 PM
Unmet Dependencies on Fedora Core with Apt-get for redhat? jon_k Linux - Software 3 05-03-2004 01:23 PM
apt + KDE3 = unmet dependencies hypermegachi Debian 2 09-29-2003 10:18 AM


All times are GMT -5. The time now is 01:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration