LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 10-12-2005, 07:31 AM   #1
Mark_667
Member
 
Registered: Aug 2005
Location: Manchester, England
Distribution: Ubuntu 12.10
Posts: 257

Rep: Reputation: 25
APIC error on AMD 64-bit Debian


Hi,
I just upgraded to the AMD-64 bit optimised verion of Debian but I get a load of errors on start up saying: APIC error on cpuo 40(40) I've googled around and found the following post
Quote:
Your boot log reveals that you're
> using ACPI and IO-APIC on a SiS chipset. Disable those and try
> again -- I wouldn't bet on ACPI+IO-APIC working on SiS.
How do I do this, especially as I can't boot past this stage (it just scrolls these messages up the screen for ages).

Please help,
Mark
 
Old 10-19-2005, 01:24 PM   #2
Mark_667
Member
 
Registered: Aug 2005
Location: Manchester, England
Distribution: Ubuntu 12.10
Posts: 257

Original Poster
Rep: Reputation: 25
For a time I got past this bit and could boot normally into Linux. I just switched it on one day and it worked, albeit with the message still popping up erratically on startup but not nearly as much as before. Now though, I'm back to square one with exactly the same problem as described above but having made no obvious changes to the system that could have caused this.
please help
 
Old 10-20-2005, 12:16 AM   #3
bobbens
Member
 
Registered: Sep 2004
Location: Barcelona
Distribution: Debian, FreeBSD, Gentoo
Posts: 586

Rep: Reputation: 30
try setting noapci and nolapic on bootup. Edit your /boot/grub/menu.lst and on the line that says kernel (for your current kernel) add "noapic nolapic" so it should look somethingl ike this:
Code:
kernel          /vmlinuz-2.6.10-master-r2 root=/dev/hda4 ro noapic nolapic
This disables apic and lapic on boot up, without these flags for example the A7N8X-X motherboards wont work properly (gives you DMA timer expiry's like crazy). Try it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.3 AMD 4400+ Dual Core installation APIC kernel panic lostowl Suse/Novell 6 12-27-2006 07:22 AM
64 bit AMD jan_bosjes Linux - Software 1 01-30-2005 09:02 AM
assembler for AMD MP (32 bit) vose Programming 2 01-21-2005 03:59 PM
32 bit kernel on 64 bit AMD machine dipsae Linux - Software 5 10-01-2004 10:03 AM
AMD 64 bit vs Dual AMD MP 2400+ GATTACA Linux - Hardware 2 06-02-2004 04:54 PM


All times are GMT -5. The time now is 10:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration