LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-28-2004, 07:35 AM   #1
OlegL
LQ Newbie
 
Registered: Aug 2004
Posts: 6

Rep: Reputation: 0
AltGr key does not work


Dear All,
after upgrading Debian to Sarge the AltGr key stop working properly. I am using German Keyboard. I can not get |, @, ~ symbols. This only happens in KDE. In Konsole everything works fine. I tried to choose different keyboard layouts in Control Center but it did not help.
I tried
xmodmap -e "keycode 113 = Mode_switch"
but it also did not help
my XF86Config-4:
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105" (I also tried 104)
Option "XkbLayout" "de"
I have this problem on my Notebook.
Thanks a lot in advance
Oleg
 
Old 08-28-2004, 10:19 AM   #2
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 51
try:

dpkg-reconfigure console-data

reboot
 
Old 08-28-2004, 06:00 PM   #3
Borka
Member
 
Registered: Jun 2004
Location: Sweden
Distribution: Ubuntu right now :/
Posts: 85

Rep: Reputation: 15
Well I from sweden and have the same problem.. with the Debian installer rc1..
 
Old 08-28-2004, 06:55 PM   #4
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 51
I don't use kde nor gnome, i use icewm, well, i installed sarge via cd1 and then dist-upgraded to sarge, i did a 'dpkg-reconfigure xserver-xfree86' after the upgrade, and in the keyboard section, instead of typing 'pc 104' i typed my keyboard model:

Logitech iTouch

and on the next screen:

es

for the spanish keyboard

altgr works perfectly, try that, maybe it'll work for ya.

Last edited by macondo; 08-28-2004 at 06:58 PM.
 
Old 08-30-2004, 05:49 AM   #5
OlegL
LQ Newbie
 
Registered: Aug 2004
Posts: 6

Original Poster
Rep: Reputation: 0
setxkbmap -rules xfree86 -model pc105 -layout de -option ""
done the job
Where shell I place this command to make X or KDE execute it on startup?
 
Old 09-17-2004, 03:22 AM   #6
weby
LQ Newbie
 
Registered: Sep 2004
Location: spain
Posts: 1

Rep: Reputation: 0
OlegL.many thanks for your info,I had the same problem and it solved it.
About your question,you can write the line in your ~/.bashrc and it will be loaded anytime you start konsole.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AltGr-key on debian-ppc working! ElPuello LinuxQuestions.org Member Success Stories 2 10-26-2004 01:58 PM
AltGr key does not work OlegL Linux - Laptop and Netbook 2 08-30-2004 10:35 AM
X.org AltGR key problem wigry Slackware 3 07-18-2004 01:15 PM
AltGr key not working in X iceman47 Linux - Software 3 03-07-2004 07:27 PM
Can't get my AltGr key to work with Norwegian keyboard layout orjanp Slackware 8 11-02-2003 09:53 AM


All times are GMT -5. The time now is 08:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration