LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 10-09-2003, 10:42 PM   #1
dbkluck
Member
 
Registered: Jun 2003
Location: Washington DC
Distribution: debian sid
Posts: 78

Rep: Reputation: 15
alsamixer- invalid CTL default


i've just installed alsa and built the modules for my kernel. however, i can't seem to get any mixer to work properly, i only get the following error message:

ALSA lib control.c:612:(snd_ctl_open_noupdate) Invalid CTL default
alsamixer: function snd_ctl_open failed for default: No such file or directory

for whatever reason, sound still works once the volume is turned up in gnome's applications>sound and video>volume control (NOT, in gnome-alsamixer, though). however, anytime i shutdown or restart (or more specifically, when alsa is stopped and restarted, which is usually the same thing) i get a message "failed to (re)store mixer settings" and the volume for everything in gnome is set back to mute and has to be manually reset. any ideas what's going on? i did a google for snd_ctl_open_noupdate and found something about wrong versions of libasound2, but apt insists i'm running the most current version of it (i run sid).

any help is appreciated.

david
 
Old 10-13-2003, 04:49 PM   #2
padlamoij
Member
 
Registered: Oct 2002
Location: East Point, GA
Posts: 188

Rep: Reputation: 30
do you have discover running during startup? Or does your system load the oss driver during start-up before the alsa driver. that messed me up for a while. check /etc/modules for the oss driver to see if its getting loaded. if discover is installed there should be a file discover in /etc/init.d/
 
Old 10-14-2003, 05:35 PM   #3
dbkluck
Member
 
Registered: Jun 2003
Location: Washington DC
Distribution: debian sid
Posts: 78

Original Poster
Rep: Reputation: 15
what's discover? i don't remember that from the install. i do know that alsaconf for whatever reason refuses to detect my soundcard, i don't know why. (it's an intel 810, pretty common). i disabled the oss driver, and that didn't change anything. then i disabled "sound" too, and still no go. the weird thing is that sound appears to work, and presumably through the alsa drivers, since oss isn't loading, it's just the mixer that's broken, so i have to manually reset the volume on every reboot. in case it's helpful, here is the current output of lsmod:

snd-pcm-oss 39556 0 (autoclean)
snd-mixer-oss 13592 1 (autoclean) [snd-pcm-oss]
apm 10060 2 (autoclean)
snd-intel8x0 18916 1
snd-pcm 61092 0 [snd-pcm-oss snd-intel8x0]
snd-timer 14436 0 [snd-pcm]
snd-ac97-codec 41368 0 [snd-intel8x0]
snd-page-alloc 6420 0 [snd-intel8x0 snd-pcm]
snd-mpu401-uart 3328 0 [snd-intel8x0]
snd-rawmidi 13376 0 [snd-mpu401-uart]
snd-seq-device 4272 0 [snd-rawmidi]
snd 29636 0 [snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-pcm snd-timer snd-ac97-codec snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore 3844 4 [snd]
sg 28060 0 (unused)
ide-scsi 10288 0

anything missing that should be there (or there that shouldn't)?

thanks for the help,

dave
 
Old 10-14-2003, 09:50 PM   #4
padlamoij
Member
 
Registered: Oct 2002
Location: East Point, GA
Posts: 188

Rep: Reputation: 30
discover is just a program that autodetects what modules you need at startup... it doesn't come with stock debian, but i install it because i'm lazy. The oss driver isn't loading so thats not the problem anyhow. I don' have much alsa knowledge. Wierd though that alsaconf doesn't detect your soundcard. hmm.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
alsamixer: function snd_ctl_open failed for default: No such file or directory agts Linux - Newbie 16 04-01-2011 08:12 AM
alsamixer --> snd_ctl_open failed for default: No such device dot hog Linux - Software 3 08-23-2009 12:14 PM
alsamixer invalid argument subaruwrx Linux - Software 1 03-12-2005 01:34 PM
Sound problem: alsamixer: function snd_ctl_open failed for default: No such device bootlizard Linux - Software 0 08-22-2004 03:45 PM
Suse 9.1 wlan-ctl-ng wlan-cfg-DEFAULT oiper Linux - Wireless Networking 0 07-25-2004 02:32 AM


All times are GMT -5. The time now is 09:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration