LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-02-2004, 12:04 PM   #1
Guste
LQ Newbie
 
Registered: Nov 2003
Posts: 1

Rep: Reputation: 0
alsactl restore problem


Hi all,

I have build my own kernel 2.4.20 with acpi-patch and it works fine.
A few days ago I wanted to install ALSA (0.9+0beta12-3) and I found a document debian-install-alsa.txt on the web. After the installation I can play music with Kaboodle and Noatum but I don't hear any sound with KsCD.
Looking to find a solution for this problem I have checked the logs and found a problem with alsactl restore at boot time. Using the shell I get the following error message:

root@STEING-PC:/usr/src/modules/alsa-driver# alsactl restore
/usr/sbin/alsactl-0.9: set_control:638: control.1.iface is invalid

So I have taken a look at the /etc/asound.state which will be updated correctly by alsactl store:

state.card0 {
control.1 {
comment.access 'read write'
comment.type INTEGER
comment.range '0 - 31'
iface MIXER
name 'Master Playback Volume'
value.0 20
value.1 20
}
control.2 {
comment.access 'read write'
comment.type BOOLEAN
iface MIXER
name '3D Control - Switch'
value false
}

I think the problem is iface MIXER but I don't know how to fix it.
So I would be gratefull for any idea or comment!

Guste
 
Old 02-08-2004, 01:53 AM   #2
smith847be
Member
 
Registered: Jun 2003
Location: Hanover, New Hampshire, USA
Distribution: Debian Sid (Unstable)
Posts: 143

Rep: Reputation: 15
If you still have this problem, then here you go: I think this problem is simpler than you think - I think you just have something on mute. apt-get install alsamixergui. Run alsamixergui. that'll give you every muteable thing. KsCD uses aRTs for sound as well as the others, so it's no core sound problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alsactl restore problem on debian ferlopes Linux - Hardware 5 05-07-2005 02:43 PM
alsamixer settings won't stick, "alsactl restore" as root after song change apax Linux - Software 0 01-01-2005 10:07 AM
alsactl restore not working at boot rgiggs Slackware 4 07-14-2004 03:57 PM
alsactl and mocules.conf problem to restore/store values destin Slackware 4 04-03-2004 08:12 AM
Doing alsactl to restore mixer setings Maurice Arthur Linux - Software 0 11-11-2003 12:56 AM


All times are GMT -5. The time now is 10:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration