LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 10-20-2005, 05:31 PM   #1
Dagger907
LQ Newbie
 
Registered: Oct 2005
Posts: 10

Rep: Reputation: 0
Alsa problem, intel onboard


Hello!
My first post here at Linuxquestions!
Allright, I've been google'ing, swearing and such all day long, until I found out it would might be a smart thing to do, to post here. I've been reading on this forum aswell, and didnt find anything! The problem is this:
I compile ALSA(tried 1.09a\b and 1.0.10rc2), and install it, I do as usual, and type alsaconf. alsaconf finds my intel8x0 (Abit BH7-e mainboard) soundchip, and configures it, I choose to write it to modprobe.conf, but alsaconf doesent finish, and heres some of the errors(sorry if the font is to big, I dont know how to make it smaller, dont flame me :P):
"Debian:~# alsaconf
/etc/init.d/alsa: Warning: Directory /var/run/alsa is not present.
Unloading ALSA sound driver modules: (none loaded).
Building card database...


Running update-modules...
Loading driver...
WARNING: Error inserting snd (/lib/modules/2.6.12-1-386/acore/snd.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_timer (/lib/modules/2.6.12-1-386/acore/snd-timer.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_pcm (/lib/modules/2.6.12-1-386/acore/snd-pcm.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_ac97_codec (/lib/modules/2.6.12-1-386/pci/ac97/snd-ac97-codec.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting snd_intel8x0 (/lib/modules/2.6.12-1-386/pci/snd-intel8x0.ko): Unknown symbol in module, or unknown parameter (see dmesg)
Setting default volumes...


===============================================================================

Now ALSA is ready to use.
For adjustment of volumes, use your favorite mixer.

Have a lot of fun! "

Allright, Im about to use my favorite mixer, I type in our beloved "alsamixer" where I get "alsamixer: function snd_ctl_open failed for default: No such device or address".

I dont even have the number of all the things I've tried, so I appologize on front for that, and thank all you helping souls!

Thanks in advance,
Eyolv
 
Old 10-20-2005, 09:27 PM   #2
deepclutch
Member
 
Registered: Nov 2004
Distribution: Debian Testing+Sid
Posts: 694
Blog Entries: 1

Rep: Reputation: 32
Post

U might have gotten alsa.debs from debian site as the configs are may be a little diffrnt from
other distros.
 
Old 10-20-2005, 09:48 PM   #3
ssfrstlstnm
Member
 
Registered: Dec 2004
Location: IN, USA
Distribution: debian etch
Posts: 402

Rep: Reputation: 30
It seems you are using debian. You don't need to compile alsa. You can get it using apt-get:
Code:
apt-get install alsa-base alsa-utils alsa-oss
The errors that you are getting may be because you compiled alsa with a different version of gcc than what you kernel was compiled with. I'm guessing. Anyway it doesn't matter, just use apt to install alsa. Then you can run alsaconf again. After your card is configured you run alsamixer to adjust volume and alsactl store to remember mixer setting when you reboot.
 
Old 10-21-2005, 09:59 AM   #4
Dagger907
LQ Newbie
 
Registered: Oct 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Hello again, and thanks for the help so far.
I've allready tried apt-get to install alsa before, and did it again now, same errors.
And when I modprobe snd-intel8x0 I get
"WARNING: Error inserting snd (/lib/modules/2.6.12-1-386/acore/snd.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_timer (/lib/modules/2.6.12-1-386/acore/snd-timer.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_pcm (/lib/modules/2.6.12-1-386/acore/snd-pcm.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_ac97_codec (/lib/modules/2.6.12-1-386/pci/ac97/snd-ac97-codec.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting snd_intel8x0 (/lib/modules/2.6.12-1-386/pci/snd-intel8x0.ko): Unknown symbol in module, or unknown parameter (see dmesg)"
hehe!

The weird thing is, that it worked a few days ago, then I tried to install OSS, just for fun, then this happened.. I dont understand anything of this, I hope you guys do :P!
 
Old 10-21-2005, 10:35 AM   #5
Dagger907
LQ Newbie
 
Registered: Oct 2005
Posts: 10

Original Poster
Rep: Reputation: 0
I tried removing linux-headers-2.6.12-1-386, linux-source-2.6.12 module-init-tools, all alsa libraries and utils, and reinstall them all using apt-get, and still I get the same errors:
Debian:~# alsaconf
Unloading ALSA sound driver modules: (none loaded).
Building card database...


Running update-modules...
Loading driver...
WARNING: Error inserting snd (/lib/modules/2.6.12-1-386/acore/snd.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_timer (/lib/modules/2.6.12-1-386/acore/snd-timer.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_pcm (/lib/modules/2.6.12-1-386/acore/snd-pcm.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_ac97_codec (/lib/modules/2.6.12-1-386/pci/ac97/snd-ac97-codec.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting snd_intel8x0 (/lib/modules/2.6.12-1-386/pci/snd-intel8x0.ko): Unknown symbol in module, or unknown parameter (see dmesg)
Setting default volumes...
 
Old 10-21-2005, 11:01 AM   #6
ssfrstlstnm
Member
 
Registered: Dec 2004
Location: IN, USA
Distribution: debian etch
Posts: 402

Rep: Reputation: 30
Maybe you don't have alsa support in your kernel. Find the config file for your kernel. Probably something like /boot/.config

Then do this:

Code:
cat /boot/.config | grep alsa
Post the output.
 
Old 10-21-2005, 11:20 AM   #7
Dagger907
LQ Newbie
 
Registered: Oct 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Hello!
I dont get any output from that command at all, and when I manually searched the config file for "alsa", I didnt find anything either. Very weird! As I said earlier in the post, it worked yesterday before I tried to install OSS, just to check it out..

Last edited by Dagger907; 10-21-2005 at 11:53 AM.
 
Old 10-21-2005, 12:31 PM   #8
ssfrstlstnm
Member
 
Registered: Dec 2004
Location: IN, USA
Distribution: debian etch
Posts: 402

Rep: Reputation: 30
It seems that it doesn't want to install the sound modules. I am not sure why oss would mess things up. Do an lsmod just to make sure that you don't have the snd modules installed. If not, I am not sure what is wrong but I bet that a recompile of your kernel would fix things. Be sure to include support for alsa and do not include support for oss.
 
Old 10-21-2005, 03:16 PM   #9
Dagger907
LQ Newbie
 
Registered: Oct 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Well, Im trying to recompile my kernel, or I have recompiled it. But my problem is in the initrd.img file I think. I get theese errors:
Kernel panic - not syncing attempted to kill init /sbin/init : 432
modprobe : FATAL : could not load /lib/modules/2.6.12.1/modules.dep

Of course modules.dep is there, but the problem is that it cant read my reiserFS partition. mkinitrd -m reiserfs doesent work, as I get /usr/sbin/mkinitrd: line 1414: reiserfs: command not found error.

A little off topic, but I hope thats okey..

Best regards,

Eyolv
 
Old 10-21-2005, 04:08 PM   #10
ssfrstlstnm
Member
 
Registered: Dec 2004
Location: IN, USA
Distribution: debian etch
Posts: 402

Rep: Reputation: 30
How did you compile the kernel? There is a good description of how to do it the debian way here: http://www.linuxquestions.org/questions/showthread.php?s=&threadid=206992
 
Old 10-21-2005, 06:23 PM   #11
Dagger907
LQ Newbie
 
Registered: Oct 2005
Posts: 10

Original Poster
Rep: Reputation: 0
I downloaded the source. from www.kernel.org, followed this guide: http://kerneltrap.org/node/799.
Then i mkinitrd, and copied it to /boot, and used a program in the KDE menu, and added the new kernel in the GRUB menu.
 
Old 10-21-2005, 07:23 PM   #12
Dagger907
LQ Newbie
 
Registered: Oct 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Hello again!
I followed the guide, and it worked! Thanks alot man, really appreciate it!

Peace
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA problem, 3.1 sarge, nvidia onboard audio 2.6.8 kernel tsiMental Debian 2 01-19-2006 04:12 PM
Unable to install intel onboard soundcard using ALSA spariggio82 Linux - Hardware 2 09-23-2005 02:22 AM
ALSA Problem with Intel Onboard Sound bjmurph Linux - Hardware 3 09-26-2004 06:38 PM
problem with sound device on alsa 0.90rc8 with onboard c-media LavaDevil94 Linux - Hardware 0 11-15-2003 04:04 PM
intel 845 gl graphics and cmi9738 onboard sound problem lvgandhi Linux - Newbie 16 08-07-2003 03:29 AM


All times are GMT -5. The time now is 11:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration