Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Debian This forum is for the discussion of Debian Linux.


  Search this Thread
Old 04-03-2013, 09:17 AM   #1
Registered: Nov 2009
Location: UK
Distribution: Gentoo
Posts: 472

Rep: Reputation: 41
Alsa not outputting sound

Helped a friend get Debian Testing (Wheezy) set up on his laptop and all appears to be working fine, except that Alsa is not outputting any audio.

lspci (with grep audio) outputs the following details about the available sound devices
00:01.1 Audio device: Advanced Micro Devices [AMD] nee ATI BeaverCreek HDMI Audio [Radeon HD 6500D and 6400G-6600G seres]
00:14.2 Audio device: Advanced Micro Devices [AMD] FCH Azalia Controller (rev 01)
And when trying to play one of the Alsa audio samples with aplay, it outputs:
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
aplay: main:682: audio open error: No such file or directory
In the alsa mixer there are two devices, one of which has only a single switch in the xfce-mixer but no controls, while the second has various controls - all of which are unmuted and at full volume, but still no sound is being produced
Old 04-03-2013, 09:45 AM   #2
Registered: Oct 2012
Distribution: OpenSuSE,RHEL,Fedora,OpenBSD
Posts: 979
Blog Entries: 2

Rep: Reputation: 235Reputation: 235Reputation: 235
Did you search the site for other threads on this?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 12 + ALC268 + Alsa-driver 1.0.18 = ALSA Error =No Sound (Tried erverything) morphynoman Slackware 9 12-04-2008 07:29 AM
Slackware 12 + ALC268 + Alsa-driver 1.0.18 = ALSA Error =No Sound (Tried erverything) morphynoman Linux - Hardware 2 11-12-2008 12:48 PM
Outputting Sound to both PCM and Speakers silent echo Linux - Newbie 3 10-28-2008 01:43 PM
alsa problem with 2 programs outputting sound librano Mandriva 3 04-18-2006 01:26 PM

All times are GMT -5. The time now is 08:18 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration