LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 09-24-2006, 09:32 AM   #1
ryzozwierz
LQ Newbie
 
Registered: Apr 2006
Location: lubelskie, Poland
Distribution: Debian Unstable
Posts: 6

Rep: Reputation: 0
alsa is always muted


Since one of last updates (i think it was libvolume-id0 update) my alsa is always muted after system reboot. I have to set up the alsamixer every time i switch on my computer. 'Alsactl store' doesn't work. What's wrong with this? I use Debian Unstable.

PS. Sorry for my English.
 
Old 09-24-2006, 11:08 AM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
That is odd. I would always do alsamixer and set volumes up. Then login as root and run the commnad ' alsactl store ' and then settings would be saved.

Might try to make a file in your home directory called .aumixrc. Here is mine.
vol:65:65:R
pcm:40:40:P
speaker:0:0:P
line:0:0:P
mic:0:0:P
cd:0:0:P
pcm2:0:0:P
igain:67:67:P
line1:0:0:P
dig1:100:100:P
phin:0:0:P
phout:0:0:P
video:0:0:P

Then you need to maybe load the sound with a command like this. aumix -L to load settings.

Brian1
 
Old 09-24-2006, 03:21 PM   #3
ryzozwierz
LQ Newbie
 
Registered: Apr 2006
Location: lubelskie, Poland
Distribution: Debian Unstable
Posts: 6

Original Poster
Rep: Reputation: 0
Is it necessary to install aumix? I'd rather not install this program.
 
Old 09-24-2006, 04:00 PM   #4
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Up to you, that is the way I do it. I am sure there are many other ways to do this. I would say other mixer apps would allow saving and loading of settings from a file.

Brian1
 
Old 09-25-2006, 12:58 PM   #5
PMorph
Member
 
Registered: Sep 2003
Distribution: Debian
Posts: 213

Rep: Reputation: 31
You might also try whether "apt-get install --reinstall alsa-utils" helps any.
 
Old 09-26-2006, 11:52 AM   #6
ryzozwierz
LQ Newbie
 
Registered: Apr 2006
Location: lubelskie, Poland
Distribution: Debian Unstable
Posts: 6

Original Poster
Rep: Reputation: 0
There has been a libvolume-id0 update and now everything is ok.
 
  


Reply

Tags
alsa, debian, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA, sound always muted after reboot. repe Slackware 5 11-14-2006 02:48 PM
alsa muted through OSS ? qwijibow Linux - General 0 11-13-2004 09:28 PM
ALSA Booting Up Muted AFI_Flame Slackware 7 07-02-2004 05:46 PM
How do I change the default muted alsa setting in Core 2? enderjm Fedora 6 04-08-2004 01:35 PM
alsa always starts muted true_atlantis Slackware 3 01-13-2004 07:42 PM


All times are GMT -5. The time now is 10:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration