LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   alsa is always muted (http://www.linuxquestions.org/questions/debian-26/alsa-is-always-muted-486476/)

ryzozwierz 09-24-2006 09:32 AM

alsa is always muted
 
Since one of last updates (i think it was libvolume-id0 update) my alsa is always muted after system reboot. I have to set up the alsamixer every time i switch on my computer. 'Alsactl store' doesn't work. What's wrong with this? I use Debian Unstable.

PS. Sorry for my English.

Brian1 09-24-2006 11:08 AM

That is odd. I would always do alsamixer and set volumes up. Then login as root and run the commnad ' alsactl store ' and then settings would be saved.

Might try to make a file in your home directory called .aumixrc. Here is mine.
vol:65:65:R
pcm:40:40:P
speaker:0:0:P
line:0:0:P
mic:0:0:P
cd:0:0:P
pcm2:0:0:P
igain:67:67:P
line1:0:0:P
dig1:100:100:P
phin:0:0:P
phout:0:0:P
video:0:0:P

Then you need to maybe load the sound with a command like this. aumix -L to load settings.

Brian1

ryzozwierz 09-24-2006 03:21 PM

Is it necessary to install aumix? I'd rather not install this program.

Brian1 09-24-2006 04:00 PM

Up to you, that is the way I do it. I am sure there are many other ways to do this. I would say other mixer apps would allow saving and loading of settings from a file.

Brian1

PMorph 09-25-2006 12:58 PM

You might also try whether "apt-get install --reinstall alsa-utils" helps any.

ryzozwierz 09-26-2006 11:52 AM

There has been a libvolume-id0 update and now everything is ok.


All times are GMT -5. The time now is 09:55 PM.