LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   All about VESA (http://www.linuxquestions.org/questions/debian-26/all-about-vesa-744657/)

sandbish 08-03-2009 12:11 AM

All about VESA
 
I am really a beginner in linux and I wonder if somebody helps me to understand the details about vesa and its different modes

GrapefruiTgirl 08-03-2009 12:26 AM

http://www.vesa.org/
http://en.wikipedia.org/wiki/VESA

Hi there, Welcome to LQ!

Your question is rather vague, and potentially covers a lot of territory. I recommend doing some reading at one of the above links first, and/or if you have a more specific question pertaining to your Linux, or your video hardware, or just further questions, please ask more specifically about what you want to know. :)

Thanks,
Sasha

sandbish 08-03-2009 12:52 PM

sorry for not being specific...actually I have been trying to start with Debian lenny, but in i386 and amd-64 bith versions....after installation...the graphics is just not coming ..rather just showing Sync out of range error...i hv tried with vga=0x317(not knowing its actual meaning) bt still its nt working...dats why I asked wheather it can be fixed in this way or not??

BigVig 08-04-2009 01:23 PM

Try editing your xorg.conf
 
Quote:

Originally Posted by sandbish (Post 3629785)
Sync out of range error...

I would suggest booting in single user mode and editing your xorg.conf file. When I have had Sync out of range errors in the recent past, the horizontal and vertical refresh rates in my xorg.conf file have been incorrect.

Boot into single user mode and edit your xorg.conf file. The path is probably /etc/X11/xorg.conf.

First, back up the file by saving it as 'xorg.conf.bak' or something. That's important.

Then, open the file in nano or vim or vi or whichever editor you prefer.

Somewhere in the file, you should see a section that looks like this:

Code:

Section "Monitor"
        Identifier  "Monitor0"
        VendorName  "Monitor Vendor"
        ModelName    "Monitor Model"
        HorizSync    30-107
        VertRefresh  48-120
EndSection

Replace the 'HorizSync' and 'VertRefresh' values with the ranges for your monitor. You should be able to find those ranges in the manual for your monitor, or on the manufacturer's website. Save the file and reboot.

If we have done everything correctly, your monitor will simply display your normal login screen and everything will be fine.

If anyone more knowledgeable has corrections, suggestions, answers or better advice than above, please, please share it below.

sandbish 08-05-2009 12:19 AM

Thanks a lot BigVig but I have already tried to do that using nano but couldn't find any xorg.conf file in the appropriate location.

the trooper 08-05-2009 08:26 AM

By default the xorg.conf file is empty after install on Debian and other distro's now.
So to modify settings you need to generate the file manually.
I posted how to do it on another thread:

http://www.linuxquestions.org/questi...ig-file-743438

And the file is located at /etc/X11/xorg.conf.

sandbish 08-05-2009 12:49 PM

sorry trooper..I am not being able to find it...can u please tell me the name of the thread ..I think its under newbie

GrapefruiTgirl 08-05-2009 01:08 PM

vga= -- framebuffer option?
 
Quote:

Originally Posted by sandbish (Post 3629785)
I have tried with vga=0x317 (not knowing its actual meaning) but still it's not working.

If I may, I want to try to clarify for the benefit of the OP & other members reading this thread.

The bold option looks to me to be a LILO or GRUB type of option, which sets the framebuffer vga mode while booting. It is NOT anything to do with Xorg, xorg.conf, or the graphical Desktop Environment one might have after logging into X.

If I'm wrong here, please someone do correct me, as it may well apply differently, or in more than one way, on a Debian system.

Sasha

the trooper 08-05-2009 01:34 PM

Quote:

The bold option looks to me to be a LILO or GRUB type of option, which sets the framebuffer vga mode while booting
Looks like a kernel boot parameter to me.
Like you would use to try and boot a problematic machine.


Quote:

i hv tried with vga=0x317(not knowing its actual meaning)
This is the worrying part,not sure where the op got this from.
The 'sync out of range error' that BigVig is referring to will need access to the xorg.conf file,hence why i posted how to generate it.
Hope this helps to clarify?

the trooper 08-05-2009 01:41 PM

Quote:

Originally Posted by sandbish (Post 3632512)
sorry trooper..I am not being able to find it...can u please tell me the name of the thread ..I think its under newbie

No need to apologise.I just tried the link i posted myself and as you say it takes you through to the newbie forum.
Not a problem,i'll post the details here:

Code:

ctrl-alt-f1
To exit the gui.
Login as root.

Code:

# /etc/init.d/gdm stop  (to stop gdm/kdm as required.)
# X -configure
# mv ~/xorg.conf.new /etc/X11/xorg.conf
# /etc/init.d/gdm start

You should now be back in the gui,but you need to logout as root:

Code:

ctrl-alt-f1 again.
ctrl-d
ctrl-alt-f7

Once you get to this point you should have a working xorg.conf file.

sandbish 08-05-2009 11:03 PM

vga=0x???
 
Thanx a lot..at last I hv become able to get the solution and now lenny is working good...but I still wonder what does the number mean actually i.e. 317..I hv found that different numbers can be used in the same format...can any of you please explain this??

rerushg 08-06-2009 01:38 AM

Quote:

Originally Posted by sandbish (Post 3633086)
Thanx a lot..at last I hv become able to get the solution and now lenny is working good...but I still wonder what does the number mean actually i.e. 317..I hv found that different numbers can be used in the same format...can any of you please explain this??

Without a lot of information we are all just guessing what you want to know. The "0x317" is a format for calling a VESA framebuffer mode at boot. I assume that you are seeing this early in the boot process. You are simply seeing the system documenting the VESA mode it is using until the X system takes over.
"vga=0x317" is merely a format that the system recognizes and the "317" is taken as a hex number. It can also be specified as decimal number: "vga=791" which means exactly the same thing to the system (Note that 791 decimal = 317 hex). Both refer (in Linux) to 16-bit color @ 1024x768 resolution.
It can be changed manually by modifying the /boot/grub/menu.lst
The file itself shows an example.

More info here:
http://en.wikipedia.org/wiki/VESA_BIOS_Extensions
and here:
http://tldp.org/HOWTO/Framebuffer-HOWTO-5.html

Have fun! :)

the trooper 08-06-2009 08:27 AM

Quote:

Originally Posted by sandbish (Post 3633086)
Thanx a lot..at last I hv become able to get the solution and now lenny is working good...but I still wonder what does the number mean actually i.e. 317..I hv found that different numbers can be used in the same format...can any of you please explain this??

Can you post what you did to cure the problem?


Quote:

The bold option looks to me to be a LILO or GRUB type of option, which sets the framebuffer vga mode while booting
Well spotted GrapefruiTgirl!.
You were right.

Edit:This got me thinking,so i booted the Debian netinstall disc to check boot parameters.
The parameter i was thinking of is vga=771 which apparently is for laptops with screen display problems.Not quite what the op was using.

rerushg 08-06-2009 09:55 AM

Quote:

Originally Posted by the trooper (Post 3633501)
Can you post what you did to cure the problem?

Saw your edit too.
I'm hardly the expert here. I just had a problem with this a while back, figured out how to fix it, then moved on. There might be some chicken-scratch notes around here somewhere but the coffee cup rings have rendered them useless. :)

I think the "vga=foo" call-out starts when BIOS boots and is just a pass-through parameter beyond that. In my view the options to change it with grub or when starting the kernel are customization options rather than functional ones.

My guess is that the vga issue had nothing to do with the OP's problem and your xorg.conf script was what got him going. Can't blame him for that since it seems like it would be relevant. I think most of us who've spent a lot of time with goofy 'puter stuff have spent a fair amount of that time chasing the wrong gremlin. :)

mushroomboy 08-07-2009 04:12 PM

Even though it's fixed now, you could have installed your vid drivers and most of the time they come with a xorg config program. Like Nvidia has nvidia-xorg or something.


All times are GMT -5. The time now is 11:58 PM.