LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 11-13-2007, 11:31 AM   #1
lord_didger
Member
 
Registered: Jun 2005
Location: Poland
Distribution: Debian
Posts: 106

Rep: Reputation: 15
AIGLX: Screen 0 is not DRI capable


H1, I have recently reinstalled my Debian and upgraded it to lenny. Everything works properly except X server. There is only one error: "(EE) AIGLX: Screen 0 is not DRI capable". I googled around but no information was helpful. How can I fix it? Log is place below

Quote:
X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: Linux Debian (xorg-server 2:1.3.0.0.dfsg-12lenny1)
Current Operating System: Linux lord 2.6.22-2-686 #1 SMP Fri Aug 31 00:24:01 UTC 2007 i686
Build Date: 20 October 2007
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Nov 13 17:18:25 2007
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "SyncMaster"
(**) | |-->Device "nVidia Corporation NV31 [GeForce FX 5600]"
(**) |-->Input Device "Generic Keyboard"
(**) |-->Input Device "Configured Mouse"
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
Entry deleted from font path.
(WW) `fonts.dir' not found (or not valid) in "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType".
Entry deleted from font path.
(Run 'mkfontdir' on "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType").
(==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi
*
*
*
*
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension XAccessControlExtension
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(EE) AIGLX: Screen 0 is not DRI capable
(II) Loading local sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/lib/xorg/modules/extensions//libGLcore.so
(II) Module GLcore: vendor="X.Org Foundation"
compiled for 1.3.0, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.3
(II) GLX: Initialized MESA-PROXY GL provider for screen 0
(**) Option "CoreKeyboard"
(**) Generic Keyboard: Core Keyboard
(**) Option "Protocol" "standard"
(**) Generic Keyboard: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Generic Keyboard: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Generic Keyboard: XkbModel: "pc105"
(**) Option "XkbLayout" "pl"
(**) Generic Keyboard: XkbLayout: "pl"
(**) Option "CustomKeycodes" "off"
(**) Generic Keyboard: CustomKeycodes disabled
(**) Option "Protocol" "ImPS/2"
(**) Configured Mouse: Device: "/dev/input/mice"
(**) Configured Mouse: Protocol: "ImPS/2"
(**) Option "CorePointer"
(**) Configured Mouse: Core Pointer
(**) Option "Device" "/dev/input/mice"
(**) Option "Emulate3Buttons" "true"
(**) Configured Mouse: Emulate3Buttons, Emulate3Timeout: 50
(**) Configured Mouse: ZAxisMapping: buttons 4 and 5
(**) Configured Mouse: Buttons: 9
(**) Configured Mouse: Sensitivity: 1
(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
(II) XINPUT: Adding extended input device "Generic Keyboard" (type: KEYBOARD)
(II) Configured Mouse: ps2EnableDataReporting: succeeded
FreeFontPath: FPE "/usr/share/fonts/X11/misc" refcount is 2, should be 1; fixing.
 
Old 11-13-2007, 01:02 PM   #2
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
the easy way to just eliminate that error would be to comment out the load dri line in your xorg.conf

Code:
Section "Module"
        Load    "bitmap"
        Load    "ddc"
#       Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "vbe"
EndSection
There may be other options depending on what graphics controller you are using , what driver, etc..

Is X not starting for you ? That error alone shouldn't stop X from loading...
I have the same error in my logs and X is working just fine..

Code:
it-etch:/var/log# cat Xorg.0.log | grep EE
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
(EE) AIGLX: Screen 0 is not DRI capable


username@it-etch:~$ glxinfo | grep direct
direct rendering: No
OpenGL renderer string: Mesa GLX Indirect
 
Old 11-13-2007, 01:22 PM   #3
lord_didger
Member
 
Registered: Jun 2005
Location: Poland
Distribution: Debian
Posts: 106

Original Poster
Rep: Reputation: 15
The thing is that my xorg.conf is quite different

Quote:
Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "pl"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "Device"
Identifier "nVidia Corporation NV31 [GeForce FX 5600]"
Driver "nv"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "SyncMaster"
Option "DPMS"
HorizSync 30-81
VertRefresh 56-75
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV31 [GeForce FX 5600]"
Monitor "SyncMaster"
DefaultDepth 24
SubSection "Display"
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection
There is nothing like 'Load "dri"'

My X server is starting but only black screen appears.

My window manager is fluxbox. Can it cause this situation?

Last edited by lord_didger; 11-13-2007 at 01:28 PM.
 
Old 11-13-2007, 02:12 PM   #4
kabniel
LQ Newbie
 
Registered: Aug 2003
Location: Sweden
Distribution: Debian Squeeze
Posts: 27

Rep: Reputation: 15
You might want to try and turn off AIGLX in your xorg.conf to see if it changes anything.

Code:
Section "Serverflags"
        Option "AIGLX" "off"
EndSection
 
Old 11-13-2007, 03:08 PM   #5
lord_didger
Member
 
Registered: Jun 2005
Location: Poland
Distribution: Debian
Posts: 106

Original Poster
Rep: Reputation: 15
I have just tried it out but nothing happened.

There is one interesting thing. I added 'vga=771' to kenrel options in grub and now I can start X but not as root. I have to use another account to do so. Moreover, my fluxbox does not work. When X starts I can see only xterm and some free space around.

However, I am not sure that this change made X to work. I have removed and installed blackbox and fluxbox a few times to find out what is going on.

What else should I do to find the bug?
 
Old 11-13-2007, 07:45 PM   #6
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Ahh look at that. You have an nvidia Graphics card..

Installing the nvidia drivers would probably resolve your graphics issues, since the nvidia drivers DO support direct rendering..

X is NOT supposed to start as ROOT that is a security risk and is disabled by default. you shouldn't be running as root for your normal user either..

Code:
default@debianetch:~$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 6800/AGP/SSE2
OpenGL version string: 2.0.2 NVIDIA 87.76
Quick nvidia install for Debian if you have a recent card.. (if your card is an older Geforce like the Geforce 4 series you need the legacy drivers)

aptitude update
aptitude install module-assistant build-essentail
m-a prepare
m-a update
m-a a-i nvidia
aptitude install nvidia-glx


edit your xorg.config and change nv to nvidia
 
Old 11-14-2007, 03:33 AM   #7
lord_didger
Member
 
Registered: Jun 2005
Location: Poland
Distribution: Debian
Posts: 106

Original Poster
Rep: Reputation: 15
farslayer, you said 'X is NOT supposed to start as ROOT'. However, befor reinstalation of system, I could start X as root. It was not disabled. Moreover, there was no problem with X befor.
Of course I will try to install Nvidia driver. Then I will write result
 
Old 11-14-2007, 03:33 AM   #8
lord_didger
Member
 
Registered: Jun 2005
Location: Poland
Distribution: Debian
Posts: 106

Original Poster
Rep: Reputation: 15
farslayer, you said 'X is NOT supposed to start as ROOT'. However, befor reinstalation of system, I could start X as root. It was not disabled. Moreover, there was no problem with X befor.
Of course I will try to install Nvidia driver. Then I will write result
 
Old 11-14-2007, 02:16 PM   #9
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Just because it can be done, does not mean that it should be done.

Running the entire system with Admin/root privileges is the Windows default way of doing things which is inherently insecure.

Linux can be configured to operate that way, but why would anyone knowingly want to lower the security level of their machine ?
 
Old 11-14-2007, 04:49 PM   #10
lord_didger
Member
 
Registered: Jun 2005
Location: Poland
Distribution: Debian
Posts: 106

Original Poster
Rep: Reputation: 15
BTW. I'm glad that there is no hindrance in using X by default. There would be another problem to deal with.

Very interesting thing happened - X and fluxbox is working now properly. Why? I would like to know myself.

I tried newest fluxbox - X didn't worked, I installed older version - the same, I installed ntfs-3g and restarted my computer - X works. Then I installed nvidia driver - X still works. Additionally, there is no error in my Xorg.log. This is the end of Xorg.log

Quote:
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension XAccessControlExtension
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
(**) Option "CoreKeyboard"
(**) Generic Keyboard: Core Keyboard
(**) Option "Protocol" "standard"
(**) Generic Keyboard: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Generic Keyboard: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Generic Keyboard: XkbModel: "pc105"
(**) Option "XkbLayout" "pl"
(**) Generic Keyboard: XkbLayout: "pl"
(**) Option "CustomKeycodes" "off"
(**) Generic Keyboard: CustomKeycodes disabled
(**) Option "Protocol" "ImPS/2"
(**) Configured Mouse: Device: "/dev/input/mice"
(**) Configured Mouse: Protocol: "ImPS/2"
(**) Option "CorePointer"
(**) Configured Mouse: Core Pointer
(**) Option "Device" "/dev/input/mice"
(**) Option "Emulate3Buttons" "true"
(**) Configured Mouse: Emulate3Buttons, Emulate3Timeout: 50
(**) Configured Mouse: ZAxisMapping: buttons 4 and 5
(**) Configured Mouse: Buttons: 9
(**) Configured Mouse: Sensitivity: 1
(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
(II) XINPUT: Adding extended input device "Generic Keyboard" (type: KEYBOARD)
(II) Configured Mouse: ps2EnableDataReporting: succeeded
(II) NVIDIA(0): Setting mode "1024x768"
(II) NVIDIA(0): Setting mode "1280x1024"
and xorg.conf

Quote:
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
EndSection

#Section "ServerFlags"
# Option "AIGLX" "off"
#EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "pl"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"

Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "Monitor"
Identifier "SyncMaster"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "nVidia Corporation NV31 [GeForce FX 5600]"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV31 [GeForce FX 5600]"
Monitor "SyncMaster"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
Have you any idea what the problem was? I suppose the bug could have been in configuration of fluxbox, because once I (while reinstalling of the package) get information that session.screen0... is improper or something similiar.

Last edited by lord_didger; 11-14-2007 at 04:56 PM.
 
Old 08-12-2008, 02:07 PM   #11
mpve
LQ Newbie
 
Registered: Aug 2008
Posts: 1

Rep: Reputation: 0
Problem solved

I had this same problem.

I found out following:
---I could login using the console
---In the console I could start kdm using root
---Then I could NOT start X as it gave me this error message back
---To start X I needed to be root (this is a security breach!) but I did it
---Then X started and all seemed to work but after a few actions done (no matter what) the system freezed

My problem was that I could not write to the /home folder as it was full! I deleted some files and all worked fine again without this problem!

So you might have this problem too. Use df on the command prompt and see if the file system is not full anywhere.
 
  


Reply

Tags
aiglx, dri


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dri and AIGLX errors with fglrx fifteen10e56 Linux - Software 0 02-08-2007 06:13 PM
Mesa linux-dri or linux-dri-x86 Won't Make Muraii Linux - Desktop 2 09-15-2006 01:19 AM
Can't use DRI and aiglx at the same time spuzzzzzzz Fedora 1 03-26-2006 03:00 PM
Unichrome DRI causes screen to go blank Lord Estraven Linux - Hardware 3 09-04-2005 07:11 AM
It's cron capable to do this? graveworm Linux - Software 1 09-27-2004 07:18 AM


All times are GMT -5. The time now is 03:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration