LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   After installing KDE 4.4.5 on Debian Squeeze wireless will not connect (http://www.linuxquestions.org/questions/debian-26/after-installing-kde-4-4-5-on-debian-squeeze-wireless-will-not-connect-906222/)

RayGo75 10-03-2011 01:48 PM

After installing KDE 4.4.5 on Debian Squeeze wireless will not connect
 
I am running the latest Debian squeeze (stable) on an old HP Laptop with a Broadcom B4318 wireless card. I have the correct drivers and if I boot into my GNOME desktop environment the wireless card works just fine. However I like the KDE desktop better so I installed that and now if I boot into KDE my wireless network card will not connect to my wireless network.

Output from iwconfig (KDE):
Quote:

root@debbie:/home/raygo# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:off/any
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

pan0 no wireless extensions.
Output from ifconfig wlan0 (KDE):
Quote:

root@debbie:/home/raygo# ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr 00:14:a5:72:7e:51
inet6 addr: fe80::214:a5ff:fe72:7e51/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:1922 errors:0 dropped:0 overruns:0 frame:0
TX packets:1065 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:821012 (801.7 KiB) TX bytes:202350 (197.6 KiB)
If there is any other information needed just ask. In the mean time I guess I will just have to use the GNOME desktop.

One other thing I do not see the network icon in the system tray on either desktop and in looking at other posts I should see a network icon on the KDE desktop.

All help is appreciated.

RayGo75 10-03-2011 02:02 PM

correction
 
I am sorry I do see a network icon on my GNOME desktop but there is no network icon on the KDE desktop. I need to open my eyes.

62chevy 10-03-2011 07:09 PM

I'm going to go out on a limb here and believe you have Network Manager installed. In Gnome you would go to System>Preferences>Startup Applications to make sure Network Manager Starts when you log in. I don't use KDE but would think it has a similar system for starting programs when you log in.

Sorry I can't be more helpful but maybe someone will stop by and tell you where to look in the menus.

cryingthug 10-03-2011 07:36 PM

wireless????
 
RayGo75,

You may have had something take over the wlan0 connection settings you had previously. You have some options.

1.Reconfigure network-manager if that is what you were using before, disable everything else.
2.You can use Wicd as a network manager instead (I like it better than network-manager).
3.Configure it using the command line (Not so easy. But possible. I managed to do it).
4.Use the cable. It is way faster that wireless! (Do some tests downloading the same file. Once with the wireless connection and then using the cable. Compare the speeds and be amazed!)

jlinkels 10-03-2011 08:56 PM

Check /etc/network/interfaces and see that the wlan0 interface is commented out everywhere.

Make sure networkmanager has started. If not, start it manually. KDE4 has its own ideas whether or not it should start a service you told it to.

One you have networkmanager opened, delete the connection you try to use and re-create.

Other than that, I have seen networkmanager being extremely reliable on a variety of hardware.

jlinkels

Knightron 10-06-2011 02:03 AM

Just so you know, gnome and kde both can use networkmanager, but they use different applets to do so, and therefor have different icons. Gnomes is called, "network-manager-gnome", and kdes is called network-manager-kde. Point is, the icon will look different in kde. If i can remember correctly, it looks like a Ethernet port hole. Look down to your bottom right in your panel, in the system tray for it. I use kde but hate there network manager applet as it doesn't seem to have the capabilities of gnomes. I use mobile broadband and can't get it to work with kdes. If you still can't get wireless to work after the good people of this forum help you out, you can try the approach i use. Use the gnome network manager in kde. First uninstall the kde plasmoid network manager. (This step can be skipped obviously if you honestly don't have it) in the terminal, su to root and run,
Code:

aptitude remove network-manager-kde plasma-widget-networkmanagement
. This will remove the kde plasmoid network manager. Now open up kdes 'System Settings', go to the advanced tab up top, then to 'Autostart', press the 'add program button, type 'nm-applet' and press ok, restart and gnomes network manager applet should be down in your system tray.

Good luck

RayGo75 10-06-2011 07:52 AM

Thank you
 
Thank you for all the replies.
I got it to work by starting knetworkmanager from Applications/System/Networkmanager and then deleting my wireless network and reconfiguring it. Now I just have to get it to startup automatically but I think I know how to do that.


All times are GMT -5. The time now is 06:52 AM.