LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 02-06-2013, 02:10 AM   #1
propofol
Member
 
Registered: Nov 2007
Location: Seattle
Distribution: Debian Wheezy & Jessie; Ubuntu
Posts: 287

Rep: Reputation: 54
[Solved]Debian multiarch conflicts


I have recently added multiarch support to my Wheezy am64 with:
Quote:
dpkg --add-architecture i386 && aptitude update
When I try to install google-earth I get the following error:
Quote:
aptitude install google-earth-stable
The following NEW packages will be installed:
freeglut3:i386 google-earth-stable ia32-libs{a} ia32-libs-i386:i386 lesstif2:i386 libacl1:i386 libaio1:i386
libasound2:i386{a} libasyncns0:i386 libattr1:i386{a} libaudio2:i386 libaudiofile1:i386 libbsd0:i386 libcaca0:i386{a}
...
libxp6:i386{a} libxpm4:i386{a} libxslt1.1:i386 libxss1:i386 libxt6:i386{a} libxtst6:i386{a} libxv1:i386 odbcinst{a}
odbcinst1debian2{a} odbcinst1debian2:i386 uuid-runtime{a} xaw3dg:i386

...

The following packages have unmet dependencies:
libjack0 : Conflicts: libjack-0.116:i386 which is a virtual package.
libjack-jackd2-0:i386 : Conflicts: libjack-0.116 which is a virtual package.
Conflicts: libjack0 but 1:0.121.3+20120418git75e3e20b-2.1 is installed.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
The following actions will resolve these dependencies:

Remove the following packages:
1) avidemux-cli
2) avidemux-plugins
3) avidemux-qt
4) binreader
5) espeak
6) ffmpeg
7) gpac
...
38) xvidenc
This seems to want to remove a range of amd64 programs which I would like to keep.

Is this a conflict between the amd64 & the i386 libraries? Is there any way to install google-earth without disrupting my existing programs?

Regards,
Stefan

Last edited by propofol; 02-07-2013 at 01:25 AM.
 
Old 02-06-2013, 09:23 PM   #2
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,857

Rep: Reputation: 617Reputation: 617Reputation: 617Reputation: 617Reputation: 617Reputation: 617
Have you tried apt-get install?

Have you tried dpkg -i?

Have you tried gDebi?

Just wondering if this is more a thing with aptitude than with dependencies.
 
1 members found this post helpful.
Old 02-06-2013, 10:59 PM   #3
propofol
Member
 
Registered: Nov 2007
Location: Seattle
Distribution: Debian Wheezy & Jessie; Ubuntu
Posts: 287

Original Poster
Rep: Reputation: 54
Thanks for the reply.

Quote:
apt-get install google-earth-stable:i386
gives me this:

Code:
The following packages have unmet dependencies:
 google-earth-stable:i386 : Depends: lsb-core:i386 (>= 3.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

....
                                                             
# apt-get install  lsb-core:i386 

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 lsb-core:i386 : Depends: lsb-invalid-mta:i386 (>= 4.1+Debian8) but it is not installable or
                          mail-transport-agent:i386
                 Depends: bc:i386 but it is not going to be installed
                 Depends: binutils:i386 but it is not going to be installed
                 Depends: bsdmainutils:i386 but it is not going to be installed
                 Depends: cpio:i386 but it is not going to be installed
                 Depends: make:i386 but it is not going to be installed
                 Depends: psmisc:i386 but it is not going to be installed
                 Depends: alien:i386 (>= 8.36) but it is not installable
                 Depends: python:i386 (>= 2.6.6-7~) but it is not installable
                 Depends: time:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
All the packages are there when I do a search, I can't work out why it does not install the required files.

Quote:
dpkg -i ./google-earth-stable_current_amd64.deb
results in this error:

Code:
dpkg: dependency problems prevent configuration of google-earth-stable:
 google-earth-stable depends on ia32-libs; however:
  Package ia32-libs is not installed.

dpkg: error processing google-earth-stable (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for man-db ...
Processing triggers for menu ...
Errors were encountered while processing:
 google-earth-stable
So now I am back at the ia32-libs catastrophe. I was under the impression that multiarch replaces ia32-libs.

Regards,
Stefan
 
Old 02-06-2013, 11:30 PM   #4
odiseo77
Senior Member
 
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 1,016

Rep: Reputation: 314Reputation: 314Reputation: 314Reputation: 314
If you have some repository for Google Earth, try installing the amd64 version, not the i386 one, like this:

Code:
apt-get install google-earth-stable
Either the above, or install ia32-libs with apt-get and after that attempt to reinstall the version of Google Earth you downloaded, with dpkg:

Code:
apt-get install ia32-libs
dpkg -i google-earth-stable_current_amd64.deb
I'm also under the impression that multiarch replaces ia32-libs, but some programs might still need them, like Google Earth (ia32-libs is listed as 'oldlibs' for Wheezy and Sid at packages.debian.org).

Regards.
 
1 members found this post helpful.
Old 02-07-2013, 01:24 AM   #5
propofol
Member
 
Registered: Nov 2007
Location: Seattle
Distribution: Debian Wheezy & Jessie; Ubuntu
Posts: 287

Original Poster
Rep: Reputation: 54
Thanks for the advice. I think you were right, it seems it was a problem with aptitude. This fixed it for me:

Code:
apt-get -f install
apt-get install ia32-libs-i386
The next problem was:
Quote:
./googleearth-bin: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
The library was located in /usr/lib/mesa-diverted/x86_64-linux-gnu/libGL.so.1 [libgl1-mesa-glx:i386]

I saw a suggestion that the 64 bit libraries are first on the list so I tried:
Code:
export LD_LIBRARY_PATH=/usr/lib/mesa-diverted/i386-linux-gnu/:$LD_LIBRARY_PATH
google-earth
Hopefully this may be of use for someone else with the same problem.

I was somewhat surprised that a multiarch setup did not automatically check for correct (i386) libraries in the 1st place.

Regards,
Stefan
 
Old 02-07-2013, 02:20 AM   #6
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,857

Rep: Reputation: 617Reputation: 617Reputation: 617Reputation: 617Reputation: 617Reputation: 617
Hi Stefan, I'm glad it is sorted for you. The reason why I suggested the other methods is because I had a very similar issue with Skype on Debian Wheezy and I eventually had to dpkg -i after checking is multiarch was installed properly. Aptitude just wouldn't do it for me on one install yet on others I have not had that issue at all.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Finding i386 dependencies in Debian multiarch Spongmonkey Debian 2 01-30-2013 01:36 AM
Mozilla does not use acroread on Debian amd64 multiarch Envite Linux - Desktop 1 01-22-2013 07:29 AM
libmp3lame0 debian squeeze dependency "multiarch support" nepalnt21 Debian 1 04-11-2012 01:03 PM
LXer: Debian to offer MultiArch support with Debian Wheezy 7 in 2013 LXer Syndicated Linux News 0 08-11-2011 02:50 AM
opinions on multiarch DrAMac Debian 5 09-21-2008 09:09 PM


All times are GMT -5. The time now is 12:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration