LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > DamnSmallLinux
User Name
Password
DamnSmallLinux This forum is for the discussion of DamnSmallLinux.

Notices



Reply
 
Search this Thread
Old 11-23-2006, 08:13 PM   #1
johngreenwood
Member
 
Registered: Nov 2006
Location: Lancashire, United Kingdom
Distribution: Slackware 13
Posts: 243

Rep: Reputation: 31
DSL lilo install to partition instead of MBR


Hi everyone, I just installed DSL onto a small partition on my first hard drive, first I tried it without a bootloader, then tried to configure lilo from slackware to boot DSL, didn't work as there was no bootable image on the DSL partition. Next I installed lilo, but was not presented with an option to install to the DSL partition, and overwrote my MBR. So I had quite a lot of messing about to get it back how it was, but still can't boot DSL from lilo, due to the same "no bootable image" problem. So, I was just wondering, is there a way to install lilo/grub to the DSL partition instead of the MBR, and if so, how?

Thanks for your help

John
 
Old 11-23-2006, 09:02 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
You can use the DSL partition instead of the MBR as the BOOT= entry in your lilo.conf file. Then copy the first 255 bytes to a file, using the dd command and edit the windows BOOT.INI file to add an entry to chainload using this file. You can google for "NTLdr lilo.conf boot" for several howto's. This will use XP's ntldr.exe program to chainload linux using your linux mbr image file.
 
Old 11-23-2006, 10:18 PM   #3
johngreenwood
Member
 
Registered: Nov 2006
Location: Lancashire, United Kingdom
Distribution: Slackware 13
Posts: 243

Original Poster
Rep: Reputation: 31
Thanks for the reply jschiwal, but I think I have sorted it. I have set the lilo installed bt Slackware to load the kernel image(I think) from DSL. Aside from a few minor issues, it seems to be working now. Also, I don't even know how to do what you said(I am very new to this), but thanks anyway, I appreciate your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can not install lilo on MBR kazuya1977 Slackware - Installation 5 03-20-2006 01:14 AM
Installing winXP on other partition wipes my MBR....i want my lilo back!! theMonkeY Slackware 2 09-22-2004 07:30 AM
lilo MBR install problem nobu Slackware - Installation 5 04-04-2004 08:33 PM
Can't install lilo to MBR or floppy pele_smk Slackware 7 12-10-2003 05:46 PM
can't install lilo, mbr not compatible bulb Linux - Hardware 3 11-10-2003 11:13 PM


All times are GMT -5. The time now is 12:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration